Ir ao conteúdo
  • Cadastre-se
vitormendonca

Agendar consultas - visualg - complexo

Recommended Posts

Olá mundo, tudo certo?

Espero que alguém possa me ajudar, vamos lá.

 

Estou com um problema para resolver a respeito de um trabalho na faculdade.

Preciso desenvolver um código em PORTUGOL que execute um MENU para agendar consultas com diversos médicos, mostrando data, hora, especialização do médico, enfim. Precisa ser completo.

 

Programa solicita nome do paciente

Programa solicita especialidade médica desejada

Programa solicita que o paciente escolha o médico

Programa mostra datas e horas disponíveis para agendar a consulta com aquele médico

(OBS.: O horário não pode bater com o horário de outra consulta)

(OBS.: Cada consulta tem um intervalo de 45 minutos ou 1 hora se facilitar)

(OBS.: A clínica funciona de 8h as 18h de segunda a sexta)

Paciente seleciona a data e hora

Programa mostra confirmação contendo nome do paciente, nome e especialização do médico, data e hora da consulta.

Programa retorna para o menu inicial.

 

Estou estagnado na parte de datas e horas. Não consigo pensar uma maneira de fazê-lo. Exemplo: Como vou determinar os meses com 28, 29(ano bissexto), 30 ou 31 dias? E como mostrar apenas os dias e horários disponíveis para o paciente escolher sua consulta? Os horários escolhidos previamente por outros pacientes não podem aparecer para não causar conflito.

Se alguém puder me dar uma luz, será muito bem-vindo.

 

Segue parte do código que fiz. Está muito incompleto ainda, porém não sei mais como prosseguir a partir do "caso 1" no código abaixo..

algoritmo "Menu Clínico"
// Função : Efetuar o agendamente de consultas com o médico específico
// Autor : GRUPO 6 *****!
// Data : 11/14/2016
// Seção de Declarações
var
opcao1, cardio, opcao_cardio, neuro, opcao_neuro, nutri, opcao_nutri, geri, opcao_geri: inteiro
paciente: caractere
inicio
// Seção de Comandos
escreval ("==========================================================")
escreval ("||  OLÁ, SEJA BEM VINDO AO PERSONAL CONSULTA AGENDATOR  ||")
escreval ("==========================================================")
escreval ("Por favor, informe seu nome: ")
leia (paciente)
procedimento menu_inicial
inicio
escreval ("==========================================================")
escreval ("||               ESPECIALIZAÇÕES MÉDICAS!               ||")
escreval ("==========================================================")
escreval ("||1. Cardiologista                                      ||")
escreval ("||2. Neurologista                                       ||")
escreval ("||3. Nutricionista                                      ||")
escreval ("||4. Geriatra                                           ||")
escreval ("||5. SAIR                                               ||")
escreval ("==========================================================")
fimprocedimento
procedimento menu_cardio
inicio
escreval ("==========================================================")
escreval ("||                     CARDIOLISTAS                     ||")
escreval ("||======================================================||")
escreval ("||1. Dra. Cristiane Guedes Pita                         ||")
escreval ("||2. Dr. George Paulo Cobe Fonseca                      ||")
escreval ("||3. Voltar                                             ||")
escreval ("==========================================================")
fimprocedimento
procedimento menu_neuro
inicio
escreval ("==========================================================")
escreval ("||                    NEUROLOGISTAS                     ||")
escreval ("||======================================================||")
escreval ("||1. Dr. Carlos Trigueiro de Souza                      ||")
escreval ("||2. Dr. Antônio Tomás Turbano                          ||")
escreval ("||3. Voltar                                             ||")
escreval ("==========================================================")
fimprocedimento
procedimento menu_nutri
inicio
escreval ("==========================================================")
escreval ("||                    NUTRICIONISTAS                    ||")
escreval ("||======================================================||")
escreval ("||1. Mônica Cristina Salgado Galvão                     ||")
escreval ("||2. Fernanda Tarcélia de Oliveira Pinto                ||")
escreval ("||3. Voltar                                             ||")
escreval ("==========================================================")
fimprocedimento
procedimento menu_geri
inicio
escreval ("==========================================================")
escreval ("||                       GERIATRAS                      ||")
escreval ("||======================================================||")
escreval ("||1. Dr. Carlos Antonio Batista de Medeiros             ||")
escreval ("||2. Dr. Anceio Botelho Pinto                           ||")
escreval ("||3. Voltar                                             ||")
escreval ("==========================================================")
fimprocedimento
repita
   menu_inicial
   escreval ("Olá ", paciente,", por favor, escolha uma opção:")
   leia (opcao1)
   limpatela
   se opcao1>=6 então
      escreval ("**********************************************************")
      escreval ("*************OPÇÃO INVÁLIDA, TENTE NOVAMENTE**************")
      escreval ("**********************************************************")
   fimse
ate (opcao1=1) ou (opcao1=2) ou (opcao1=3) ou (opcao1=4) ou (opcao1=5)
escolha (opcao1)
caso 1
   repita
      menu_cardio
      escreval ("Digite o número referente ao seu médico de preferência: ")
      leia (opcao_cardio)
      limpatela
   ate opcao_cardio=3
caso 2
   menu_neuro
caso 3
   menu_nutri
caso 4
   menu_geri
caso 5
   escreval ("==========================================================")
   escreval ("|| Obrigado por utilizar o PERSONAL CONSULTA AGENDATOR! ||")
   escreval ("==========================================================")
fimescolha
fimalgoritmo

 

Gratidão e boas vibrações! <3

Editado por DiF
A citação não pode e não deve ser usada para códigos. Para isso use o botão CODE <>
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @vitormendonca.

 

1) Local "correto" das declarações

A declaração dos procedimento devem ficar acima do "início" principal...ou seja, logo após o "var". Basicamente descer o trecho lá de cima para após os procedimentos. (a não ser que exista algum motivo especial para ficar do jeito que está, é claro)

 

3 horas atrás, vitormendonca disse:

inicio
// Seção de Comandos
escreval ("==========================================================")
escreval ("||  OLÁ, SEJA BEM VINDO AO PERSONAL CONSULTA AGENDATOR  ||")
escreval ("==========================================================")
escreval ("Por favor, informe seu nome: ")
leia (paciente)

 

 

 

2) Sobre as datas

 

3 horas atrás, vitormendonca disse:

Estou estagnado na parte de datas e horas. Não consigo pensar uma maneira de fazê-lo. Exemplo: Como vou determinar os meses com 28, 29(ano bissexto), 30 ou 31 dias?

Vai depender como vai estruturar o armazenamento das consultas...  mas de um modo geral, você poderia ignorar os anos bissextos e dizer que todo mês tem 30 dias por enquanto.
 

 

3) Horários disponíveis / Horários agendados

 

3 horas atrás, vitormendonca disse:

E como mostrar apenas os dias e horários disponíveis para o paciente escolher sua consulta? Os horários escolhidos previamente por outros pacientes não podem aparecer para não causar conflito.

Mesma coisa... vai depender de como estruturar para armazenar esses informações...

 

***

 

Então, essas consultas é para um só paciente ou para vários?

 

Sugiro que inicialmente tente modelar para cadastrar as consultas sem se preocupar datas disponíveis ou mesmo se a data é válida.

 

No aguardo.

 

  • Curtir 3

Compartilhar este post


Link para o post
Compartilhar em outros sites

Opa, e aí @Simon Viegas , tudo bem?

Obrigado pela resposta companheiro.

 

Aparentemente eu estava tentando fazer do modo mais complicado. Conversei com meu professor e ele disse que não precisava mostrar as datas disponíveis para agendamento,apenas para o próprio usuário informar a data e a hora da consulta. Ele sugeriu que eu usasse vetores para isso, mas não tenho ideia de como empregá-los.

Caso a data e a hora informada pelo usuário fosse igual a outra, o programa precisa avisar e solicitar uma nova data e hora.

 

19 horas atrás, Simon Viegas disse:

Então, essas consultas é para um só paciente ou para vários?

 

São para vários. É um MENU onde o usuário irá informar a especialidade, o médico, a data e a hora. Ao efetuar a marcação precisa aparecer uma mensagem com a confirmação do agendamento e perguntar ao usuário se ele deseja agendar outra consulta. Caso sim voltar para o procedimento menu_inicial, caso não apenas finalizar.

 

Outra dificuldade que tenho é para voltar ao menu anterior e essa está me matando porque acredito que seja relativamente simples. Quando saio do menu_inicial (das especializações) e entro no procedimento que solicita a escolha do médico tem 3 opções. Quando o usuário digita a opção 3 eu gostaria que voltasse para o menu anterior, porém ele apenas mostra o menu anterior e finaliza. Veja abaixo onde acredito que esteja o problema.

 

23 horas atrás, vitormendonca disse:

escolha (opcao1)
caso 1
   repita
      menu_cardio
      escreval ("Digite o número referente ao seu médico de preferência: ")
      leia (opcao_cardio)
      limpatela
   ate opcao_cardio=3
caso 2
   menu_neuro
caso 3
   menu_nutri
caso 4
   menu_geri
caso 5
   escreval ("==========================================================")
   escreval ("|| Obrigado por utilizar o PERSONAL CONSULTA AGENDATOR! ||")
   escreval ("==========================================================")
fimescolha

 

 

Do "caso 2" ao "caso 4" está incompleto pois estava tentando terminar o caso 1 primeiro para ver como ia fazer os outros. Basicamente, terei apenas que copiar.

 

Valeu galera! Tenho bastante interesse nesse assunto e quero aprender mais sobre programação depois dessa matéria na faculdade. Faço Civil então vão cobrar só o básico, mas depois das provas vou começar a estudar C. Com certeza vou fazer parte do fórum constantemente.

Grande abraço e mais uma vez, gratidão!

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Atualizando:

 

Fiz algumas alterações mas nada significativo demais. Não sei se estou usando vetor e matriz de maneira correta.

Segue o código:

algoritmo "Menu Clínico"
// Função : Efetuar o agendamente de consultas com o médico específico
// Autor : GRUPO 6!
// Data : 11/14/2016
// Seção de Declarações
var
opcao1, opcao2, cardio, neuro, nutri, geri, mes, dia, hora,d, h : inteiro
paciente: caractere
jan_vet: vetor[1..30, 1..5] de inteiro

procedimento menu_inicial
inicio
escreval ("==========================================================")
escreval ("||               ESPECIALIZAÇÕES MÉDICAS!               ||")
escreval ("==========================================================")
escreval ("||1. Cardiologista                                      ||")
escreval ("||2. Neurologista                                       ||")
escreval ("||3. Nutricionista                                      ||")
escreval ("||4. Geriatra                                           ||")
escreval ("||5. SAIR                                               ||")
escreval ("==========================================================")
fimprocedimento

procedimento menu_cardio
inicio
escreval ("==========================================================")
escreval ("||                     CARDIOLISTAS                     ||")
escreval ("||======================================================||")
escreval ("||1. Dra. Cristiane Guedes Pita                         ||")
escreval ("||2. Dr. George Paulo Cobe Fonseca                      ||")
escreval ("||3. Voltar                                             ||")
escreval ("==========================================================")
fimprocedimento

procedimento menu_neuro
inicio
escreval ("==========================================================")
escreval ("||                    NEUROLOGISTAS                     ||")
escreval ("||======================================================||")
escreval ("||1. Dr. Carlos Trigueiro de Souza                      ||")
escreval ("||2. Dr. Antônio Tomás Turbano                          ||")
escreval ("||3. Voltar                                             ||")
escreval ("==========================================================")
fimprocedimento

procedimento menu_nutri
inicio
escreval ("==========================================================")
escreval ("||                    NUTRICIONISTAS                    ||")
escreval ("||======================================================||")
escreval ("||1. Mônica Cristina Salgado Galvão                     ||")
escreval ("||2. Fernanda Tarcélia de Oliveira Pinto                ||")
escreval ("||3. Voltar                                             ||")
escreval ("==========================================================")
fimprocedimento

procedimento menu_geri
inicio
escreval ("==========================================================")
escreval ("||                       GERIATRAS                      ||")
escreval ("||======================================================||")
escreval ("||1. Dr. Carlos Antonio Batista de Medeiros             ||")
escreval ("||2. Dr. Anceio Botelho Pinto                           ||")
escreval ("||3. Voltar                                             ||")
escreval ("==========================================================")
fimprocedimento

inicio
// Seção de Comandos
escreval ("==========================================================")
escreval ("||  OLÁ, SEJA BEM VINDO AO PERSONAL CONSULTA AGENDATOR  ||")
escreval ("==========================================================")
escreval ("Por favor, informe seu nome: ")
leia (paciente)

repita
   menu_inicial
   escreval ("Olá ", paciente,", por favor, escolha uma opção:")
   leia (opcao1)
   limpatela

   se opcao1>=6 então
      escreval ("**********************************************************")
      escreval ("*************OPÇÃO INVÁLIDA, TENTE NOVAMENTE**************")
      escreval ("**********************************************************")
   fimse

   escolha (opcao1)
   caso 1
      repita
         menu_cardio
         escreval ("Digite o número referente ao seu médico de preferência: ")
         leia (opcao2)
         se opcao2=1 então
            escreval ("Dra. Cristiane Guedes Pita escolhida com sucesso.")
            escreval ("Por favor, escolha o mês da consulta:")
            leia (mes)
                 escolha (mes)
                 caso 1
                 escreval ("Mês escolhido: Janeiro")
                 escreval ("Por favor, informe um dia útil do mês de Janeiro para ser atendido:")
                 leia (d)
                 escreval ("A Dra. Cristiane Guedes faz 5 atendimentos por dia, um por hora, iniciando a primeira consulta as 13h e a última as 17h.")
                 escreval ("Por favor, escolha qual horário deseja ser atendido:")
                 leia (h)
                 para d <- 1 ate 30 faca
                      para h <- 1 ate 5 faca
                      leia (jan_vet[d,h])
                      fimpara
                 fimpara
                 caso 2
                 caso 3
                 caso 4
                 caso 5
                 caso 6
                 caso 8
                 caso 9
                 caso 10
                 caso 11
                 caso 12
                 outrocaso
            limpatela
         ate opcao2=3
         escolha opcao2
         caso 1
         caso 2
         caso 3
            menu_inicial
         fimescolha
      caso 2
         menu_neuro
      caso 3
         menu_nutri
      caso 4
         menu_geri
      caso 5
         escreval ("==========================================================")
         escreval ("|| Obrigado por utilizar o PERSONAL CONSULTA AGENDATOR! ||")
         escreval ("==========================================================")
      fimescolha
   ate (opcao1=1) ou (opcao1=2) ou (opcao1=3) ou (opcao1=4) ou (opcao1=5)
fimalgoritmo

Ainda não está funcionando. Quando eu digito o dia e a hora da consulta ele armazena corretamente nas variáveis mas no próximo passo ele tira os valores que coloquei e iguala o dia e hora a 1.

 

Gostaria que ficasse armazenada da seguinte maneira:

Criei uma matriz [1..30, 1..5] onde [1..30] representa os dias do mes e [1..5] a quantidade de atendimentos que sera feito por dia, 1 por hora. Como eu disse, não sei se estou usando corretamente este conceito de matriz.

 

Qualquer ajuda será bem vinda!

Abraços!

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @vitormendonca.

 

Para agendar você pode verificar se na coordenada resultada na data e hora desejada já está ocupada ou não. Ou seja, se na posição tem "0" ou não. Se tiver zero, é por quê tem livre. Ai agenda. Se não tiver, é porque já está ocupada.

 

No aguardo.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não sei mesmo como fazer @Simon Viegas 

Acredito que não estou usando os vetores da maneira correta.

 

Veja se é assim que funciona.

 

Quero que o usuário informe o dia e a hora da visita.

 

Tendo um vetor [1..30,1..5]. Se o usuário informar o dia 10 e a hora 3, eu quero que essa informação fique armazenada na Linha 10, coluna 3..

 

Caso você tenha o VisualG na sua máquina, poderia testar esse código com o F8 (parte por parte) e me dizer alguma coisa?

 

caso 1
                 escreval ("Mês escolhido: Janeiro")
                 escreval ("Por favor, informe um dia útil do mês de Janeiro para ser atendido:")
                 leia (d)
                 escreval ("A Dra. Cristiane Guedes faz 5 atendimentos por dia, um por hora, iniciando a primeira consulta as 13h e a última as 17h.")
                 escreval ("Por favor, escolha qual horário deseja ser atendido:")
                 leia (h)
                 para d <- 1 ate 30 faca
                      para h <- 1 ate 5 faca
                      leia (jan_vet[d,h])
                      fimpara
                 fimpara

Quando peço para usuário informar o dia e a hora, eles ficam armazenados nas variáveis "d" e "h".

Mas quando chega na parte "para d<-1 ate 30 faca", a variável "d" perde o valor atribuído pelo usuário e recebe o valor 1 automaticamente, independente do dia informado pelo usuário.

 

Será que estou errando na estrutura de repetição "para, ate, faca"?

Obrigado +1 vez , camarada!

[]'s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @vitormendonca.

 

1) Uso de laço de repetição

5 minutos atrás, vitormendonca disse:

Será que estou errando na estrutura de repetição "para, ate, faca"?

Sim! Pois a coordenada é dada pela data e hora, ou seja, é específica. :)

 

**

2) Agendamento de consulta

8 minutos atrás, vitormendonca disse:

Tendo um vetor [1..30,1..5]. Se o usuário informar o dia 10 e a hora 3, eu quero que essa informação fique armazenada na Linha 10, coluna 3..

A coordenada resultada está em (10,3), logo vai acessar a posição (10,3), ou seja, "jan_vet[d,h]".

 

Ai você poderia armazenar algo que identifique o armazenamento, como por exemplo o nome... algo como:

jan_vet[d,h]<-paciente

 

 

3) Sobre ter vaga no horário

Basta verificar que na coordenada tem algo já armazenado ou não... então, quando não se cadastra nada na posição, qual valor vai está contido nele? (descubra)

Daí, se estiver com esse valor, está vago! Se tiver diferente, é porque está ocupado (claro).

 

***

 

No aguardo.

 

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Show! Valeu @Simon Viegas sua ajuda foi muito útil, entretanto, ainda não consegui finalizar 100%.

 

Vamos lá:

 

3 horas atrás, Simon Viegas disse:

1) Uso de laço de repetição

4 horas atrás, vitormendonca disse:

Será que estou errando na estrutura de repetição "para, ate, faca"?

Sim! Pois a coordenada é dada pela data e hora, ou seja, é específica. :)

 

Show! Esta parte resolvemos. Vou mandar o código abaixo para quem também tiver esta dúvida, dar uma olhada.

 

3 horas atrás, Simon Viegas disse:

2) Agendamento de consulta

4 horas atrás, vitormendonca disse:

Tendo um vetor [1..30,1..5]. Se o usuário informar o dia 10 e a hora 3, eu quero que essa informação fique armazenada na Linha 10, coluna 3..

A coordenada resultada está em (10,3), logo vai acessar a posição (10,3), ou seja, "jan_vet[d,h]".

 

Ai você poderia armazenar algo que identifique o armazenamento, como por exemplo o nome... algo como:


jan_vet[d,h]<-paciente

 

Esta ajuda foi indispensável. Obrigado mesmo.

 

3 horas atrás, Simon Viegas disse:

3) Sobre ter vaga no horário

Basta verificar que na coordenada tem algo já armazenado ou não... então, quando não se cadastra nada na posição, qual valor vai está contido nele? (descubra)

Daí, se estiver com esse valor, está vago! Se tiver diferente, é porque está ocupado (claro).

 

 

Aqui me perdi. Não tenho ideia de como fazer essa verificação em um vetor. Pode mandar um exemplo?

Eu verifiquei que quando se cria o vetor não tem nada armazenado em nenhuma posição. Estão todas em "branco". Tem algum comando que verifique se a posição está em branco ou precisa necessariamente ter algum dado preenchendo para efetuar a verificação?

 

Vou mandar abaixo como está ficando o código. Por favor, dê uma conferida.

.

adicionado 4 minutos depois

Por enquanto, só se pode agendar para a primeira especialização, primeiro médico, e no mês de Janeiro.
Estou tentando fazer este corretamente, depois irei copiando e alterando os termos.

 

Segue:

 

algoritmo "Menu Clínico"
// Função : Efetuar o agendamento de consultas com um médico específico.
// Autor : GRUPO 6!
// Data : 11/14/2016
// Seção de Declarações
var
opcao1, opcao2, cardio, neuro, nutri, geri, mes, dia, d, h : inteiro
continua, paciente: caractere
jan_vet: vetor[1..30, 1..5] de caractere


procedimento menu_inicial
inicio
escreval ("==========================================================")
escreval ("||               ESPECIALIZAÇÕES MÉDICAS!               ||")
escreval ("==========================================================")
escreval ("||1. Cardiologista                                      ||")
escreval ("||2. Neurologista                                       ||")
escreval ("||3. Nutricionista                                      ||")
escreval ("||4. Geriatra                                           ||")
escreval ("||5. SAIR                                               ||")
escreval ("==========================================================")
fimprocedimento

procedimento menu_cardio
inicio
escreval ("==========================================================")
escreval ("||                     CARDIOLISTAS                     ||")
escreval ("||======================================================||")
escreval ("||1. Dra. Cristiane Guedes Pita                         ||")
escreval ("||2. Dr. George Paulo Cobe Fonseca                      ||")
escreval ("||3. Voltar                                             ||")
escreval ("==========================================================")
fimprocedimento

procedimento menu_neuro
inicio
escreval ("==========================================================")
escreval ("||                    NEUROLOGISTAS                     ||")
escreval ("||======================================================||")
escreval ("||1. Dr. Carlos Trigueiro de Souza                      ||")
escreval ("||2. Dr. Antônio Tomás Turbano                          ||")
escreval ("||3. Voltar                                             ||")
escreval ("==========================================================")
fimprocedimento

procedimento menu_nutri
inicio
escreval ("==========================================================")
escreval ("||                    NUTRICIONISTAS                    ||")
escreval ("||======================================================||")
escreval ("||1. Mônica Cristina Salgado Galvão                     ||")
escreval ("||2. Fernanda Tarcélia de Oliveira Pinto                ||")
escreval ("||3. Voltar                                             ||")
escreval ("==========================================================")
fimprocedimento

procedimento menu_geri
inicio
escreval ("==========================================================")
escreval ("||                       GERIATRAS                      ||")
escreval ("||======================================================||")
escreval ("||1. Dr. Carlos Antonio Batista de Medeiros             ||")
escreval ("||2. Dr. Anceio Botelho Pinto                           ||")
escreval ("||3. Voltar                                             ||")
escreval ("==========================================================")
fimprocedimento

inicio
// Seção de Comandos

continua <- "S"

enquanto continua = "S" faca
   escreval ("==========================================================")
   escreval ("||  OLÁ, SEJA BEM VINDO AO PERSONAL CONSULTA AGENDATOR  ||")
   escreval ("==========================================================")
   escreval ("Por favor, informe o nome do paciente: ")
   leia (paciente)

   menu_inicial
   escreval ("Olá ", paciente,", por favor, escolha uma opção:")
   leia (opcao1)
   limpatela

   se opcao1>=6 então
      escreval ("**********************************************************")
      escreval ("*************OPÇÃO INVÁLIDA, TENTE NOVAMENTE**************")
      escreval ("**********************************************************")
   fimse

   escolha (opcao1)
   caso 1
      menu_cardio
      escreval ("Digite o número referente ao seu médico de preferência: ")
      leia (opcao2)
      se opcao2=1 então
         escreval ("Dra. Cristiane Guedes Pita escolhida com sucesso.")
         escreval ("Por favor, escolha o mês da consulta:")
         leia (mes)
              escolha (mes)
              caso 1
                   escreval ("Por favor, informe um dia para atendimento:")
                   leia (d)
                   escreval ("Cada consulta tem um intervalo de 1h.")
                   escreval ("Por favor, escolha um horário entre 1am e 5pm para ser atendido:")
                   leia (h)
                   jan_vet[d,h] <- paciente
                   limpatela
                   escreval ("============================================================")
                   escreval ("||Consulta agendada com sucesso. Veja informações abaixo: ||")
                   escreval ("||--------------------------------------------------------||")
                   escreval ("||Especialidade: Cardiologia                              ||")
                   escreval ("||Médico(a): Dra. Cristiane Guedes Pita	                ||")
                   escreval ("||Dia ",d ," de Janeiro de 2017 às ",h,"PM                ||")
                   escreval ("||Paciente: ", paciente, "                                ||")
                   escreval ("============================================================")
              fimescolha
      fimse

   caso 5
      escreval ("==========================================================")
      escreval ("|| Obrigado por utilizar o PERSONAL CONSULTA AGENDATOR! ||")
      escreval ("==========================================================")

   fimescolha
   
   escreval ("Deseja efetuar outro agendamento?")
   escreva ("S/N:")
   leia (continua)
fimenquanto
fimalgoritmo

Até logo!

[]'s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×