Ir ao conteúdo
  • Cadastre-se
anonymouatour

Visualg procedimento

Recommended Posts

Estou tentando colocar este procedimento no meu algoritmo para remover os rgs mas apresenta um error e n consigo achar alguem poderia me ajudar?  O error sempre cai na func<-""

procedimento Excluir()
var
{linha : inteiro //vetor}
i:inteiro
procura: caractere
achou : logico
apaga : caractere
inicio
Limpatela
//Cabecalho
Escreva("Digite o rg que deseja excluir.: ")
Leia(Procura)
Escreval("|---------|")
achou <- falso
Para i de 1 ate 100 Faca
Se (func[i] = Procura) então
achou <- verdadeiro
interrompa
FimSe
FimPara
Se achou então
Limpatela
//Cabecalho
Escreval("|	Confirma a exclusão do rg abaixo?	")
Escreval("|-----------------------------------------------------------------")
Escreval("| RG....: ", func[i])
Escreva("| [S] Sim [N] Não]")
Leia(apaga)
Se (apaga = "S") então
func[i] <- ""

Limpatela
//Cabecalho
Escreval("|	Registro Excluído com Sucesso	|")
Escreval("|----------------------------------------------------------------|")
FimSe
SeNao
Limpatela
//Cabecalho
Escreval("|	Nenhum Registro encontrado para Exclusão	|")
Escreval("|----------------------------------------------------------------|")
FimSe
fimprocedimento

 

adicionado 16 minutos depois

refiz e percebi q ele está removendo apenas o primeiro numero da posicao do vetor o que faço para q ele remova todos?

 

 

procedimento Excluir()
var
{linha : inteiro //vetor}
i:inteiro
procura: caractere
achou : logico
apaga : inteiro
inicio
Limpatela
//Cabecalho
Escreva("Digite o rg que deseja excluir.: ")
Leia(Procura)
Escreval("|---------|")
achou <- falso
// para i de 1 ate 100 faca
 para total de 1 ate 100 faca
{Para total de 1 ate 100 Faca  }
Se (func[total] = Procura) então
achou <- verdadeiro
interrompa
FimSe
FimPara
Se achou então
Limpatela
//Cabecalho
Escreval("|	Confirma a exclusão do rg abaixo?	")
Escreval("|-----------------------------------------------------------------")
Escreval("| RG....: ", func[total])
//Escreva("| [S] Sim [N] Não]")
//Leia(apaga)
Se (apaga = "S") então
func[total] <- apaga

Limpatela
//Cabecalho
Escreval("|	Registro Excluído com Sucesso	|")
Escreval("|----------------------------------------------------------------|")
FimSe
fimse

//SeNao
Limpatela

fimprocedimento

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@anonymouatour Posta aqui como conseguiu resolver o problema!

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@anonymouatour Peço novamente  por gentileza que poste aqui como resolveu o problema

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Assim que tiver tempo irei postar pois estou fazendo um monte de projetos agora e ainda vou querer adicionar mais algumas coisinhas depois para brincar um pouco mais nesse algoritmo, espero que me compreenda abs

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

Aqui o excluir tava fazendo prova sem tempo


procedimento Excluir()

var

i:inteiro

procura: inteiro

achou : logico

apaga : INTEIRO

 

inicio

Limpatela

Escreva("Digite o RG que deseja excluir.: ")

Leia(procura)

Escreval("|---------|")

achou <- falso

para i de 1 ate 100 faca

Se (func = procura) então 

achou <- verdadeiro 

interrompa 

FimSe 

FimPara 

Se achou então 

Limpatela 

Escreval("|         Confirma a exclusão do RG abaixo?       ") 

Escreval("|-------------------------------------") 

Escreval("| RG....: ", func) 

func <- apaga 

Escreval("| RG....: ", func) 

Limpatela 

escreval("|        Registro Excluído com Sucesso |") 

fimse 

Limpatela 

escreval 

aguardarENTER 

fimprocedimento 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×