Ir ao conteúdo
  • Cadastre-se
Whillis

Como ver a média de um vetor!?

Recommended Posts

 Olá, estou fazendo um trabalho de linguagem de programação no visualg

e precisava saber como se faz a média de um vetor

(que no caso seria o VetorB).

 Estou com problemas nessa última estrutura "para" :

Var
vetorA: vetor [1..10] de inteiro
VetorB: vetor [1..10] de inteiro
i:inteiro
num:inteiro
media:real
result:real

Inicio
i<-1
Para i de 1 ate 10 faca
 Leia(num)
 vetorA [i]<-num
 i<-i+1
Fimpara

escreval("")
escreval("calculando o dobro...")
escreval("")

para i de 1 ate 10 faca
timer (50)
VetorB[i] <- VetorA[i] * 2
escreva(VetorB[i])
fimpara

para i de 1 ate 10 faca
media <- VetorB[i] + VetorB[i]
result <- media/10
fimpara

Fimalgoritmo

agradeço desde ja

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Whillis

O result deve ficar fora do laço de repetição, afinal não faz sentido você calcular a média 10 vezes.

Você vai pegar a soma que foi gerada no laço de repetição e dividir por 10.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 horas atrás, Math.Pi disse:

@Whillis

O result deve ficar fora do laço de repetição, afinal não faz sentido você calcular a média 10 vezes.

Você vai pegar a soma que foi gerada no laço de repetição e dividir por 10.

 Oh obrigado mesmo

n sei como q n enxerguei um problema tão simples :D

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×