Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Whillis

Como ver a média de um vetor!?

Recommended Posts

 Olá, estou fazendo um trabalho de linguagem de programação no visualg

e precisava saber como se faz a média de um vetor

(que no caso seria o VetorB).

 Estou com problemas nessa última estrutura "para" :

Var
vetorA: vetor [1..10] de inteiro
VetorB: vetor [1..10] de inteiro
i:inteiro
num:inteiro
media:real
result:real

Inicio
i<-1
Para i de 1 ate 10 faca
 Leia(num)
 vetorA [i]<-num
 i<-i+1
Fimpara

escreval("")
escreval("calculando o dobro...")
escreval("")

para i de 1 ate 10 faca
timer (50)
VetorB[i] <- VetorA[i] * 2
escreva(VetorB[i])
fimpara

para i de 1 ate 10 faca
media <- VetorB[i] + VetorB[i]
result <- media/10
fimpara

Fimalgoritmo

agradeço desde ja

Editado por Whillis
inseri programa utilizado
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Whillis

O result deve ficar fora do laço de repetição, afinal não faz sentido você calcular a média 10 vezes.

Você vai pegar a soma que foi gerada no laço de repetição e dividir por 10.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • 2 horas atrás, Math.Pi disse:

    @Whillis

    O result deve ficar fora do laço de repetição, afinal não faz sentido você calcular a média 10 vezes.

    Você vai pegar a soma que foi gerada no laço de repetição e dividir por 10.

     Oh obrigado mesmo

    n sei como q n enxerguei um problema tão simples :D

    • Curtir 2

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×