Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
MatheusArtilino

algoritmo (visualg) (iniciante)

Recommended Posts

algoritmo "ativ2"

var
   vet1,vet2 :vetor[1..10] de inteiro
   vet3 :vetor[1..20] de inteiro
   c,x  :inteiro
inicio
   c:= 0
   x:= 0
   escreval (" *preenchendo o vetor 1* ")
   para c de 1 ate 10 faca
      escreval ("=========================")
      escreva (" informe o ",c," número: ")
      leia (vet1[c])
      escreval ("=========================")
      escreval (" *preenchendo o vetor 2* ")
      escreval ("=========================")
      escreva (" informe o ",c," número: ")
      leia (vet2[c])
      escreval ("=========================")
   fimpara
   para x de 1 ate 20 faca
      vet3[x] := vet1[c]
      x:= (x)+(1)
      vet3[x] := vet2[c]
      x:= (x)+(1)
   fimpara
fimalgoritmo

estou com problemas com esse algoritmo, alguém poderia me ajudar ?

erro1.png

Questão1.png

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @MatheusArtilino. Seja bem vindo ao Fórum do Clube do Hardware... :)

 

O comando de "atribuição" no VisuAlg é "<-", em vez de ":=".

 

Outra coisa, precisa seguir a ordem estipulada no enunciado, ou seja, primeiro ler o primeiro vetor, depois ler o segundo... você está fazendo ao mesmo tempo.

 

Dentro do para você está controlando o x tanto pelo para, tanto manualmente (x<-x+1)... não é uma boa ideia. Ou controla só pelo para e ajusta o código, ou implementa usando outra estrutura de repetição, como repita ou enquanto.

 

No aguardo.

 

 

 

Editado por Simon Viegas
  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
algoritmo "ativ2"

var
   vet1,vet2 :vetor[1..10] de inteiro
   vet3 :vetor[1..20] de inteiro
   c,x  :inteiro
inicio
   escreval (" *preenchendo o vetor 1* ")
   para c de 1 ate 10 faca
      escreval ("=========================")
      escreva (" informe o ",c," número: ")
      leia (vet1[c])
      escreval ("=========================")
   fimpara
   escreval (" *preenchendo o vetor 2* ")
   para c de 1 ate 10 faca
      escreval ("=========================")
      escreva (" informe o ",c," número: ")
      leia (vet2[c])
      escreval ("=========================")
   fimpara
   c:= 0
   x:= 0
   repita
      c:= (c)+(1)
      x:= (x)+(1)
      vet3[x]:= (vet1[c])
      x:=(x)+(1)
      vet3[x]:= (vet2[c])
   ate (c=10)
   limpatela
   escreval ("=========================================")
   escreval (" * informando  vetor 1 * ")
   para c de 1 ate 10 faca
      escreva (vet1[c],",")
   fimpara
   escreval (" ")
   escreval ("=========================================")
   escreval (" * informando  vetor 2 * ")
   para c de 1 ate 10 faca
      escreva (vet2[c],",")
   fimpara
   escreval (" ")
   escreval ("=========================================")
   escreval (" * informando  vetor 3 [intercalação] * ")
   para x de 1 ate 20 faca
      escreva (vet3[x], ",")
   fimpara
fimalgoritmo

@simon viegas  obrigado por responder, consegui finalizar o algoritmo.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

 

@MatheusArtilino, massa...

 

Aproveitando, caso não conheça, apresento um recurso interessante do VisuAgl: ALEATORIO. Com ele, o próprio VisuAlg gera os números automaticamente... facilita muito na hora de testar, ex.:

 

...
inicio
ALEATORIO ON
escreval (" *preenchendo o vetor 1* ")
para c de 1 ate 10 faca
   escreval ("=========================")
   escreva (" informe o ",c," número: ")
   leia (vet1[c])
   escreval ("=========================")
fimpara
escreval (" *preenchendo o vetor 2* ")
para c de 1 ate 10 faca
   escreval ("=========================")
   escreva (" informe o ",c," número: ")
   leia (vet2[c])
   escreval ("=========================")
fimpara
ALEATORIO OFF
c:=0
x:=0
...

É auto explicativo... os leia()  que estiverem dentro do ON e OFF são preenchidos com valores aleatório automaticamente.

 

Outra coisa, dá para fazer com o para também. Se quiser parar para tentar, fique a vontade... uma dica seria utilizando o x de 1 a 10 e fazer a uma correlação das posições entre os vetores...

 

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×