Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Lucas.Bryan

VisualG RESOLVIDO algoritmo no visualg

Recommended Posts

Boa noite. Atualmente estou no 2 semestre de engenharia da computação e, estou tendo aula de algoritmo.

inicialmente, o professor começou a nos ensinar a ''criar'' algoritmos no visual g, e por curiosidade, fui procurar os ''comandos'' do visualg e vi um chamado ESCOLHA. e resolvi criar uma calculadora básica. porém, eu não consigo utilizar o comando escolha, até a parte de escolher a opção da operação vai, só que não passa dai,

algoritmo "CalculadoraBasica"
var
primeiro, segundo, resultado1, resultado2, resultado3, resultado4:real
a, b, c, d, letra:caracter
inicio
escreval ("Entre com o primeiro numero")
Leia (primeiro)
escreval ("Entre com o segundo numero")
leia (segundo)
Escreval ("Escolha a letra da opção desejada: a (SOMA), b (SUBTRAÇÃO), c ( DIVISÃO), d (MULTIPLICAÇÃO)")
leia (letra)
resultado1<-(primeiro+segundo)
resultado2<-(primeiro-segundo)
resultado3<-(primeiro\segundo)
resultado4<-(primeiro*segundo)
escolha letra
	caso a
 		escreval ("A SOMA dos valores escolhidos é igual a,"resultado1)
	caso b
		escreval ("A Subtração dos valores escolhidos é igual a,"resultado2)
	caso c
		escreval ("A Divisão dos valores escolhidos é igual a,"resultado3)
	caso d
		escreval ("A Multiplicação dos valores escolhidos é igual a,"resultado4)
 fimescolha
 fimalgoritmo

ao lado, como você pode ver na imagem abaixo, a operação é calculada, mas na parte de, por exemplo, escolhi soma (a), nao aparece o resultado de soma.

Desde ja, Obrigado

Screenshot_1.png

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tem uns erros de sintaxe...

 

resultado3<-(primeiro\segundo) -> o correto é /

 

caso a  -> o correto é caso "a"

 

escreval ("A SOMA dos valores escolhidos é igual a,"resultado1)  Colocou a vírgula que separa as expressões dentro das aspas.

o correto é escreval ("A SOMA dos valores escolhidos é igual a", resultado1)

 

voce meio que fez uma bagunça na declaração de variáveis, repetiu e criou variáveis sem necessidade.

 

Aqui um exemplo de como ficaria um pouco melhor:

algoritmo "CalculadoraBasica"
var
primeiro, segundo, resultado:real
letra:caracter
inicio
escreval ("Entre com o primeiro numero")
Leia (primeiro)
escreval ("Entre com o segundo numero")
leia (segundo)
Escreval ("Escolha a operação desejada: + (SOMA), - (SUBTRAÇÃO), / (DIVISÃO), * (MULTIPLICAÇÃO)")
leia (letra)
escolha letra
	caso "+"
 		resultado<-(primeiro + segundo)
	caso "-"
		resultado<-(primeiro - segundo)
	caso "/"
		resultado<-(primeiro / segundo)
	caso "*"
		resultado<-(primeiro * segundo)
	outrocaso
      escreval("A operacao digitada e invalida!")
 fimescolha
 escreval("Resultado: ", resultado)
 fimalgoritmo

 

  • Curtir 1
  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×