Ir ao conteúdo
  • Cadastre-se
Jaime Neto23

PHP Erro interno do Servidor! Error 500

Recommended Posts

Bom eu estava programando de boas seguindo um vídeo quando de repente faço um código aqui que deu certo,

ele serve para inserir os dados nos campos da tabela lojas do banco fabrica só que o problema é que quando aperto o botão para inserir os dados na tabela

ele mostra um erro, mesmo dando certo  WTF  OBS: Imagem do Erro depois do código

 

Aqui o Código 

<?php
$nomeLoja=filter_input(INPUT_GET, "nloja");
$nomeGerente=filter_input(INPUT_GET, "ngerente");
$nomeCidade=filter_input(INPUT_GET, "ncidade");
$nomeBairro=filter_input(INPUT_GET, "nbairro");
$numeroEstabele=filter_input(INPUT_GET, "nmr");
$nomeRua=filter_input(INPUT_GET, "nrua");
$nomeEstado=filter_input(INPUT_GET, "nestado");
$telefone=filter_input(INPUT_GET, "tel");
$link= mysqli_connect("localhost","root","","fabrica");
if($link){
$query= mysqli_query($link,"insert into lojas values('','$nomeLoja','$nomeGerente','$nomeRua','$nomeBairro','$numeroEstabele','$nomeEstado','$nomeCidade','$telefone');");
if ($query) {
    header("Location : fabrica_cadLoja.php");
}
else{
die("Erro:".mysqli_error($link));
}
}
else{
    die("erro :".mysqli_error($link));
}
?>

 

E aqui a imagem do erro:

 

599cc24535320_CapturadeTela(410).thumb.png.eca94fa802cf0dfb2359131366cb64c0.png

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Jaime Neto23

 

Olá,

Pelo que eu vi, falta coisas na sua instrução SQL.

 

A estrutura do insert é:

 INSERT INTO [tabela](campos) VALUES (campos)

 

Então deveria ser algo do tipo:

 

insert into lojas(nomeLoja, nomeGerente, nomeRua, 
                  nomeBairro, numeroEstabele, nomeEstado, 
                  nomeCidade, telefone) 
values('$nomeLoja','$nomeGerente','$nomeRua',
       '$nomeBairro','$numeroEstabele','$nomeEstado',
       '$nomeCidade','$telefone')

 

PS: para ver se está funcionando mesmo, teste sua instrução SQL diretamente no phpmyadmin. Se lá funcionar, o problema é no php. Se não funcionar, reveja o sql!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Parando pra pensar  é verdade tem algo estranho, mesmo adicionando isso da erro pera ae vou tentar ver aqui, qual método você utiliza pra adicionar ao banco ?

adicionado 1 minuto depois

porque tipo como eu consegui adicionar sem colocar os campos do banco

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Jaime Neto23 Não sei por onde você está fazendo isso, mas eu testo sempre diretamente no phpmyadmin.

 

Depois que funciona, eu desenvolvo a UI dos cadastros no php.

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

@Jaime Neto23 Vá em seu PHP.ini e mude as opções:

 

display_errors = Off

 

Mude para

 

display_errors = On

 

e depois vá em

 

error_reporting = ????

 

e deixe

 

error_reporting = E_ALL

 

adicionado 1 minuto depois

Reinicie seu apache e veja os erros que ele irá exibir.

 

https://dev.mysql.com/doc/refman/5.7/en/insert.html

Para mais informações sobre a sintaxe do sql

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×