Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Herbet

VisualG Não aparece a resposta no VisualG

Recommended Posts

Estava tentando resolver o seguinte problema:

Faça um algoritmo que leia um nº inteiro e mostre uma mensagem indicando se este número é par ou ímpar, e se é positivo ou negativo.

 

Fiz o algoritmo, mas quando coloco um número ímpar e negativo não aparece nada escrito, sendo que em todas as outras condições dá certo.

var
   num :inteiro
inicio
   escreva ("Digite um número: ")
   leia  (num)
   
   se (num%2 = 0) e (num > 0) então
      escreval (num, " é par e positivo")
   senao
      se (num%2 = 0) e (num < 0) então
         escreval (num, " é par e negativo")
      senao
         se (num%2 = 1) e (num > 0) então
            escreval (num, " é ímpar e positivo")
         senao
            se (num%2 = 1) e (num < 0) então
               escreval (num, " é ímpar e negativo")
            fimse
         fimse
      fimse
   fimse


 

image.thumb.png.2cf00bdf6d3e0b6d548f532f4d51362e.png

image.thumb.png.adabb0af2df81237ad653ed2b3fd19e0.png

 

Queria que descobrissem onde eu tô errando

 

 

 

Editado por Simon Viegas
Olá! Favor ler tópico e seguir orientações sobre POSTAGEM DE CÓDIGOS: http://www.clubedohardware.com.br/announcement/27-poste-seus-c%C3%B3digos-corretamente/
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Herbet    só no ultimo se está com um erro pois se 

(num % 2 = 1)e (num < 0 ) 

então num % 2 não será 1 e sim -1 , assim você precisa colocar esse -1 no lugar do  1 ou colocar  num % 2 <> 0 no lugar do num % 2 = 1

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

Importante: @Herbet, além desse ponto relatado por @devair1010, informei 0 (zero) e não deu alguma resposta. Zero é número inteiro também, concorda? Precisa tratar esse caso.

 

 

Da forma que você fez (com a correção) ficou muito bom... mas também poderia fazer, por exemplo, separando por categorias, algo como:

- quando igual a zero;

- quando maior que zero;

- quando menor que zero.

 

Para o primeiro apenas dá a resposta e para cada um dos 2 últimos verifica se é par ou ímpar e dá a respectiva resposta.

 

Lembrando que a forma que você fez ficou bom, falta apenas tratar o zero... este exemplo acima seria uma forma "diferente" de fazer a mesma coisa. Se quiser tentar para treinar, fique a vontade.

 

No aguardo.

 

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×