Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
RafaelCLP

Editor perdendo formatação no ctrl+c/v

Recommended Posts

É um problema que tem pelo menos desde que voltei a participar do fórum, e cada vez me incomoda mais. Não sei se preciso explicar, ou se já é conhecido por todos, mas em resumo:

1. Digite algo no editor, com alguma formatação (negrito, links etc).

2. Copie o texto e atualize a página.

3. Cole o texto copiado na caixa do editor. Toda a formatação é perdida.

 

Em todos os pedidos de configuração pra PC eu conseguiria reaproveitar grande parte de algum outro post meu de recomendação, mas tenho que reescrever (ou no mínimo reformatar) tudo porque o CTRL+C/V não funciona direito. Cada vez mais cansado de fazer isso...

 

Então eu fui em um outro fórum que costumava participar e acabou de atualizar pra última versão do IPB (uns 3 dias atrás) e testei lá. Está funcionando perfeitamente! Logo, há solução já!

 

Teria como corrigir o problema aqui no CDH também? Seria de grande ajuda.

 

Edit: adicionado imagem de exemplo com o que acontece quando colo texto com formatação aqui no CDH e quando colo no outro fórum.

exemplo.png

exemplo2.png

Editado por RafaelCLP
removendo trecho desnecessário

Compartilhar este post


Link para o post
Compartilhar em outros sites

@RafaelCLP Pelo que eu me lembro há uma limitação de plataforma que impomos.

Acontece que muitos estavam abusando da ferramenta.

Copiando parte de sites, que em sua maioria era recomendação de peças de PC e colavam no post.  Onde vinha formatado com imagens e  estrutura html.. isso estava gerando poluição visual.

 

Não é um bug. Apenas foi desabilitado!

Creio que não há possibilidade de retornarmos isso. 

O @Gabriel Torres pode nos confirmar isso.

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • 2 minutos atrás, DiF disse:

    @RafaelCLP Pelo que eu me lembro há uma limitação de plataforma que impomos.

    Acontece que muitos estavam abusando da ferramenta.

    Copiando parte de sites, que em sua maioria era recomendação de peças de PC e colavam no post.  Onde vinha formatado com imagens e  estrutura html.. isso estava gerando poluição visual.

     

    Não é um bug. Apenas foi desabilitado!

    Creio que não há possibilidade de retornarmos isso. 

    O @Gabriel Torres pode nos confirmar isso.

     

    Entendo. Será que não teria como voltar mas em vez de ser o padrão, você ter que pressionar um atalho diferente pra colar com formatação? Geralmente CTRL+V vem com formatação, e CTRL+SHIFT+V não. Não daria pra inverter? Ou ao menos por um botão na barra superior do editor pra colar com formatação?

     

    É extremamente cansativo ter que recolocar todos os links, negrito etc, como no caso a seguir:

    Citação

    Processador: Ryzen 3 1200 (R$ 306 Cissa)

    Placa-mãe: ASRock A320M-DGS (R$ 260 Kabum)

    ...

    TOTAL: R$ 1720 (+fretes)

    Claro que dá pra fazer algo sem formatação, mas fica muito bagunçado na minha opinião:

    Citação

    Processador: Ryzen 3 1200

    --> R$ 306 Cissa https://www.cissamagazine.com.br/processador-amd-ryzen-3-1200-31ghz-cache-10mb

    Placa-mãe: ASRock A320M-DGS

    --> R$ 260 Kabum https://www.kabum.com.br/produto/93135/placa-mãe-asrock-p-amd-am4-a320m-dgs-ddr4/?tag=a320

    ...

    TOTAL: R$ 1720 (+fretes)

     

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    @RafaelCLP já tentou copiar o código fonte?

     

    Só funciona aqui dentro do fórum ou pra outros lugares que usem HTML, mas já é um alento. ;)

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • 6 minutos atrás, Evandro disse:

    @RafaelCLP já tentou copiar o código fonte?

     

    Só funciona aqui dentro do fórum ou pra outros lugares que usem HTML, mas já é um alento. ;)

    Não entendi o que quis dizer com "copiar o código fonte". Não vi nenhuma opção que me dê acesso ao HTML (por exemplo). Você quis dizer "inspecionar elemento" pelo navegador?

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Não, na caixa de redação da mensagem, no canto superior esquerdo (puxando uma seta do seu avatar) tem esse botão <> Código-Fonte.

     

    Escreva um texto e coloque formatações, clique nele e você verá os códigos ocultos. ;)

     

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Quando eu clico nele, apenas abre uma caixa pra colocar um código. Se eu selecionar o texto da caixa de redação (CTRL+A) e clicar no botão <>, o texto aparece na caixa dele mesmo, mas sem nenhuma formatação e sem nenhum código:

    exp.thumb.png.3ca88f759fcfe75265eeb1f45e84d882.png

    Tentei inclusive colocar negrito em uma parte desse texto antes de clicar no botão pra ver se ia, mas não apareceu <b> nem nada. Com link apareceu uns círculos vermelhos:

    exp2.thumb.png.42a31561b152925d4d50054009adcad0.png

     

    Estou fazendo algo errado?

     

    Edit: bom, pelo menos bbcode ainda funciona. Vou simplesmente voltar a usá-lo.

    Editado por RafaelCLP

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    @RafaelCLP Este recurso não é para ser usado desta forma. esse CODE <> é exclusivo para códigos no setor de programação.

     

    Como já falamos anteriormente, o colar formatado foi desabilitado por conta do mau uso dos usuários e não temos intenção de retornar com ele. Do jeito que sugeriu no post #03,  voltaríamos a estaca zero e teríamos o problema novamente.

     

    A opção que o @Evandro mencionou, não está disponível para usuários, somente para a moderação, para  quando precisarmos editar manualmente um post/tópico que não dê para usar o editor.

     

    Entendo a sua frustração em ter que fazer sempre o mesmo processo para postar... mas infelizmente não tem como alterarmos isso.

     

    Se você usa os mesmos links e e tudo, você pode postar no seu post o link deste tópico na qual você menciona..   Ou fazer manualmente mas sem tanta formatação.

     

    O que mais nos interessa na formatação dos links é que os links tenham texto.

     

    Por exemplo assim:   Google

    Editado por DiF

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • 3 minutos atrás, DiF disse:

    @RafaelCLP Este recurso não é para ser usado desta forma. esse CODE <> é exclusivo para códigos no setor de programação.

     

    Como já falamos anteriormente, o colar formatado foi desabilitado por conta do mau uso dos usuários e não temos intenção de retornar com ele. Do jeito que sugeriu no post #03,  voltaríamos a estaca zero e teríamos o problema novamente.

     

    A opção que o @Evandro mencionou, não está disponível para usuários, somente para a moderação, para caso quando precisemos editar manualmente um post/tópico que não dê para usar o editor.

     

    Entendo a sua frustração em ter que fazer sempre o mesmo processo para postar... mas infelizmente não tem como alterarmos isso.

     

    Se você usa os mesmos links e e tudo, você pode postar no seu post o link deste tópico na qual você menciona..   Ou fazer manualmente mas sem tanta formatação.

     

    O que mais nos interessa na formatação dos links é que os links tenham texto.

     

    Por exemplo assim:   Google

    Tranquilo. Só um detalhe, eu uso parte apenas de cada configuração, não exatamente a mesma, então linkar não adianta. Vou tentar voltar a usar bbcode pra ver se fica mais fácil.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    35 minutos atrás, DiF disse:

    A opção que o @Evandro mencionou, não está disponível para usuários, somente para a moderação, para caso quando precisemos editar manualmente um post/tópico que não dê para usar o editor.

     

    Foi mal, achei que era pra todo mundo isso. :oops:

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    @RafaelCLP @DiF

     

    Confirmando: a remoção de formatação quando usa-se o control C + control V é proposital. Como explicado, o pessoal estava copiando e colando textos de outros sites e com isso estava trazendo código HTML oculto (formatação), quebrando o nosso layout e gerando muita poluição visual. Infelizmente, é algo que não pensamos em mudar por enquanto. Espero que entenda.

     

    @Evandro @RafaelCLP

     

    A opção "Código-Fonte" só está disponível para moderadores, para que moderadores possam justamente remover problemas de formatação, caso eles existam. Por motivos de segurança, não temos como liberar esta opção para usuários... 

     

    Obs: a plataforma atual não usa BBCODE. Pois BBCODE é algo que trazia problemas de desempenho ao fórum, e foi removido da plataforma.

     

    • Curtir 3

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • 2 horas atrás, Gabriel Torres disse:

    @RafaelCLP @DiF

     

    Confirmando: a remoção de formatação quando usa-se o control C + control V é proposital. Como explicado, o pessoal estava copiando e colando textos de outros sites e com isso estava trazendo código HTML oculto (formatação), quebrando o nosso layout e gerando muita poluição visual. Infelizmente, é algo que não pensamos em mudar por enquanto. Espero que entenda.

     

    @Evandro @RafaelCLP

     

    A opção "Código-Fonte" só está disponível para moderadores, para que moderadores possam justamente remover problemas de formatação, caso eles existam. Por motivos de segurança, não temos como liberar esta opção para usuários... 

     

    Obs: a plataforma atual não usa BBCODE. Pois BBCODE é algo que trazia problemas de desempenho ao fórum, e foi removido da plataforma.

     

    BBCode funciona sim nela '-'. Testando italico Testando negrito Testando url

     

    Edit: mas infelizmente quando edita fica o texto formatado, nao o bbcode :/, então se eu quisesse reaproveitar algo que fiz teria que manter um txt com os posts. Bom, se não há o que fazer tranquilo. Pode trancar o tópico.

    Editado por RafaelCLP
    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    Visitante
    Este tópico está impedido de receber novos posts.





    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×