Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Sandro de Oliveira Castro

Excel RESOLVIDO Data automática no Excel sem atualizar no dia seguinte

Recommended Posts

Boa Tarde, em minha planilha de tenho um campo data e campo dia no campo data personalizei a formatação para digitar o dia e o mês e já sair o ano, isso sem as barras, a personalização ficou assim 00"/"00"/2018", então jogo somente, exemplo 1302 e já sai 13/02/2018, a questão é da célula onde está o campo dia formatei para ser igual ao campo data só que com a formatação em dias da semana. ex. segunda-feira; terça... o problema que não está aparecendo o dia correto. Se eu mesmo digitar no campo data, a data completa ou seja com as barras e o ano aí dá certo. ex. 13/02/2018 (digitado completo pelo usuário). O que queria é justamente otimizar, sem precisar digitar as barras e o ano, no campo data deu certo no outro não. Se pegar a formatação data disponível no excel converte para o ano 1903, já tentei de várias formas, se uso a fórmula Hoje(), no dia seguinte, quando abrir a planilha atualizará, e como são lançamentos diários e distintos não pode ser atualizado, sempre tem que ficar o do dia mesmo. Tentei criar um módulo em vba  
Function pegadata()
pegadata = Date
End Function

e depois na célula data colocar a função
=SE(A1<>””;pegadata();””)

Não deu certo, retornou #nome!

Caso alguém tenha a solução e possa ajudar, agradeço

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia, @Sandro de Oliveira Castro , bem vindo.

 

Formate a célula como você vinha fazendo, como dia da semana mas use essa fórmula (supondo suas Datas na coluna A):

 

=DATA(2018;DIREITA(A2;2);ESQUERDA(TEXTO(A2;"0000");2))

Se quiser em VBA:

 

Function PegaData(rgData As Range) As Variant
  If IsDate(rgData.Text) Then PegaData = CDate(rgData.Text) Else PegaData = ""
End Function

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Obrigado pela atenção, mas não adiantou, o dia sai errado de acordo com a data. ex.: hoje é 14/02/2018 com esse procedimento do dia por extenso sai segunda e hoje é quarta. Resolvi de outro maneira, como são planilhas do mês, coloquei em células separadas o Mês e o ano, nos campos das datas coloquei a seguinte fórmula: =SE(J3="";"";DATA($C$1;$B$1;J3)), ou seja, j3 digito o dia, ex.: 14 aí no campo data ele busca a referência do mês e ano e sai a data completa 14/02/2018, conforme formatação, na outra célula, para o dia por extenso coloco = e a célula onde a data completa aparece, essa célula formatei dddd, aí deu certo.

    adicionado 5 minutos depois

    Como faço para encerrar o tópico ou não precisa

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    28 minutos atrás, Sandro de Oliveira Castro disse:

    mas não adiantou, o dia sai errado de acordo com a data. ex.: hoje é 14/02/2018 com esse procedimento do dia por extenso sai segunda e hoje é quarta.

     

    Talvez você não tenha inserido as fórmulas corretamente. Dá certo sim, veja no anexo.

    Dúvida Sandro.zip

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×