Ir ao conteúdo
  • Cadastre-se
diego_janjao

Excel Função médiases () + mês ()

Recommended Posts

Olá pessoal, tudo bem?

Hoje gostaria de aprender uma coisa, utilizar a função mês() sem a necessidade de uma coluna auxiliar que transforma as datas em número de 1 a 12 para usar na função médiases.

 

Algum tempo atrás vi algo parecido com =médiases(B1:B10;mês(A1:A10)=1), ou seja, quer fazer a média dos valores de B1 a B10 se as datas de A1 a A10 corresponderem a janeiro. Este é um exemplo que dei sabendo que a fórmula está errada, achei que fosse assim mas não é.

 

Poderiam me explicar? Obrigado.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde amigo @diego_janjao ,

 

Eu acho que não dá dessa forma, pois o argumento que a função pede é o intervalo, não uma operação sobre o intervalo. É o mesmo caso do CONT.SES do tópico do ano passado do colega David.sps: Conte.ses - critério mês;ano;nome

 

10 horas atrás, diego_janjao disse:

Algum tempo atrás vi algo parecido com =médiases(B1:B10;mês(A1:A10)=1)

 

Talvez você tenha visto algo assim então (matricial), será que não?:

 

=MÉDIA(SE(MÊS(A1:A10)=1;B1:B10;""))

 

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@diego_janjao

 

A função SOMARPRODUTO aceita utilizar as funções dia/mês/ano, e dá para calcular a média com critério utilizando essa função.

 

[]s

Editado por Patropi
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@diego_janjao , Bom Dia.

 

As funções MÉDIASES SOMASES, não trabalha com mês ano, mas podemos driblar confere as formula para obter o resultado esperado com dois critérios de seleção

 

Se foi útil clica no curtir é uma forma de agradecimento pela ajuda

Se você Visitante Também gostou e foi útil pode clicar no Curtir

 

Decio

 

exemplo Decio.xlsx

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×