Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
marcohistorico

Regular várias tensões com 1 fonte de 12v

Recommended Posts

Bom dia amigos!

 

Sou leigo no assunto e já acabei fritando o regulador de tensão do meu arduino (espero que seja só isso). Então estou recorrendo a vocês.

A imagem é o problema.

Tenho uma fonte de 12v e quero ligar vários aparelhos em tensões diferente.

 

Até então tinha ligado os relés com um regulador de tensão 7805 e dois capacitores, 470uF e 100uF.

O resto, liguei direto da fonte.

Sequer liguei o motor e já resultou na queima do arduino.

 

O que fiz errado?

Como devo fazer essa ligação?

 

Obrigado!

 

 

5a955014989e6_peas.jpg.2d34deb5043bd031beb3dc85e19cc930.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, marcohistorico disse:

O que fiz errado?

Como ligou? Provavelmente ligou o motor em alguma saída ou no regulador do arduino

 

1 hora atrás, marcohistorico disse:

Como devo fazer essa ligação?

Algo como... o arduino deve conversar com a placa com relés apenas com sinais e nunca com potência. Esta deve passar apenas pelos contatos dos relés e nunca pelos sinais. Por favor considere clicar arduino rele no google imagens ou clique neste link

 

Um pouco + que o google não fala... Tá vendo esta imagem??

maxresdefault.jpg

ok facilita a montagem e visualização mas...

Nem mesmo isso eu (eu) recomendo pois está usando o 5V e gnd do sistema digital. A dica: use outro +5 outro 7805 e outro gnd :=> outra fonte no relé. Conecte os gnd's e claro o sinal amarelo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá Isadora.

 

Acho que eu não soube me explicar.

 

A fonte alimenta 3 coisas:

- o arduino

- o motor

- os pinos de alimentação dos relés (não os pinos de sinal). Os relés tem optoacoplador 

 

1 hora atrás, Isadora Ferraz disse:

Como ligou? Provavelmente ligou o motor em alguma saída ou no regulador do arduino

 

Vou fazer por partes!

 

  • MOTOR

Conectei o motor diretamente à fonte 12v.

Mas vale dizer que sequer cheguei a liga-lo.

Ele até passa por uma das saídas de um relé (COM e NO) que serve de interruptor, mas não é o problema.

 

  • ARDUINO

Liguei pelo plug P4 diretamente à fonte 12v.

 

  • RELÉS

NÃO são alimentados pelo arduino. O arduino controla APENAS O SINAL do relé.

Estou alimentando os relés através do 7805.

Sai um fio da fonte 12v, passa pelo regulador e vai para os relés

Conectei nestes pinos destacados em verde (sem os jumpers).

 

 

Então ficou assim:

 

complet.gif.41efdd4647546d291788702d82230ffa.gif

 

 

Acho que agora me expliquei melhor! hehehe

 

Só não vale tirar sarro de meu esqueminha tosco. Sou aprendiz de iniciante!!!

Compartilhar este post


Link para o post
Compartilhar em outros sites

De boa... todos somos eternos iniciantes...

 

Estes pontos circulados são propícios pra alimentação do módulo (que não conheço)? Viu na descrição dele? Instintiva e intuitivamente eu (eu) acharia que a alimentação era na borneira algo como em dc+ e dc-

Atenção às polaridades...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sim, a alimentação é por ali.

O dc+ e - que fica nos bornes são para o sinal. É possível usar a alimentação do sinal para ativar o relé (deixando os jumpers), mas aí perde-se a função do optoacoplador.

 

É bom frisar que os relés funcionaram normalmente.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Se você diz,... então tá....

No momento não consigo acrescentar mais nada além do que já te disse e...

2 horas atrás, Isadora Ferraz disse:

Atenção às polaridades...

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Seria possível o capacitor de 470uF ter puxado uma tensão reversa do arduino?

Eu estava pensando em adicionar um diodo em cada equipamento.

Será que este poderia ser o problema?

Compartilhar este post


Link para o post
Compartilhar em outros sites

kibon

eu ia perguntar qual foi mas penso que se quisesse dizer já o tinha feito né. Afinal me pareces bem maduro pra entender que esta é a essência de foruns. Siga seu coração...:mellow:

de nada...

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×