Ir ao conteúdo
  • Cadastre-se
zacabarros

RESOLVIDO Driver AHCI (Windows 10) para GA-970A-UD3P

Recommended Posts

Saudações a todos!

 

Eu resolvi, após os de relutância, aposentar o Windows 7 e instalar o Windows 10 no meu PC. Em boa parte, em razão do Gears of War, que só roda nesse último rsrs.

Mas... eis o problema: tenho um SSD, e como muitos devem saber, quando instalamos o Windows num SSD, ele pede pelo driver AHCI antes da instalação. Só que no site da Gigabyte e no CD só disponibilizaram o driver para W7 e W8. E, como era de se esperar, nenhum deles é reconhecido na hora da instalação...

Por isso recorro a vós para saber se alguém sabe se por acaso alguém sabe onde encontrar este bendito driver, ou se há outra forma de resolver o problema.

Agradeço a todos desde já! Abraços!

 

P.S.: Minha placa-mãe é a GA-970-UD3P (revisão 2.0)

Editado por zacabarros

Compartilhar este post


Link para o post
Compartilhar em outros sites

O W10 deveria reconhecer, já de pronto, o driver.

 

Outra, os driveres do w8-64 deveriam funcionar também. Ah! Gigabyte... tenta o suporte deles. Para a marvell minha conseguiram, quando eu tinha gigabyte ainda

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 minuto atrás, ilkyest disse:

O W10 deveria reconhecer, já de pronto, o driver.

 

Outra, os driveres do w8-64 deveriam funcionar também. Ah! Gigabyte... tenta o suporte deles. Para a marvell minha conseguiram, quando eu tinha gigabyte ainda

 

 

Não conheço o W10, mas creio que esses drivers do AHCI (q são instalados antes do próprio sistema) não vêm previamente no Windows, precisando ou estar num pen-drive, ou CD etc.

 

Sobre o suporte da Gigabyte, fala do fórum do site deles? Vou ver lá se encontro também. valeu!

Compartilhar este post


Link para o post
Compartilhar em outros sites

@zacabarros  o padrão AHCI deve ser habilitado ANTES de instalar o windows, daí tu formata ele, instala, e voilá. No windows 7 tinha como habilitar depois, que dever-se-ía alterar o registro, e daí, habilitar o ahci e rebootar...

 

https://www.tecmundo.com.br/hardware/37598-como-mudar-a-configuração-do-hd-para-ahci-depois-de-instalar-o-windows.htm

 

Deve ser feito o registro no windows, e depois, habilitar o ahci. Não sei se funciona igual no windows 10

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Consegui resolver! A opção AHCI tinha de estar desativada na bios para ele parar de requisitar driver pra esse tipo de instalação. Daí a instalação ia normalmente. E, assim como disseste, um colega também tinha sugerido que mudasse o registro, conforme uma resposta q ele havia visto há algum tempo no site da Microsoft, após a instalação do sistema. Depois disso, eu não lembro bem, mas creio que não mudei nada na Bios, mas quando fui lá posteriormente o AHCI tava ativado já. Se não estiver, creio que se deva fazê-lo.

Pena que a Gigabyte não deva lançar driver nenhum pra essa placa pra simplesmente acabar com o problema pela raiz...

Abaixo, os passos dados no site da M$:

 

Citação

Hello David,

Thank you for posting your query in Microsoft Community.

We regret for the inconvenience caused to you. We will be glad to assist you with your issue.

You can try the below steps and check if it helps:

1. While in Windows, press the Win+R keys to open Run, type regedit, and click/tap on OK to open Registry Editor.
2. If prompted by UAC, click/tap on Yes.
3. In the left pane of Registry Editor, browse to the key location below.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV
4. In the right pane of the iaStorV key, double click/tap on the Start DWORD to modify it. (see screenshot above)
5. Type 0 (zero) for AHCI, and click/tap on OK.

6. In the left pane of Registry Editor, browse to the key location below.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorAV\StartOverride
7. In the right pane of the StartOverride key, double click/tap on the 0 DWORD to modify it.
8. Type 0 (zero), and click/tap on OK.

9. In the left pane of Registry Editor, browse to the key location below.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci

10. In the right pane of the storahci key, double click/tap on the Start DWORD to modify it. (see screenshot above)
11. Type 0 (zero) for AHCI, and click/tap on OK.

12. In the left pane of Registry Editor, browse to the key location below to see if you have the StartOverride here. If you don't, then go to step 15 below.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\StartOverride

13. If you do, then, in the right pane of the StartOverride key, double click/tap on the 0 DWORD to modify it.
14. Type 0 (zero), and click/tap on OK.

15. When finished, close Registry Editor.
16. Boot the computer to your BIOS or UEFI firmware settings.

17. In your BIOS or UEFI firmware settings, enable AHCI, and save & exit to apply and restart the computer.

Note: These settings will vary per brand and model number of motherboard. Please read your motherboard manual for more specific details about how to change SATA settings for it.

18. When Windows starts, it'll automatically install AHCI drivers.

19. When finished, you'll need to click/tap on Restart Now to restart the computer one last time.

Check if it helps. For further assistance you can contact Samsung support.

Thank you.

 

 

Enfim, valeu pela ajuda, ilkyest! Abraços!

Editado por zacabarros

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×