Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Dante Brandão

Excel Somarproduto e Concatenar consolidando dados

Recommended Posts

boa tarde!

nas colunas de a, b, c e d entro com as informações.

as colunas i, j, k, l e m consolida os dados informados e soma as quantidades e distribue conforme o ano selecionado.

usei a formula somarproduto e concatenar na celula " i11" , mas não retornou o valor correto.

para exemplificar melhor a planilha está anexa.

conseguem me apoiar

abs

image.png

somarproduto e concatenar.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde, @Dante Brandão ,

 

Insira na célula I10 a fórmula abaixo, clique e arraste por  todo o intervalo:

 

=SOMARPRODUTO((ANO($A$10:$A$23)=$B$3)*($B$10:$B$23=$H10)*($C$10:$C$23=I$9)*$D$10:$D$23)

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde Edson,

 

Utilizei a formula comentada e os valores deram muita diferença. Ainda não é a formula ideal.

 

Abs,

Compartilhar este post


Link para o post
Compartilhar em outros sites
36 minutos atrás, Dante Brandão disse:

Utilizei a formula comentada e os valores deram muita diferença.

 

Não encontrei inconsistência nenhuma. Quais valores deram diferença? Dá um exemplo baseado nos dados que você disponibilizou na tabela.

Somarproduto e concatenar.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Consegui desenvolver a formula. 

Segue abaixo a solução:

 

Basta inserir na celula I10 e arrastar

 

=SOMARPRODUTO(($E$10:$E$23=$H10&I$9)*(ANO($A$10:$A$23)=$B$3)*($D$10:$D$23))

 

Edson, mesmo assim agradeço a atenção e empenho em me ajudar.

 

Abs, 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, Dante Brandão disse:

=SOMARPRODUTO(($E$10:$E$23=$H10&I$9)*(ANO($A$10:$A$23)=$B$3)*($D$10:$D$23))

 

Não existe nada nesse intervalo de E10 a E23 na planilha que você postou.!

 

Então você deve ter anexado alguma versão modificada e postado por engano aqui, por isso não deu certo.

 

A fórmula que te passei era pra testar no arquivo que você postou aqui, não numa versão modificada.

Editado por Edson Luiz Branco

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×