Ir ao conteúdo
  • Cadastre-se
Danielle Garcia

VisualG Algoritmo está com erro

Recommended Posts

Alguém pode me ajudar em identificar o erro desse algoritmo?

algoritmo "CODIMENTAÇÃO"
// Função : Se
// Autor : Danielle Garcia
// Data : 19/03/2018
// Seção de Declarações
var
   T, LE, C, R, L, PV, LR, DT: REAL
   TS: INTEIRO //(1 - BIG BOB; 2 - CHEESBURGUER)
   Q: INTEIRO

inicio
   // Seção de Comandos

   escreval ("Qual o tipo de sanduíche?(1 - big bob; 2 - chessburguer)")
   leia (TS)
   escreval ("Qual a quantidade vendida?")
   leia (Q)
   escreval ("Qual o tempo utilzado, em minutos?")
   leia (T)
   escreval ("Qual percentual de lucro desjado, em porcentagem?")
   leia (LE)
   Se (TS = 1) então
      C <- 3.098*Q
   senao
      Se (TS = 2) então
         C <- 1.657 * Q
      senao
      fimse
   fimse
   escreval ("O custo de fabricação dos sanduiches é:", C)
   PV <- ((C*(LE+100))/100)/Q
   escreval("O preço de venda unitária é:", PV)
   R <- PV*Q
   escreval ("A receita é:", R)
   L <- R - C
   escreval ("O lucro é:", L)
   DT <- (4*Q) - T
   Se (DT < 0) então
      escreval ("Tempo é maior do que o esperado. É necessário treinamento.", DT)
   senao
      SE (DT > 0) então
         escreval ("Tempo menor do que o esperado. Está dento do previsto.", DT)
      SENAO
      fimse
   FIMSE
fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite. Qual é o erro/mensagem?

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×