Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Danielle Garcia

VisualG Algoritmo está com erro

Recommended Posts

Alguém pode me ajudar em identificar o erro desse algoritmo?

algoritmo "CODIMENTAÇÃO"
// Função : Se
// Autor : Danielle Garcia
// Data : 19/03/2018
// Seção de Declarações
var
   T, LE, C, R, L, PV, LR, DT: REAL
   TS: INTEIRO //(1 - BIG BOB; 2 - CHEESBURGUER)
   Q: INTEIRO

inicio
   // Seção de Comandos

   escreval ("Qual o tipo de sanduíche?(1 - big bob; 2 - chessburguer)")
   leia (TS)
   escreval ("Qual a quantidade vendida?")
   leia (Q)
   escreval ("Qual o tempo utilzado, em minutos?")
   leia (T)
   escreval ("Qual percentual de lucro desjado, em porcentagem?")
   leia (LE)
   Se (TS = 1) então
      C <- 3.098*Q
   senao
      Se (TS = 2) então
         C <- 1.657 * Q
      senao
      fimse
   fimse
   escreval ("O custo de fabricação dos sanduiches é:", C)
   PV <- ((C*(LE+100))/100)/Q
   escreval("O preço de venda unitária é:", PV)
   R <- PV*Q
   escreval ("A receita é:", R)
   L <- R - C
   escreval ("O lucro é:", L)
   DT <- (4*Q) - T
   Se (DT < 0) então
      escreval ("Tempo é maior do que o esperado. É necessário treinamento.", DT)
   senao
      SE (DT > 0) então
         escreval ("Tempo menor do que o esperado. Está dento do previsto.", DT)
      SENAO
      fimse
   FIMSE
fimalgoritmo

 

Editado por Simon Viegas
Inserir tag CODE
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite. Qual é o erro/mensagem?

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×