Ir ao conteúdo
  • Cadastre-se
LUCIANO LUIZ ROSA

Excel RESOLVIDO Buscar data em uma tabela e retornar "FER"se for feriado

Recommended Posts

Amigos, boa tarde!

        Estou tentando encontrar uma fórmula que possa me indicar se as datas existentes na coluna C da Planilha 1 Abaixo , correspondem a dias de feriados, conforme datas existentes na tabela 2(Tabela de Feriados).

 

        Por exemplo, se o dia 01/01/2018 (coluna C, linha 7) da planilha 1, constar como feriado na planilha 2(tabela de Feriados), a célula B7 retornará "FER", abreviatura de feriado.

     

       Com esta formula, terei condições de visualizar automaticamente na planilha 1, todos os feriados que ocorrem no período que estarei fazendo o levantamento.

 

PLANILHA 1 

image.thumb.png.7d23130ed0d3e259417b157013241f8f.png

 

PLANILHA 2 - TABELA DE FERIADOS

 

image.thumb.png.a584e9f9f248dc5e02d57f3eb4d559fc.png

 

(a tabela de feriados corresponde ao intervalo de (h2:AB22)

image.thumb.png.22193b684d192fd488b0ac9204165c63.png

 

Alguém poderia me ajudar, preciso muito resolver esta questão, pois, já tentei diversas opções aqui e não consegui resolver.

 

Abraços a todos!

MODELO DE CARTÃO - MÚLTIPLAS APURAÇÕES.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Considerando que sou leigo em Excel avançado, "bolei" uma maneira, talvez arcaica, porém, aparentemente útil para resolução do seu problema. Vejamos:

Inseri 2 colunas na aba "Registro de ponto", uma para a fórmula, e outra para converter o resultado para "FER", que você deseja.

Para executar o teste, alterei a data da célula "H2" aba "Feriados" e coloquei a mesma data da célula "C7" da aba "registro de ponto" para facilitar a identificação do resultado final. 

O "problema" é que quando a data não é feriado, a célula consta como # N/D - não disponível. Porém, acredito que há maneiras mais "criativas e simplificadas" para a resolução. Mas, no momento, foi o que consegui pensar. Acredito que já irá te auxiliar.

 

adicionado 4 minutos depois

 

MODELO DE CARTÃO - MÚLTIPLAS APURAÇÕES.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Consegui resolver esta questão do #nd com a formula abaixo:

 

=SE(ÉERROS(PROCV(C8;Feriados!$H$2:$AB$22;1;FALSO));"";PROCV(C8;Feriados!$H$2:$AB$22;1;FALSO))

 

vou agora testar e ver o restante das fórmulas.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Com a fórmula procv utilizada,  ela retorna somente os feriados quando estes encontram-se na primeira coluna da tabela de feriados. As datas das demais colunas, a formula não encontra os resultados. Isto acontece porque é necessário indicar a coluna de resultado, que no caso do nosso exemplo, foi a coluna 1. Todavia, existem vários outros feriados que encontram-se nas demais colunas. Acho que o a formula Índice.corresp resolveria...

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite, @LUCIANO LUIZ ROSA

 

Para facilitar nas fórmulas, dê o nome lstFeriados à lista de feriados que corresponde ao intervalo F1:AB22 da planilha Feriados.

Na B7 da planilha REGISTRO PONTO, teste a seguinte fórmula (depois arraste para baixo):

 

=SE(SOMARPRODUTO(--($C7=ÍNDICE(lstFeriados;CORRESP(ANO($C7);ÍNDICE(lstFeriados;0;1);0);0)))>0;"FER";$C7)

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@LUCIANO LUIZ ROSA , Bom Dia.

 

Eliminei a coluna D e só usei a formula para mostrar se é feriado ou não, confere

 

Se foi útil clica no curtir é uma forma de agradecimento pela ajuda

Se você Visitante Também gostou e foi útil pode clicar no Curtir

 

Decio

 

MODELO_DE_CARTÃO_-_MÚLTIPLAS_APURAÇÕES_Decio.xlsx

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Só olhando a resposta do amigo @deciog fui perceber que nem seria necessário comparar o ano primeiro (primeira coluna da Feriados) pois os feriados já são datas completas (dãããã:wiggle:) rsrsrsr. Então dá pra usar um simples CONT.SE.

 

Na B7 da REGISTRO PONTO e arraste:

=SE(CONT.SE(Feriados!$F$1:$AB$22;$C7)=0;$C7;"FER")

________

Obs.: @deciog , baixei seu modelo mas não entendi: porque o intervalo e sua fórmula começa em H2?

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Edson Luiz Branco , Bom Dia.

 

 

Obrigado pelo alerta

 

Eu só acrescentei a função SE(É.NÃO.DISP não mudei a formula que estava na planilha feita pelo @lHenrique_10  e também não conferir as informações, um erro mas pouco tempo hoje.

 

Decio

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
4 minutos atrás, deciog disse:

Obrigado pelo alerta...

...um erro mas pouco tempo hoje

 

Não por isso, parceiro! Mais é porque. fiquei curioso com sua solução e alterei aqui para G2 mas não consegui retornar os valores... acho que não entendi a fórmula... 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×