Ir ao conteúdo
  • Cadastre-se
Tanai

VisualG Visualg não reconhece PROCEDIMENTO

Recommended Posts

Bom dia,

 

Estou com problema no meu Visualg.

 

Estou tentando utilizar o PROCEDIMENTO. porém o Visualg não está reconhecendo o comando.

 

 não fica sublinhado que nem o "inicio" ou "fimalgoritmo". e o programa não roda. ...

 

 

5ab4ed3659cde_erroprocedimento.thumb.png.e819bdc598d810b8333209d798bc0324.png

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

Por favor, poste o código em forma de texto.

 

 

No aguardo.

adicionado 3 minutos depois

Sobre:

2 horas atrás, Tanai disse:

Estou tentando utilizar o PROCEDIMENTO. porém o Visualg não está reconhecendo o comando.

 

 não fica sublinhado que nem o "inicio" ou "fimalgoritmo". e o programa não roda. ...

 

Nesse caso, creio que é assim mesmo... o importante que fique azul e o programa rode.

 

Ou está apresentando alguma falha ao compilar/executar?

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Tanai    não está reconhecendo o comando por que você colocou um procedimento com o nome copo e está tentando chamar outro procedimento com nome Topo, então você pode chamar o procedimento com o mesmo nome, então no lugar de Topo() coloque copo() ou crie outro procedimento com nome Topo, e ele também tem outro erro que é a chamada de procedimento dentro do mesmo procedimento, e o nome do procedimento não fica azul não, só a palavra procedimento  .

Algoritmo "procedimento"
Var
  i : inteiro
  pesado,n : caracter
  p,mai : real
procedimento copo
inicio
  //copo()   esta chamada aqui dentro não pode
  limpatela
  escreval("detector de pessoa pesada")
  escreval("maior peso ate agora ",mai," KG")
  escreval("----------------------------------")
fimprocedimento
Inicio
  copo()
  para i de 1 ate 5 faca
    escreval("digite o nome : ")
    leia(n)
    escreval("digite o peso de ",n," : ")
    leia(p)
    se p>mai ENTÃO
      mai := p
      pesado := n
    fimse
  fimpara

Fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×