Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Tanai

VisualG Visualg não reconhece PROCEDIMENTO

Recommended Posts

Bom dia,

 

Estou com problema no meu Visualg.

 

Estou tentando utilizar o PROCEDIMENTO. porém o Visualg não está reconhecendo o comando.

 

 não fica sublinhado que nem o "inicio" ou "fimalgoritmo". e o programa não roda. ...

 

 

5ab4ed3659cde_erroprocedimento.thumb.png.e819bdc598d810b8333209d798bc0324.png

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

Por favor, poste o código em forma de texto.

 

 

No aguardo.

adicionado 3 minutos depois

Sobre:

2 horas atrás, Tanai disse:

Estou tentando utilizar o PROCEDIMENTO. porém o Visualg não está reconhecendo o comando.

 

 não fica sublinhado que nem o "inicio" ou "fimalgoritmo". e o programa não roda. ...

 

Nesse caso, creio que é assim mesmo... o importante que fique azul e o programa rode.

 

Ou está apresentando alguma falha ao compilar/executar?

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Tanai    não está reconhecendo o comando por que você colocou um procedimento com o nome copo e está tentando chamar outro procedimento com nome Topo, então você pode chamar o procedimento com o mesmo nome, então no lugar de Topo() coloque copo() ou crie outro procedimento com nome Topo, e ele também tem outro erro que é a chamada de procedimento dentro do mesmo procedimento, e o nome do procedimento não fica azul não, só a palavra procedimento  .

Algoritmo "procedimento"
Var
  i : inteiro
  pesado,n : caracter
  p,mai : real
procedimento copo
inicio
  //copo()   esta chamada aqui dentro não pode
  limpatela
  escreval("detector de pessoa pesada")
  escreval("maior peso ate agora ",mai," KG")
  escreval("----------------------------------")
fimprocedimento
Inicio
  copo()
  para i de 1 ate 5 faca
    escreval("digite o nome : ")
    leia(n)
    escreval("digite o peso de ",n," : ")
    leia(p)
    se p>mai ENTÃO
      mai := p
      pesado := n
    fimse
  fimpara

Fimalgoritmo

 

Editado por devair1010
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×