Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Amilton Cândido

VisualG Salário líquindo de funcionário

Recommended Posts

Construa um algoritmo em Visualg, que calcule o salário líquido de um funcionário. O programa recebe o salário bruto do funcionário, caso este seja inferior a R$1.000,00 é descontado 7% em impostos, se o salário variar de R$ 1.000,00 até R$1.500,00 é descontado 12% em imposto, se for superior a R$1.500,00 é descontado 15%. Ao final o programa deve exibir o nome e o salário líquido do funcionário.

 

Aonde está o erro?

var
   salb: real
   NOME: CARACTERE
Inicio
   Escreval("Sistema de gestão de pagamentos")
   Escreva ("Digite o nome do funcionário:")
   Leia(nome)
   Escreva("Digite o salário bruto do funcionário:R$")
   Leia (salb)
   se (salb<1000) então
      escreva ("O salário liquido é: ",salb - (salb*0.07))
      se (salb>=1000 e <=1500) então
         escreva ("O salário liquido é: ",salb - (salb*0.12))
         se (salb>1500) então
            escreva ("O salário liquido é: ",salb - (salb*0.15))
         fimse
      fimse
   fimse

 

Editado por Simon Viegas
Inserir tag CODE

Compartilhar este post


Link para o post
Compartilhar em outros sites

image.thumb.png.f699ffd4bcc0346be40a7cbf79653e43.png

 

Não está calculando com o valor 1.500. Quando são valores menores que 1.000, ele calcula, porém, dá esse erro.

 

image.thumb.png.4208c71de2f2c7e4a6bc779ed8fe41c4.png

Compartilhar este post


Link para o post
Compartilhar em outros sites
var
   salb: real
   NOME: CARACTERE
Inicio
   Escreval("Sistema de gestão de pagamentos")
   Escreva ("Digite o nome do funcionário:")
   Leia(nome)
   Escreva("Digite o salário bruto do funcionário:R$")
   Leia (salb)
   se (salb<1000) então
      escreva ("O salário liquido é: ",salb - (salb*0.07))
   fimse
   se (salb<=1500) então
      escreva ("O salário liquido é: ",salb - (salb*0.12))
   senao
      escreva ("O salário liquido é: ",salb - (salb*0.15))
   fimse

 

Tente assim e poste o resultado.
 

Editado por Simon Viegas
Inserir tag CODE

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não use acentos nos comandos do VisualG, como a mensagem de erro informa.

 

Para postar o código use a tag code (ver orientação no alto da página).

Editado por Ricardov

Compartilhar este post


Link para o post
Compartilhar em outros sites

Funcionou. Muito obrigado!

Editado por Simon Viegas
Remover conteúdo off-topic. Para um novo problema, crie um NOVO TÓPICO
  • Confuso 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

Só para complementar...

 

Como são condições mutuamente excludentes, é necessário o uso dos senão. Seu código poderia ficar assim:

Algoritmo "semnome"
//ENUNCIADO
//Construa um algoritmo em Visualg, que calcule o salário líquido de um
//funcionário. O programa recebe o salário bruto do funcionário, caso este
//seja inferior a R$1.000,00 é descontado 7% em impostos, se o salário variar
//de R$ 1.000,00 até R$1.500,00 é descontado 12% em imposto, se for superior
//a R$1.500,00 é descontado 15%. Ao final o programa deve exibir o nome e o
//salário líquido do funcionário.
var
   nome :caractere
   salb :real
Inicio
   escreval("Sistema de gestão de pagamentos")
   escreva ("Digite o nome do funcionário: ")
   leia(nome)
   escreva("Digite o salário bruto do funcionário: R$")
   leia(salb)
   se (salb<1000) ENTÃO
      escreva ("O salário liquido é: ",salb-(salb*0.07))
   senao
      se (salb<=1500) ENTÃO
        escreva ("O salário liquido é: ",salb-(salb*0.12))
      senao
           escreva ("O salário liquido é: ",salb-(salb*0.15))
      fimse
   fimse
Fimalgoritmo

 

Como a "frase final" é praticamente igual, só mudando o resultado... poderia fazer assim:

var
   nome :caractere
   salb :real
   sall :real
...
   se (salb<1000) ENTÃO
      sall<-salb-(salb*0.07))
   senao
      se (salb<=1500) ENTÃO
        sall<-salb-(salb*0.12))
      senao
           sall<-salb-(salb*0.15))
      fimse
   fimse
   escreva ("O salário liquido é: ",sall)

 

Como a fórmula do salário líquido também é constante, só mudando o valor da taxa, poderia ficar assim:

var
   nome :caractere
   salb :real
   taxa :real
   sall :real
....
   se (salb<1000) ENTÃO
      taxa<-0.07
   senao
      se (salb<=1500) ENTÃO
        taxa<-0.12
      senao
           taxa<-0.15
      fimse
   fimse
   sall<-salb-(salb*taxa)
   escreva ("O salário liquido é: ",sall)

 

Para tentar ainda mais organizar, poderia deixar as taxas como constantes.

Algoritmo "semnome"
const
   TAXA1 = 0.07 //taxa para salários menores que 1000
   TAXA2 = 0.12 //taxa para salários entre 1000 e 1500 (inclusos)
   TAXA3 = 0.15 //taxa para salários maiores que 1500
var
   nome :caractere
   salb :real
   taxa :real
   sall :real
Inicio
   escreval("Sistema de gestão de pagamentos")
   escreva ("Digite o nome do funcionário: ")
   leia(nome)
   escreva("Digite o salário bruto do funcionário: R$")
   leia(salb)
   se (salb<1000) ENTÃO
      taxa<-TAXA1
   senao
      se (salb<=1500) ENTÃO
        taxa<-TAXA2
      senao
           taxa<-TAXA4
      fimse
   fimse
   sall<-salb-(salb*taxa)
   escreva ("O salário liquido é: ",sall)
Fimalgoritmo

 

 

adicionado 20 minutos depois

Ah! Sobre o erro que você teve.

 

19 horas atrás, Amilton Cândido disse:

Não está calculando com o valor 1.500. Quando são valores menores que 1.000, ele calcula, porém, dá esse erro.

Isso acontece porque você deixou os se dentro do outro... observe seu primeiro código lá em cima...

 

DICA:
O Visualg tem um recurso de auto-indentação. Basta pressionar Ctrl+G. Se fizesse isso, já veria que tem alguma coisa errada. Pois todos os se deveriam ficar na mesma linha.

 

PS:

O código do @Olinad212 também tem um errinho... experimente inserir valores menos que 1000.

 

19 horas atrás, Olinad212 disse:

   //estrutura se 1
   se (salb<1000) então
      escreva ("O salário liquido é: ",salb - (salb*0.07))
   fimse
   //estrutura se 2
   se (salb<=1500) então
      escreva ("O salário liquido é: ",salb - (salb*0.12))
   senao
      escreva ("O salário liquido é: ",salb - (salb*0.15))
   fimse

 

Vejam, o código está com duas estruturas de se separadas. A primeira verifica e independente do que aconteça, após vai verificar a segunda... ou seja, mesmo que a resposta desse sempre certa (como se só existissem salários maiores que 1000), mesmo assim a estrutura estaria com erro... A correção desse código do @Olinad212 seria esse meu primeiro desse tópico (uso do senão para deixar apenas uma estrutura). Ou também poderia ficar assim:

algoritmo "FCdG"
var
   salb: real
   NOME: CARACTERE
Inicio
   Escreval("Sistema de gestão de pagamentos")
   Escreva ("Digite o nome do funcionário:")
   Leia(nome)
   Escreva("Digite o salário bruto do funcionário:R$")
   Leia (salb)
   se (salb<1000) ENTÃO
      escreva ("O salário liquido é: ",salb - (salb*0.07))
   fimse
   se (salb>=1000) e (salb<=1500) ENTÃO
      escreva ("O salário liquido é: ",salb - (salb*0.12))
   fimse
   se (salb>1500) ENTÃO
      escreva ("O salário liquido é: ",salb - (salb*0.15))
   fimse
fimalgoritmo

Dessa forma, a mais simples possível, teríamos 3 estruturas... são 3 se diferentes, ou seja, mesmo que já tenha encontra a taxa correta, o programa ainda sim vai verificar se é uma outra.... o que não faz sentido... logo, entra a tal necessidade dos senão, como já citado lá em cima:

 

20 minutos atrás, Simon Viegas disse:

Como são condições mutuamente excludentes, é necessário o uso dos senão.

 

Editado por Simon Viegas

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×