Ir ao conteúdo
  • Cadastre-se
Amilton Cândido

VisualG Calcular raiz quadrada de um numero sempre menor que 9

Recommended Posts

Caro usuário,

 

Seja bem-vindo ao Fórum do Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a resposta está correta ou não, ou para que possa ser auxiliado com a dúvida no desenvolvimento do exercício.

 

Infelizmente, não há como resolver os trabalhos pelos usuários. O objetivo do Fórum do Clube do Hardware é auxiliar seus usuários a encontrar soluções para que possam sanar suas dúvidas, e não de trazer soluções prontas para seus usuários.. Além disso, copiar e colar respostas que não são de autoria própria do qualquer usuário é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Amilton Cândido.

 

20 horas atrás, Amilton Cândido disse:

Calcular a raiz quadrada no visualg, na linguagem portugol, de um número sempre que este for menor que 9.

 

Uma resposta poderia ser assim:

algoritmo "FCdH"
//Calcular a raiz quadrada no Visualg, na linguagem portugol, de um número
//sempre que este for menor que 9.
var
  numero     :real
  raizNumero :real
Inicio
escreval("Escreva o número")
leia(numero)
se (numero<9) ENTÃO
   raizNumero<-raizq(numero)
   escreval("Raiz de",numero,"=",raizNumero)
senao
   escreval("Número maior que 9, não vou calcular a raiz")
fimSe
fimalgoritmo

 

 

 

Como no mundo do reais, não existem raízes de número negativos, então poderia ficar assim:

algoritmo "FCdH"
//Calcular a raiz quadrada no Visualg, na linguagem portugol, de um número
//sempre que este for menor que 9.
var
  numero     :real
  raizNumero :real
Inicio
escreval("Escreva o número")
leia(numero)
se numero>=0 ENTÃO
   se (numero<9) ENTÃO
      raizNumero<-raizq(numero)
      escreval("Raiz de",numero,"=",raizNumero)
   senao
      escreval("Número maior que 9, não vou calcular a raiz")
   fimSe
senao
   escrevaL("Numero menor que 0, não existe raiz real")
fimse
fimalgoritmo

 

Etc.

 

Qualquer dúvida é só perguntar.

 

No aguardo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×