Ir ao conteúdo
  • Cadastre-se
RaiDuMal

Dificuldade em funcionar motores de passo com cnc shield V4

Recommended Posts

Primeiramente, obrigado por estar lendo!

   Agora vamos la. Eu fiz um PDF com o meu problema muito bem explicado, meu projeto é pra TCC então o quanto antes resolver melhor. E por ter pouca informação em português sobre o Cnc shield v4 esse post vai ajudar mais pessoas.

 

 

 

 

motor passo.pdf

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Dom Bonilla Vou seguir certinho pelos links q você mandou, se resolver eu posto aqui. Mas ainda acho q o problema e algum erro em ligar os motores.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Para facilitar a vida dos leitores coloque o texto e fotos no post, não no anexo.

 

Já verificou e se a fonte fornece a tensão correta e não arria quando aciona os motores? Seria bom usar uma fonte com capacidade de corrente maior, por garantia.

 

Também pode usar um osciloscópio para verificar a forma de onda na saída dos drivers dos motores.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Multímetro é o mais básico dos instrumentos em eletrônica, e você quer fazer um projeto de automação sem isso? Invejo seu otimismo.

 

adicionado 2 minutos depois
2 horas atrás, Ricardov disse:

Também pode usar um osciloscópio para verificar a forma de onda na saída dos drivers dos motores.

Ricardo, o cara sequer investiu R$ 20,00 num multímetro.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu (eu) acho que você devia experimentar outra abordagem algo como entender  como funciona um motor de passo e tal. Ficar dependente dos tais shields e suas bibliotecas te ingessam e não te permite progredir, se é que me entende. P.ex. pense e entenda em termos de esquemáticos e código fonte. Conecte os dois...

O multímetro lhe cai bem. E... já fez um pisca led?

  • Haha 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Ricardov ricardo como o projeto é em grupo meus amigos acharam melhor fazer a troca dos componentes. Então enviei de volta aos vendedores e ele vão me enviar outro testado.

adicionado 6 minutos depois

@Sérgio Lembo  então eu curso TI e não eletrônica. O nosso tcc é pra estudar na verdade os programas e como interagem com os motores no corte das peças. Eu ate tinha um multímetro mais minha mãe sumiu com ele kkk. Ontem eu e meus amigos voltamos a testar (regulamos os trimpots e mesmo assim o erro persistiu então resolvemos fazer a troca por componentes ja testados, se persistir o problema quando chegar eu falo aqui no post)

adicionado 10 minutos depois

@Isadora Ferraz Sim, tinha utilizado o exemplo blink no arduíno IDE e o arduíno respondeu certo. 

adicionado 55 minutos depois

@Ricardov então minha escola não possui lab de eletrônica eu quis fazer o projeto porque acho a parte de eletrônica interessante. Um tempo atrás fiz um aquecedor por indução magnética então comecei a me interessar em alguns projetos.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pessoal eu fiz um teste e resolvi trocar os componentes, o vendedor prometeu mandar um testado. Assim que chegar eu testo e mando aqui pra vocês.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×