Ir ao conteúdo
  • Cadastre-se
Lucas Da Silva Aleixo

VisualG RESOLVIDO Por que está dando este erro de sintaxe no laço de "para"

Recommended Posts

algoritmo "Exercício 9 - Para"
// Função : Este programa pede para o usuário informar a taxa de juros, o capital, o período e ao final é exibido o montante ao final de cada mês.
// Autor : 
// Data : 01/04/2018
// Seção de Declarações 
var
  m, p, i, n :real
  x :inteiro
inicio
  escreva("Informe a taxa de juros: ")
  leia(i)
  
  escreva("Informe o capital: ")
  leia(p)
  
  escreva("Informe o período: ")
  leia(n)
  
  i := (i / 100)
  
  para x de 1 ate n faca
    n := (n + 1)
    m := (p * (1 + i) ^ n)
    escreval(x, "° Mês: R$", m)
  fimpara
fimalgoritmo

Porém ao ser executado da erro de sintaxe na linha "para x de 1 ate n faca". Como posso resolver?

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Lucas Da Silva Aleixo    esse erro é por que você colocou a variável n como real e o comando para só aceita inteiros, então para acertar coloque o n junto com o x que é do tipo inteiro lá no inicio .

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×