Ir ao conteúdo
  • Cadastre-se
Eluir

Excel RESOLVIDO Juntar células e o resultado manter a formatação (IMPOSSÍVEL????)

Recommended Posts

É simples, mas creio que não existe fórmula para isso:

 

JUNTAR CÉLULAS E MANTER A FORMATAÇÃO DA OUTRAS ANTERIORES, EXEMPLO?

 

Ta aí.. quero ver uma resposta...

 

A1 = 01 B1 = 02 

 

Juntar os valores e o resultado na C3 = 0102

 

Por favor, não venha com fórmulas de por "0#" nem de "0"

Na linha B os números já são A2 = 02 B2 = 12, então se eu por regras por COLUNA eu fico com 02012 (vem um zero na frente)

Nada de formata coluna por coluna... 

 

 

É simples, mas quero o RESULTADO vindo com a FORMATAÇÃO ZERO A ESQUERDA 

 

O excel só está puxando aINFORMAÇÃO... 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Eluir , use, na C1, a seguinte fórmula:

 =CONCATENAR(A1;B1)

Ele vai juntar, na C1, o conteúdo da A1 e da B1 da forma como estão lá. 

Compartilhar este post


Link para o post
Compartilhar em outros sites

experimente na celula [c1]  

 

=texto(a1;rept("0";núm.caract(a1)))  & texto(b1;rept("0";núm.caract(b1)))

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Kleber Peters Não não.. já tinha tentado.. o resultado volta 123 e não 010203

 

adicionado 1 minuto depois

@Basole Também não... o resultado na C1 é 123 e não 010203

adicionado 3 minutos depois

Ops.. o resultado é 12 e não 0102

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sugiro disponíbolizar o arquivo exemplo pra entender melhor e fazer os testes de acordo com a formatação

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Basole Muito Obrigado pela ajuda Basole... to perdido há 02 semanas.. já liguei até pra Microsoft.. por isso mandei o desafio!!!!!!!

 

Pense num bronca... obrigadão!!!!

Análise de sequência.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

voce está utilizando a formatação personalizada "0#" nas colunas A a K.

 

Sendo assim pode utilizar a seguinte formula, pra chegar ao resultado desejado

 

=TEXTO(A1;"00") &TEXTO(B1;"00")& TEXTO(C1;"00")& TEXTO(D1;"00")&TEXTO(E1;"00")& TEXTO(F1;"00") & TEXTO(G1;"00") & TEXTO(H1;"00")& TEXTO(I1;"00") & TEXTO(J1;"00") & TEXTO(K1;"00")

 

E se alterar a formatação para mais caracteres pode usar a formula 

 

=TEXTO(A1;REPT("0";CÉL("largura";A1)))

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Basole :) Valeuuuuu Basole..... Orbigadão mesmo!!

 

Eu não de quase nada... mas precisado to por aqui...

 

Valeu... :) 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×