Ir ao conteúdo
  • Cadastre-se
Douglas Marins

Portugol Não estou conseguindo criar esse algorítimo de vetores

Recommended Posts

» Criar um algoritmo que leia as informações de 4 produtos distintos (ex
Tabela abaixo) e seja capaz de buscar um determinado produto informado pelo
usuário e imprima na tela todas as informações sobre esse produto.
» A estrutura possui o identificador “Produtos” e conta com os campos: Tipo,
Preço e Quantidade em Estoque.

2018-04-03 (2).png

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Douglas Marins      você precisa criar os vetores onde ficará armazenado as informações que você pedirá ao usuário, então precisa de um vetor para o produto e outro para o tipo e outro para o preço e outro para a quantidade e precisa também de um contador para apontar para a posição dos vetores onde será guardado essa informações , então primeiro você cadastra as informações e depois você faz a busca de um produto .   então para criar os vetores seria assim :

produto,tipo     : vetor[1..10] de caractere
preco,quantidade : vetor[1..10] de inteiro
contador         : inteiro
sair             : caractere

então poderá cadastrar até no máximo 10 produtos, coloque um enquanto / fimenquanto que repita enquanto você quiser fazer outro cadastro e dentro desse laço use o comando leia para pegar os dados referentes ao produto, e quando não quiser fazer mais cadastros então sai do laço e pede para digitar um produto para fazer a busca para ver se esse produto está armazenado .   essa parte seria assim :

contador := 0
enquanto sair != "s" faca
  contador := contador+1
  escreva("Digite O Nome Do Produto ")
  leia(produto[contador])
      .
      .
faça o mesmo para os outro dados
      .
      .
  escreva("Quer Cadastrar Outro Produto  S/N")
  leia(sair)
fimenquanto

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×