Ir ao conteúdo
  • Cadastre-se
Caio I Bertazzi

compilar kernel no linux no meu notebook

Recommended Posts

Coloquei os programas kernel-pakage e o lib..... 5 para fazer o menuconfig  no Debian stable 9 mas os ultimos kerneis o -4.15.15 e 4.16 os dois dão erro logo no menuconfig mudou alguma coisa na compilação que não estou sabemdo já tenho uma máquina complicada pois não consegue nem instalar o ubuntu é uma maquina com um nvidia 1060 6 gb e placa wireless killer que nenhum linux reconhece por isso o ubuntu nem entra para na entrada e fica alí agora o Debiam Stable consegui por o testing acontece a mesma coisa que o ubuntu e agora não consigo atualizar o kernel qual seria o Problema é uma máquina parruda com 17 de 7 geração placa de video nvidia 1060 wireless killer 1050 e 32 de memória com discos ssd de 256 e um 1 TB trabalho com autocad preciso de maquina potente mas adoro linux e reservei 500 do discão para um mas isto me frustrou muito .
Se alguem tiver alguma dica do que fazer agradeço
Caio

Compartilhar este post


Link para o post
Compartilhar em outros sites

Uma coisa que levo comigo no linux é: se algo está funcionando, não mexa.

rsrsrssrs

É arrumar dor de cabeça.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Vi que usa o Debian Stable no momento o Stretch, versão 9. O kernel padrão dele é o 4.9, um kernel LTS que vai ter suporte por um bom tempo e já é suficiente para a maioria dos dispositivos.

Uma solução para atualizar o kernel sem necessitar de compilação é usar o repositório stretch-backports. Este repositório porta as novidades do Debian testing (no momento codinome Buster, versão 10) para a versão atual sem que seja necessário atualizar todo o sistema.  O pacote do kernel chama-se linux-image-amd64 e está atualmente na versão 4.14 no stretch-backports e 4.15 no testing.

Para adicionar o repositório stretch-backports no seu sistema deve atualizar o arquivo /etc/apt/sources.list colocando no final do arquivo a seguinte linha:

deb http://ftp.debian.org/debian stretch-backports main


Em seguida atualize os pacotes com um apt update. Para instalar qualquer pacote do repositório backports, deve usar o comando:
 

apt-get -t stretch-backports install "package"

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
6 horas atrás, Davi Silva Santos disse:

Vi que usa o Debian Stable no momento o Stretch, versão 9. O kernel padrão dele é o 4.9, um kernel LTS que vai ter suporte por um bom tempo e já é suficiente para a maioria dos dispositivos.

Uma solução para atualizar o kernel sem necessitar de compilação é usar o repositório stretch-backports. Este repositório porta as novidades do Debian testing (no momento codinome Buster, versão 10) para a versão atual sem que seja necessário atualizar todo o sistema.  O pacote do kernel chama-se linux-image-amd64 e está atualmente na versão 4.14 no stretch-backports e 4.15 no testing.

Para adicionar o repositório stretch-backports no seu sistema deve atualizar o arquivo /etc/apt/sources.list colocando no final do arquivo a seguinte linha:


deb http://ftp.debian.org/debian stretch-backports main


Em seguida atualize os pacotes com um apt update. Para instalar qualquer pacote do repositório backports, deve usar o comando:
 


apt-get -t stretch-backports install "package"

 

 

adicionado 2 minutos depois

meu problema é alguma coisa na máquina com novos kerneis quando instalei o do backports o debiam entra até o nome e senha do usuário aí entra a tela fica cinza e trava tenho que rebutar com alt f2 algo não funciona

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 horas atrás, Caio I Bertazzi disse:

 

adicionado 2 minutos depois

meu problema é alguma coisa na máquina com novos kerneis quando instalei o do backports o debiam entra até o nome e senha do usuário aí entra a tela fica cinza e trava tenho que rebutar com alt f2 algo não funciona

Se tudo funciona bem no terminal, o problema pode ser nos drivers da placa NVIDIA. Está usando os drivers proprietários? O driver livre só funciona 100% nas placas da série GTX 700. A partir daí só com o driver proprietário.
Sem falar que placas de vídeo em laptops são muito mais chatas para usar, principalmente as da NVIDIA devido a tecnologia Optimus da própria marca que nem eles mesmos suportam direito no próprio driver proprietário. Para rodar sem problemas infelizmente só em desktop.
Se for laptop com placa NVIDIA que possui a tecnologia Optimus, precisa de usar ou só o driver livre (trocará de placa através do método PRIMUS) ou o driver proprietário em conjunto com o Bumblebee.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×