Ir ao conteúdo
  • Cadastre-se
Kazoii

VisualG Repetição para não funcionando

Recommended Posts

Galera meu professor me deu esse exercício mais por motivos que não entendo ele nao quer rodar.

Escreva um programa que:
 Leia dois números inteiros
 Armazene o menor valor em uma variável a e o maior em uma variável b
 Escreva todos os inteiros do intervalo [a, b]

Programação:

Var
// Seção de Declarações das variáveis 
number1, number2:inteiro
Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
escreva("Digite o primeiro numero: ")
leia(number1)
escreva("Digite o segundo numero: ")
leia(Number2)
se (number1 < number2) então
PARA de number1 ate number2 FAÇA
escreva (number1)
number1+1
fimpara

senao 
para number2 ate number1  faca
escreva (number2)
number2+1
fimpara
fimse

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Kazoii.

 

Existem alguns pontos a serem verificados. Para resumir, fiz algumas alterações, e inserir comentários para tentar explicar no próprio código.

algoritmo "FCdH"
// Leia dois números inteiros
// Armazene o menor valor em uma variável a e o maior em uma variável b
// Escreva todos os inteiros do intervalo [a, b]
var
    {number1, number2:inteiro} //por que em inglês?
    numero1, numero2:inteiro
    i :inteiro //auxiliar utilizado no
inicio
escreva("Digite o primeiro numero: ")
leia(numero1)
escreva("Digite o segundo numero: ")
leia(numero2)
se (numero1 < numero2) ENTÃO
   {para de numero1 ate numero2} //sintaxe incompleta
   para i de numero1 ate numero2 faca
      {escreva(number1)}
      escreva(i)
      {numero1+1} //a variável que será atualiza é a "i". E já é controlada pelo para
   fimpara
//PARA TESTAR, SÓ TRATAREMOS O CASO ACIMA
//senao
//   para number2 ate number1  faca
//      escreva (number2)
//      number2+1
//   fimpara
fimse
fimAlgoritmo

 

Por favor, dê uma revisada. Tente entender os pontos...

 

Ai implementa a "outra parte".

 

Posta o "código final" aqui para revisarmos e, caso exista, posta o  "código que conseguiu implementar" e onde está com dúvidas.

 

No aguardo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Citação:

Spoiler
Em 04/04/2018 às 19:01, Simon Viegas disse:

Olá @Kazoii.

 

Existem alguns pontos a serem verificados. Para resumir, fiz algumas alterações, e inserir comentários para tentar explicar no próprio código.



algoritmo "FCdH"
// Leia dois números inteiros
// Armazene o menor valor em uma variável a e o maior em uma variável b
// Escreva todos os inteiros do intervalo [a, b]
var
    {number1, number2:inteiro} //por que em inglês?
    numero1, numero2:inteiro
    i :inteiro //auxiliar utilizado no
inicio
escreva("Digite o primeiro numero: ")
leia(numero1)
escreva("Digite o segundo numero: ")
leia(numero2)
se (numero1 < numero2) ENTÃO
   {para de numero1 ate numero2} //sintaxe incompleta
   para i de numero1 ate numero2 faca
      {escreva(number1)}
      escreva(i)
      {numero1+1} //a variável que será atualiza é a "i". E já é controlada pelo para
   fimpara
//PARA TESTAR, SÓ TRATAREMOS O CASO ACIMA
//senao
//   para number2 ate number1  faca
//      escreva (number2)
//      number2+1
//   fimpara
fimse
fimAlgoritmo

 

Por favor, dê uma revisada. Tente entender os pontos...

 

Ai implementa a "outra parte".

 

Posta o "código final" aqui para revisarmos e, caso exista, posta o  "código que conseguiu implementar" e onde está com dúvidas.

 

No aguardo.

 

Muito obrigado Simon, eu confundi tudo ao fazer o PARA, eu achei que tinha que escrever a sequência, por isso ele não estava indo e lógico estava incompleto também, muito obrigado pela ajuda...

 

adicionado 1 minuto depois
var
    numero1, numero2:inteiro
    i :inteiro //auxiliar utilizado no
inicio
escreva("Digite o primeiro numero: ")
leia(numero1)
escreva("Digite o segundo numero: ")
leia(numero2)
se (numero1 < numero2) ENTÃO
   {para de numero1 ate numero2} //sintaxe incompleta
   para i de numero1 ate numero2 faca
      {escreva(number1)}
      escreva(i)
      {numero1+1} //a variável que será atualiza é a "i". E já é controlada pelo para
   fimpara
fimse
se (numero1 > numero2) ENTÃO
   {para de numero1 ate numero2} //sintaxe incompleta
   para i de numero2 ate numero1 faca
      {escreva(number1)}
      escreva(i)
      {numero1+1} //a variável que será atualiza é a "i". E já é controlada pelo para
   fimpara
fimse

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Kazoii.

 

Para complementar.

 

1#

Com são condições mutuamente excludentes, é necessário uso do senao. Ex.:

algoritmo "FCdH"
var
   numero1, numero2:inteiro
   i :inteiro
inicio
escreva("Digite o primeiro numero: ")
leia(numero1)
escreva("Digite o segundo numero: ")
leia(numero2)
se (numero1 < numero2) ENTÃO
   para i de numero1 ate numero2 faca
      escreva(i)
   fimpara
fimse
senao
   se (numero1 > numero2) ENTÃO
      para i de numero2 ate numero1 faca
         escreva(i)
      fimpara
   fimse
fimAlgoritmo

 

 

 

2#

O enunciado pede que use variáveis para receber o maior e menor valores...

Em 04/04/2018 às 18:43, Kazoii disse:

 Leia dois números inteiros
Armazene o menor valor em uma variável a e o maior em uma variável b
 Escreva todos os inteiros do intervalo [a, b]

 

Poderia ser algo como:

algoritmo "FCdH"
var
   numero1, numero2:inteiro
   a,b :inteiro
   i :inteiro
inicio
escreva("Digite o primeiro numero: ")
leia(numero1)
escreva("Digite o segundo numero: ")
leia(numero2)
se (numero1<=numero2) ENTÃO
   a<-numero1
   b<-numero2
senao
   a<-numero2
   b<-numero1
fimSe
para i de a ate b faca
   escreva(i)
fimPara
fimAlgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×