Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Kazoii

VisualG Repetição para não funcionando

Recommended Posts

Postado (editado)

Galera meu professor me deu esse exercício mais por motivos que não entendo ele nao quer rodar.

Escreva um programa que:
 Leia dois números inteiros
 Armazene o menor valor em uma variável a e o maior em uma variável b
 Escreva todos os inteiros do intervalo [a, b]

Programação:

Var
// Seção de Declarações das variáveis 
number1, number2:inteiro
Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
escreva("Digite o primeiro numero: ")
leia(number1)
escreva("Digite o segundo numero: ")
leia(Number2)
se (number1 < number2) então
PARA de number1 ate number2 FAÇA
escreva (number1)
number1+1
fimpara

senao 
para number2 ate number1  faca
escreva (number2)
number2+1
fimpara
fimse

 

Editado por Simon Viegas
Inserir tag CODE
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Kazoii.

 

Existem alguns pontos a serem verificados. Para resumir, fiz algumas alterações, e inserir comentários para tentar explicar no próprio código.

algoritmo "FCdH"
// Leia dois números inteiros
// Armazene o menor valor em uma variável a e o maior em uma variável b
// Escreva todos os inteiros do intervalo [a, b]
var
    {number1, number2:inteiro} //por que em inglês?
    numero1, numero2:inteiro
    i :inteiro //auxiliar utilizado no
inicio
escreva("Digite o primeiro numero: ")
leia(numero1)
escreva("Digite o segundo numero: ")
leia(numero2)
se (numero1 < numero2) ENTÃO
   {para de numero1 ate numero2} //sintaxe incompleta
   para i de numero1 ate numero2 faca
      {escreva(number1)}
      escreva(i)
      {numero1+1} //a variável que será atualiza é a "i". E já é controlada pelo para
   fimpara
//PARA TESTAR, SÓ TRATAREMOS O CASO ACIMA
//senao
//   para number2 ate number1  faca
//      escreva (number2)
//      number2+1
//   fimpara
fimse
fimAlgoritmo

 

Por favor, dê uma revisada. Tente entender os pontos...

 

Ai implementa a "outra parte".

 

Posta o "código final" aqui para revisarmos e, caso exista, posta o  "código que conseguiu implementar" e onde está com dúvidas.

 

No aguardo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
Postado (editado)

Citação:

Spoiler
Em 04/04/2018 às 19:01, Simon Viegas disse:

Olá @Kazoii.

 

Existem alguns pontos a serem verificados. Para resumir, fiz algumas alterações, e inserir comentários para tentar explicar no próprio código.



algoritmo "FCdH"
// Leia dois números inteiros
// Armazene o menor valor em uma variável a e o maior em uma variável b
// Escreva todos os inteiros do intervalo [a, b]
var
    {number1, number2:inteiro} //por que em inglês?
    numero1, numero2:inteiro
    i :inteiro //auxiliar utilizado no
inicio
escreva("Digite o primeiro numero: ")
leia(numero1)
escreva("Digite o segundo numero: ")
leia(numero2)
se (numero1 < numero2) ENTÃO
   {para de numero1 ate numero2} //sintaxe incompleta
   para i de numero1 ate numero2 faca
      {escreva(number1)}
      escreva(i)
      {numero1+1} //a variável que será atualiza é a "i". E já é controlada pelo para
   fimpara
//PARA TESTAR, SÓ TRATAREMOS O CASO ACIMA
//senao
//   para number2 ate number1  faca
//      escreva (number2)
//      number2+1
//   fimpara
fimse
fimAlgoritmo

 

Por favor, dê uma revisada. Tente entender os pontos...

 

Ai implementa a "outra parte".

 

Posta o "código final" aqui para revisarmos e, caso exista, posta o  "código que conseguiu implementar" e onde está com dúvidas.

 

No aguardo.

 

Muito obrigado Simon, eu confundi tudo ao fazer o PARA, eu achei que tinha que escrever a sequência, por isso ele não estava indo e lógico estava incompleto também, muito obrigado pela ajuda...

 

adicionado 1 minuto depois
var
    numero1, numero2:inteiro
    i :inteiro //auxiliar utilizado no
inicio
escreva("Digite o primeiro numero: ")
leia(numero1)
escreva("Digite o segundo numero: ")
leia(numero2)
se (numero1 < numero2) ENTÃO
   {para de numero1 ate numero2} //sintaxe incompleta
   para i de numero1 ate numero2 faca
      {escreva(number1)}
      escreva(i)
      {numero1+1} //a variável que será atualiza é a "i". E já é controlada pelo para
   fimpara
fimse
se (numero1 > numero2) ENTÃO
   {para de numero1 ate numero2} //sintaxe incompleta
   para i de numero2 ate numero1 faca
      {escreva(number1)}
      escreva(i)
      {numero1+1} //a variável que será atualiza é a "i". E já é controlada pelo para
   fimpara
fimse

 

Editado por Simon Viegas
Inserir tag CODE no código; Inserir tag SPOILER na citação
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Kazoii.

 

Para complementar.

 

1#

Com são condições mutuamente excludentes, é necessário uso do senao. Ex.:

algoritmo "FCdH"
var
   numero1, numero2:inteiro
   i :inteiro
inicio
escreva("Digite o primeiro numero: ")
leia(numero1)
escreva("Digite o segundo numero: ")
leia(numero2)
se (numero1 < numero2) ENTÃO
   para i de numero1 ate numero2 faca
      escreva(i)
   fimpara
fimse
senao
   se (numero1 > numero2) ENTÃO
      para i de numero2 ate numero1 faca
         escreva(i)
      fimpara
   fimse
fimAlgoritmo

 

 

 

2#

O enunciado pede que use variáveis para receber o maior e menor valores...

Em 04/04/2018 às 18:43, Kazoii disse:

 Leia dois números inteiros
Armazene o menor valor em uma variável a e o maior em uma variável b
 Escreva todos os inteiros do intervalo [a, b]

 

Poderia ser algo como:

algoritmo "FCdH"
var
   numero1, numero2:inteiro
   a,b :inteiro
   i :inteiro
inicio
escreva("Digite o primeiro numero: ")
leia(numero1)
escreva("Digite o segundo numero: ")
leia(numero2)
se (numero1<=numero2) ENTÃO
   a<-numero1
   b<-numero2
senao
   a<-numero2
   b<-numero1
fimSe
para i de a ate b faca
   escreva(i)
fimPara
fimAlgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×