Ir ao conteúdo
  • Cadastre-se
nldj

PHP Indicação de Framework PHP

Recommended Posts

Tenho uma aplicação web hospedada num Cloud Windows na locaweb rodando PHP 5.3 com banco de dados sql server.

 

Eu programo no modo procedural. Gostaria de obter indicações de framework, uma vez que nunca utilizei e tenho pouca familiaridade com orientação a objetos e tenho pouca familiaridade com orientação a objetos.

Compartilhar este post


Link para o post
Compartilhar em outros sites

É brabo no começo! e eu ainda sei muito pouco e por isso ainda uso a forma procedural, mas separo os módulos PHP usando técnica parecida com MVC só que em pastas e dessa forma fica bem organizado e fácil de dar suporte !

 

Usar frameworks requer um nível conhecimento na linguagem já bem avançado. 

 

O Framework PHP mais queridinho é o LARAVEL.

 

Você pode fazer um curso gratuito sobre o LUMEN, que é uma versão reduzida do Laravel pela TIM Tec https://cursos.timtec.com.br/course/desenvolvimento-web-php/intro

 

Pode fazer o cadastro aqui: https://cursos.timtec.com.br/courses e depois ir no link acima do curso em específico.

Além dele tém varios outros totalmente gratuítos (JavaScript, Angular, SQl, etc....)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Verdade, tem outros, mas é questão de gosto ou adaptação.

veja aqui o ranking 2018 dos frameworks para PHP

https://coderseye.com/best-php-frameworks-for-web-developers/

 

image.png.479444fc1759adb4db9799be76b279aa.png

 

É sempre bom testar alguns desses frameworks vamos dizer mais "aclamados" e veja com qual se adapta melhor.

 

Eu tô me lascando mais com Laravel porque vejo muitos anûncios de emprego exigindo conhecimento nesse framework

Compartilhar este post


Link para o post
Compartilhar em outros sites

Além de ser uma questão de gosto e requerer um nível já bem avançado de orientação a objeto, o framework tem que ser compatível com as configurações do PHP 5.3 presentes em meu servidor hospedado na Locaweb. O Laravel é o mais popular (eu sei), mas se não me engano é para versões maiores ou iguais a 7 do PHP. 

 

Eu programo da forma procedural, e também separo os módulos em pastas. Gostei da sugestão do microframewor LUMEN, ainda mais pela disponibilidade do curso gratuito, afinal sei que no começo vai ser difícil.

 

Obrigado a todos!

Compartilhar este post


Link para o post
Compartilhar em outros sites
14 horas atrás, nldj disse:

Além de ser uma questão de gosto e requerer um nível já bem avançado de orientação a objeto, o framework tem que ser compatível com as configurações do PHP 5.3 presentes em meu servidor hospedado na Locaweb. O Laravel é o mais popular (eu sei), mas se não me engano é para versões maiores ou iguais a 7 do PHP. 

 

Eu programo da forma procedural, e também separo os módulos em pastas. Gostei da sugestão do microframewor LUMEN, ainda mais pela disponibilidade do curso gratuito, afinal sei que no começo vai ser difícil.

 

Obrigado a todos!

 

Sim o Laravel 5.6 requer uso do PHP7, porém as versões anteriores ainda são disponíveis para download, veja.

image.png.b0c13fe1ef1c749303fabced55a57f43.png

 

O Laravel 5.4 requer no mínimo o PHP 5.6.4 (a que eu uso mais).

 

Sim a promessa do LUMEN é ser menor e mais leve e com bem menos módulos, o LUMEN vem com o que é mais importante e usual do Laravel, então quando migrar tudo para o Laravel a diferença não será notada.

Compartilhar este post


Link para o post
Compartilhar em outros sites

levei uma semana para aprender o php básico, e logo a parte de orientação a objetos. você pode se atualizar aqui: https://www.cursoemvideo.com/

Inclusive você pode obter um certificado de realização do curso. Como você ja sabe programar em php é só fazer a parte de programação a objetos e partir para o laravel.
 

E logo fazer esse curso aqui sobre laravel:


Atualize-se.... vale a pena. Não levo mais de uma semana e já aprendi um montão.
Acredite... não sei muito de programação web pois levo 6 anos com C/C++ shuesuheushu

Sorte.

Compartilhar este post


Link para o post
Compartilhar em outros sites

A versão mínima do Laravel é a 4.2, e ela requer o PHP 5.4. E a versão mínima do LUMEN é a 5.1 para PHP 5.5

 

Meu servidor só roda PHP 5.3

Compartilhar este post


Link para o post
Compartilhar em outros sites

É! bom! de acordo com a necessidade ou melhor viabilidade, seria fazer um upgrade do PHP, até porque tem coisas que já estão depreciadas em 5.3, mas acredito que não lhe afetem, mas é bom ver a viabilidade do upgrade.

  • Curtir 3

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×