Ir ao conteúdo
  • Cadastre-se
RJacques

PHP Index.php não carrega no Mobile

Recommended Posts

Pessoal, eu tenho um site feito em html mas no meio do site coloquei um php para puxar post e imagens do blog, nos browsers de pc o site abre normalmente,

mas no celular o index.php só carrega até a parte que começa o codigo php que coloquei, o resto da página não está carregando.

alguem saberia me dizer o que poderia ser.

 

segue link da página http://pluripublicidade.com.br/clinicadacoluna/index.php

 

att

Richardy

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sua página está abrindo normalmente pela url: http://pluripublicidade.com.br/clinicadacoluna/ SEM  nenhuma pagina INDEX no final da url, pois ela carerega normalmente internamente sozinho e está abrindo no mesmo url http://pluripublicidade.com.br/clinicadacoluna/index.php com essa index.php.

 

Se clicar  na imagem DO LOGOTIPO ou no item de menu INICIO, abre essa url : http://pluripublicidade.com.br/clinicadacoluna/index.html

erro1.jpg.17f0ec98e5f327f115b5ab9107285af6.jpg

 

e dá esse erro:

erro2.jpg.7857a6c8138bafadf742075fad16bace.jpg

 

Mas se voce clicar no item de menu CORPO CLINICO, e clicar novamente NO LOGOTIPO ou INICIO

as duas abrem essa url: http://pluripublicidade.com.br/clinicadacoluna/index.php

 

E nesse momento se clicar novamente em NO LOGOTIPO ou INICIO as duas vão dar erro e abrir a url: http://pluripublicidade.com.br/clinicadacoluna/index.html

 

Percebeu que o erro é o 404?

 

Está com erros de redirecionamento na sua URL que está hora apontando para pagina INDEX.PHP e  outrora para INDEX.HTML.

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@RJacques  jamais use dois arquivos index!   escolha um e use. Por padrão, acho melhor sempre fazer com o php.

Compartilhar este post


Link para o post
Compartilhar em outros sites

então, agradeço as observações, mas como falei eu estou alterando o site para php, pois precisei incrementar o codigo para puxar os posts, por isso não alterei o restante dos links.

mas essa pagina index.php ela nao carrega inteira no mobile,

Compartilhar este post


Link para o post
Compartilhar em outros sites
7 minutos atrás, RJacques disse:

então, agradeço as observações, mas como falei eu estou alterando o site para php, pois precisei incrementar o codigo para puxar os posts, por isso não alterei o restante dos links.

mas essa pagina index.php ela nao carrega inteira no mobile,

abri seu link e parte da página carrega normalmente o corpo e o que não aparece é o rodapé que eu acho que não está carregando e o menu do navbar não abre as opções de menu.

Está usando o que ? Bootstrap?

Se for está fazendo algo errado ao carregar alguma classe ou pode ser a ordem de carregamento das classes que não está correta.

Se for o caso de estar usando Bootstrap, sugiro ler atentamente a página de documentação e ter certeza que está seguindo as recomendações, inclusive se sua página inicial segue o template necessário: https://v4-alpha.getbootstrap.com/getting-started/introduction/#starter-template

 

Mesmo que esteja migrando totalmente o site para PHP, ela irá rodar sobre uma base HTML, então se a base estiver com problemas o retorno server side do PHP virá com certos problemas de exibição.

Compartilhar este post


Link para o post
Compartilhar em outros sites

olá, Jonny então, a página ela vai ter somente uma parte de php, uma parte pequena, sendo que se eu tiro essa parte de código que contem o php o index abre normalmente sem problema alguma, mas quando coloca esse bloco de código o site só carrega até o inicio desse bloco o restante do site pra baixo não carrega nada.

Compartilhar este post


Link para o post
Compartilhar em outros sites
20 minutos atrás, RJacques disse:

olá, Jonny então, a página ela vai ter somente uma parte de php, uma parte pequena, sendo que se eu tiro essa parte de código que contem o php o index abre normalmente sem problema alguma, mas quando coloca esse bloco de código o site só carrega até o inicio desse bloco o restante do site pra baixo não carrega nada.

bom dia!

 

Tem que ver como esse seu código PHP está sendo implementado e o que voce quer retornar via PHP, pois se forem informações de um BD tudo bem, é necessário usar o PHP, mas se for o caso de informação estática tem outras ferramentas como JQuery/Ajax junto ao Bootstrap que podem lhe ajudar a montar um layout totalmente html inclusive com recursos de loading de imagens, videos, etc...

 

Acredito ser necessário voce postar seu código para ser feito uma análise do caso e verificar o porque disso estar acontecendo na sua página.

 

Não sou expert em PHP, estou voltando a ativa como programador aos poucos, mas no pouco que sei e se eu puder lhe ajudo, pois para mim é bom colocar a cuca para funcionar novamente!

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×