Ir ao conteúdo
  • Cadastre-se
JorgeSouza

Excel Puxar texto com caractere específico

Recommended Posts

Fala pessoas, de boa?

 

Eu queria saber se tem algum jeito de puxar um texto/palavra que tenha um caractere específico. Como assim?

 

                      1

A   contato@contato.com.br

 

Aí eu digito a fórmula para puxar tudo que tenha "@" naquela célula, é possível fazer isso?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Considerando-se que os dados que quer retornar comece na celula A2. 

 

Experimente

 

Exemplo

 

=SEERRO(ÍNDICE($A$2:$A$20;MENOR(SE(CONT.SE($A$2:$A$20; "*@*")>0;LIN($A$2:$A$20)-1);LIN(A1));1);"")

 

Como se trata de uma formula matricial, você pressiona Ctrl+Shift+Enter, o Excel coloca a fórmula entre chaves ({ }) e insere uma instância da fórmula em cada célula do intervalo selecionado.

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@JorgeSouza , Bom Dia.

 

Confere esta exemplo se esta correto para você

 

Se foi útil clica no curtir é uma forma de agradecimento pela ajuda

Se você Visitante Também gostou e foi útil pode clicar no Curtir

 

Decio

 

Exemplo Decio.xlsx

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigado senhores!

 

Dúvida resolvida :D

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×