Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Aploxy

Portugol Calcular salário a ser pago

Recommended Posts

5ad901b171bd1_Semttulo.png.4930b48d251922f77b3ba02307478dd9.png

 

Como faço para limitar um valor de salário para aumentar em porcentagem ?

 

Ex: Preciso informar o nome e o salário. 

Funcionários que ganham entre 5 e 7mil o aumento vai ser de 14%, e o resultado precisa ser o salario mais a porcentagem. 

E que condição eu uso, se então ?

 

Editado por Aploxy
Melhoria

Compartilhar este post


Link para o post
Compartilhar em outros sites

Deixa eu ver se entendi, você tem um limite máximo de salário,  exemplo :

Limite 10mil reais.

você quer implementar uma rotina que recebe o nome e o salário de determinado funcionário, e apresenta o valor e o percentual aumentado, até chegar no limite de 10 mil reais ?!

Compartilhar este post


Link para o post
Compartilhar em outros sites
16 minutos atrás, jerfesonguerreiro disse:

Deixa eu ver se entendi, você tem um limite máximo de salário,  exemplo :

Limite 10mil reais.

você quer implementar uma rotina que recebe o nome e o salário de determinado funcionário, e apresenta o valor e o percentual aumentado, até chegar no limite de 10 mil reais ?!

Não, 

 

Eu preciso dizer a porcentagem, conforme o salário. Se ele ganha de 8.000 até 10.000 ele vai ganhar tantos porcento de aumento. O funcionário que ganha menos que 8.000 vai ganhar outra porcentagem, e por ai vai. 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pode usar se então se forem poucas faixas de salário. Se forem muitas faixas o código fica confuso e existem formas melhores.

Compartilhar este post


Link para o post
Compartilhar em outros sites
se salario => 7000 e salario <= 10000 então
   salario = salario*1.17
fimse

 

Isso vai aumentar o salário em 17% na faixa entre 7.000 e 10.000 reais.

Editado por Luís Roberto C. da Silva
  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Resolvido obrigado !

 

se (s >= 8.000) e (s <10.000) então
    r <- s+s*0.06
fimse
Editado por Simon Viegas
Botão code <>
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

@Aploxy, qual o enunciado do problema?

 

Pois é necessário analisar as "regras" especificamente, por exemplo:

 

10 horas atrás, Aploxy disse:

Funcionários que ganham entre 5 e 7mil o aumento vai ser de 14%, e o resultado precisa ser o salario mais a porcentagem.

 

Esse "entre" inclui os 5 e o 7? ou seja, vai suar >= ou >... assim como <= ou <?

 

Veja o exemplo:

8 horas atrás, Aploxy disse:

se (s >= 8.000) e (s <10.000) então
    r <- s+s*0.06
fimse

 

Por que num lado usou >= e no outro < (sem o =)?

 

 

Resumindo:

Se possível, poste o enunciado completo, assim como o código atual para analisarmos.

 

No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Citação

var
n : literal
s, r : real
inicio
escreval("Digite o nome do funcionário:")
leia(n)
escreval("Digite o salário:")
leia(s)
se s >= 10.000 então
   r <- s+s*0.04
senao
   se (s >= 8.000) e (s <10.000) então
      r <- s+s*0.06
   senao
      se (s >= 7.000) e (s <8.000) então
         r <- s+s*0.08
      senao
         se (s < 7.000) então
            r <- s+s*0.1
         fimse
      fimse
   fimse
fimse
escreval("Valor do salário:", n, r)

fimalgoritmo
 

 

Editado por Aploxy
Melhoria

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×