Ir ao conteúdo
  • Cadastre-se
vclima95

Nenhuma distribuição linux funciona no meu computador

Recommended Posts

Olá, tem algi muito estranho acontecendo no meu notebook. Toda vez que coloco o live usb nele ele simplesmente reinicia no meio da inicialização (depois do GRUB, então não é problema de BIOS). Já tentei 3 distribuições diferentes (Antergos, Debian e Ubuntu) criadas com o rufus e pelo DD no terminal. O computador funciona perfeitamente com o windows, inclusive estou usando ele. Já procurei ajuda em um fórum do antergos e tudo me me falaram pra fazer não funcionou (incluir como kernel parameters panic=0 i915.enable_guc_loading=1 i915.enable_guc_submission=1). Ele simplesmente apaga a tela sem nenhuma mensagem e inicia de novo, como se tivesse segurando o botão de power. 
Estas são as especificações dele:

Computer:
  Computer Type                                     PC ACPI de base x64
  Operating System                                  Microsoft Windows 10 Home Single Language
  Internet Explorer                                 11.371.16299.0
  Edge                                              41.16299.371.0
  DirectX                                           DirectX 12.0
  Computer Name                                     LAPTOP-0915CLML
  User Name                                         Victor
  Date / Time                                       2018-04-14 / 18:35

Motherboard:
  CPU Type                                          DualCore Intel Core i5-6200U, 2800 MHz (28 x 100)
  Motherboard Name                                  Acer F5-573
  Motherboard Chipset                               Intel Sunrise Point-LP, Intel Skylake-U
  DIMM1: Kingston ACR24D4S7S8MB-8                   8 GB DDR4-2400 DDR4 SDRAM  (21-17-17-39 @ 1200 MHz)  (20-17-17-39 @ 1200 MHz)  (19-17-17-39 @ 1200 MHz)  (18-17-17-39 @ 1200 MHz)  (17-17-17-39 @ 1200 MHz)  (16-16-16-38 @ 1163 MHz)  (15-15-15-35 @ 1090 MHz)  (14-14-14-33 @ 1018 MHz)  (13-13-13-31 @ 945 MHz)  (12-12-12-28 @ 872 MHz)  (11-11-11-26 @ 800 MHz)  (10-10-10-24 @ 727 MHz)

Display:
  Video Adapter                                     Intel(R) HD Graphics 520  (1 GB)
  Video Adapter                                     Intel(R) HD Graphics 520  (1 GB)
  Video Adapter                                     Intel(R) HD Graphics 520  (1 GB)
  3D Accelerator                                    Intel HD Graphics 520
  Monitor                                           LG Philips LP156WHU-TPE1  [15.6" LCD]

Multimedia:
  Audio Adapter                                     Intel Skylake HDMI @ Intel Sunrise Point-LP PCH - High Definition Audio Controller
  Audio Adapter                                     Realtek ALC255 @ Intel Sunrise Point-LP PCH - High Definition Audio Controller

Storage:
  IDE Controller                                    Intel(R) 6th Generation Core Processor Family Platform I/O SATA AHCI Controller
  IDE Controller                                    Realtek PCIE CardReader
  Storage Controller                                Controlador de Espaços de Armazenamento da Microsoft
  Disk Drive                                        WDC WD10JPVX-22JC3T0  (1 também, 5400 RPM, SATA-III)
  Optical Drive                                     HL-DT-ST DVDRAM GUE1N
  SMART Hard Disks Status                           OK

edit: Já tentei com um DVD fisico, gravando a ISO e a mesma coisa aconteceu

Compartilhar este post


Link para o post
Compartilhar em outros sites

Deve ser porque a BIOS está configurada pra dar boot em modo UEFI. Infelizmente isso não é padronizado e cada BIOS tem uma opção diferente, mas todas essas opções são referentes as configurações "IDE/sata/boot mode/SO".

Procure alguma opção na BIOS que permita alternar entre "Boot UEFI", "Boot Legacy", "Boot SO" etc. Tenha em mente que essa configuração ajusta a placa-mãe pra iniciar o Windows 10 ou outros Sistemas, caso ative a opção dos outros sistemas, é possível que o Windows 10 não funcione, necessitando assim reiniciar o computador e alterar novamente a opção na BIOS para que seu computador inicie o Windows 10 como de costume.

Pesquise por imagens no google sobre "Boot legacy / UEFI" e veja as imagens, isso vai te dar uma pista sobre onde você tem que ir. e lembre-se:

UEFI Ativado: Geralmente o Windows 10 requer essa opção e os outros sistemas não conseguem iniciar

Legacy: Geralmente o windows 10 não funciona, mas os outros SO's sim.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@vclima95 ele reinicia antes de começar o live ou depois que você instala? Não ficou claro para mim se o note funciona com a iso live e não funciona instalado, ou não funciona nem com a live. Todas as três acontece a mesma coisa?

 

Passei por uns fóruns da Acer em que há várias reclamações parecidas com a sua. Parece que a solução não tem a ver com o pendrive, mas com a bios. você tem que entrar na bios e adicionar o GRUB nas configurações de secure boot. Aí reinicia, dá f12 (ou o que seja) para inciar pelo pendrive e ele vai aceitar a instalação...

 

os dois sites que me pareceram mais esclarecedores:

https://community.acer.com/en/discussion/386009/acer-aspire-e5-573g-you-can-not-install-any-one-linux-distribution-the-problem-bios-1-25/p2

5. Go in to your BIOS settings and add Grub to the trusted secure boot settings.  Don't disable secure boot.
6.  Install linux,
Again, make sure you read all of the posts in this https://community.acer.com/en/discussion/comment/516864#Comment_516864 and any supporting links within.

 

ou

https://community.acer.com/en/discussion/488206/install-ubuntu-for-f5-573g-765c

You have to got to the Bios. Security>select efi file as tusted>klick through until for e.g. grub64 or so. you must give a name for this boot entry.  You cannot damage something here seriously. After you must save Bios settings and reboot and again to the Bios. Now you can choose the created "boot device!" or you just press F12 while booting and choose it.

 

adicionado 1 minuto depois

@CiroboyBR pelo menos o Ubuntu não tem mais esse problema, ele aceita secure boot e uefi. Debian também não deve ter.

Compartilhar este post


Link para o post
Compartilhar em outros sites
14 minutos atrás, Arutha disse:

@CiroboyBR pelo menos o Ubuntu não tem mais esse problema, ele aceita secure boot e uefi. Debian também não deve ter.

Na teoria e na prática? você já tentou instalar o ubunto 17 em uma placa-mãe com uefi ativado? E instalou sem problemas?

O que você acha que é esse SECURE BOOT?

Compartilhar este post


Link para o post
Compartilhar em outros sites

@CiroboyBR na prática. Pra mim não deu problema nenhum. Bom, o 16.04, ainda não cheguei no 17 por falta de HD novo em casa.

Agora não precisa ficar bravo, pode ser que em alguns sistemas ainda dê problema, tanto que, se você olhar, minha sugestão para o@vclima95 passa justamente, não por desativar, mas por adicionar o instalador do linux nas opções de secure boot. Eu não sou a pessoa mais expert do mundo, mas uso ubuntu há muito tempo e estou sempre checando essas coisas no fórum deles. Isso quer dizer que mantenho meu conhecimento mais ou menos atualizado, mas também significa que posso dizer ou entender algo errado.

Agora o secure boot é uma segurança para impedir ataques:

"Sua função é evitar que drivers e loaders não autorizados, sejam executados em tempo de boot. Isso evita falhas de segurança exploradas por malwares do tipo bootkit."

 

NÃO é, definitivamente, uma coisa criada para uso apenas da microsoft, ou para impedir a instalação de outros sistemas operacionais. O Ubuntu 64bits trabalha com isso desde a versão 12. Hoje em dia os problemas de instalação de linux têm muito mais a ver com gpt do que com Uefi e secure boot.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu descartei o problema de boot porque ele inicializa o sistema linux, mas durante o carregamento do sistema reinicia. O Live foi criado como GPT para UEFI, abre sem problema até a parte onde escolho como vai iniciar (no caso do Antergos permite escolher entre a versão clássica, uma versão com drivers gráficos padrão e o boot EFI padrão) quando eu escolho qualquer uma das duas versões ele inicia o carregamento e morre. Tanto o secure boot quanto o TMP estão desativados na BIOS. @Arutha ele reinicia antes de começar o Live, eu tenho um HD externo com uma versão do Deepin instalada que acontece a mesma coisa.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pois siga a sugestão lá dos fóruns: ative o secure boot com o pendrive espetado e adiciona aos instaladores confiáveis.

quem sabe dá certo?

3 minutos atrás, vclima95 disse:

Eu descartei o problema de boot porque ele inicializa o sistema linux

Ele inicializa porque o linux usa secureboot e paralisa porque não está na lista de confiáveis? estou raciocinando aqui com as informações que vi, não estou dizendo que é isso rsss

Compartilhar este post


Link para o post
Compartilhar em outros sites

É estranho porque eu ja tive problemas com secure boot antes e congelava antes de inicializar o grub, mas de qualquer forma estou tentando o procedimento do fórum, não é como se eu tivesse alguma ideia melhor mesmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Arutha Instalei diversos Linux nos meus notebooks e PCs, dentre eles Ubunto, Kali, Backtrack, Slitaz, BackBox etc. Sempre dava alguma incompatibilidade, quando não era na instalação era na atualização do linux. Não dá pra manter um treco desses ativado com um SO Linux, sempre tem a possibilidade de ocorrer um erro.

Resumindo, pra evitar dor de cabeça é só desativar. O preço da segurança adicional que o UEFI provê não é viável (a meu ver).

 

21 minutos atrás, Arutha disse:

Agora não precisa ficar bravo

Não estou bravo e não sei de onde você tirou isso.

Compartilhar este post


Link para o post
Compartilhar em outros sites
4 minutos atrás, CiroboyBR disse:

Instalei diversos Linux nos meus notebooks e PCs, dentre eles Ubunto, Kali, Backtrack, Slitaz, BackBox etc. Sempre dava alguma incompatibilidade, quando não era na instalação era na atualização do linux. Não dá pra manter um treco desses ativado com um SO Linux, sempre tem a possibilidade de ocorrer um erro.

Resumindo, pra evitar dor de cabeça é só desativar. O preço da segurança adicional que o UEFI provê não é viável (a meu ver).

 

Beleza, experiências diferentes, conclusões diferentes.

Independentemente da nossa discussão, o que eu achei nos fóruns da acer é que a instalação funciona se mantiver ativado e adicionar o grub. Se der certo, o colega @vclima95 vai nos contar.

 

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

É, não funcionou. Tentei as duas abordagens. Criei um LiveUSB GPT/UEFI, liguei o secure boot novamente e adicionei na lista de confiáveis. Depois criei um MBR/Legacy, mudei o modo de boot na BIOS e reiniciou da mesma forma.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@vclima95 puxa que chato! O colega @Marcos FRM sugeriu atualizar a bios e eu lembro daquele fórum da Acer que alguns falavam disso também, mas ao contrário: que a última atualização da bios é que tinha criado o problema. Como o tópico era um pouco antigo, imaginei que não fosse importante e você já tivesse atualizado a bios. Se não o fez, é uma opção.

De resto, não sei o que mais sugerir. Se fosse um PC AMD, eu lembro

Acabei de lembrar uma bobagem enorme, mas que pode ser: você tem windows 10 certo? A inicialização rápida está ativada? Ela é um treco que em vez de desligar o HD deixa ele num modo de hibernação híbrido, inacessível para outros sistemas. Ou seja, pode ser que o pendrive de instalação não consiga copiar coisas para o HD! Tente desativá-la, seguem várias "receitas":

 

Vá para o windows 10 e em configuração clique em energia (ou sistema e depois energia, não lembro de cabeça), clique em   Configurações de energia adicionais e no lado esquerdo da janela, clique em Escolher o que faz o botão de energia, e na tela seguinte em "Alterar configurações não disponíveis no momento". Logo abaixo desclique o "ligar a inicialização rápida".

Ou desative o hibernar

ou altere o registro:

No executar digite regedit e tecle enter

Navegue até a chave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Power

Do lado direito no ítem   HiberbootEnabled   dê dois cliques e deixe com o valor 0

reinicie

ou use o prompt de comando

Abra o cmd como administrador;

Digite powercfg -h off e aperte Enter;

reinicie

 

Depois você pode voltar a ativar a hibernação. Poderá entrar no linux quando quiser, mas não terá acesso aos arquivos do win10.

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
50 minutos atrás, Marcos FRM disse:

A questão do NTFS não deve ser relevante.

 

Tem tudo para ser bug no firmware e/ou no kernel.

 

Era no kernel mesmo, adicionei o parametro "intel_pstate=no_hwp" e bootou normal. Achei a solução aqui https://bbs.archlinux.org/viewtopic.php?id=208352.

Obrigado pela ajuda galera :thumbsup:

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×