Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Marcelo Saldanha

VisualG Algoritmos, mostrar quantidade de divisores

Recommended Posts

Boa Tarde pessoal

se possível alguém me dar uma ajuda

eu tenho que criar um algoritmo que de o quadrado de um numero depois o cudo , os divisores e o primo

pois não consegui fazer com que diga a quantidade de divisores só consegui mostrar os divisores como posso fazer pra mostrar somente a quantidade?

Algoritmo "Atividade 3"

Var
   rep, qd, cb, resto, i, aux  : inteiro
   cabecalho : caractere

Inicio
   cabecalho <- "Numero Quadrado Cubo Divisores Primos"
   escreval (cabecalho)
   para rep de 01 ate 20 faca
      escreva(rep, "")
      qd <- rep * rep
      escreva (qd, "")
      cb <- (rep * rep) * rep
      escreva (cb, "")
      para resto de 1 ate rep faca
         se (rep mod resto = 0) então
            escreva(resto)
         fimse
      fimpara
      aux <- 0
      para i de 2 ate rep -1 faca
         se rep mod i = 0 então
            aux <- aux +1
         fimse
      fimpara
      se aux = 0 então
         escreva ("sim")
      senao aux =
         escreva ("nao")
      fimse
      escreval("")

   fimpara

Fimalgoritmo

 

Editado por Simon Viegas
Inserir tag CODE
  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

@Marcelo Saldanha, na sua pergunta já tem a resposta.

 

23 horas atrás, Marcelo Saldanha disse:

não consegui fazer com que diga a quantidade de divisores só consegui mostrar os divisores como posso fazer pra mostrar somente a quantidade?

Não é para mostrar os divisores, mas sim a quantidade de divisores, logo em vez de mostrar ao encontrar um divisor, vá "contando".. Após mostra a quantidade.

 

Abaixo segue um com essa alteração, mais um conjunto de outras sugestões. Sugiro que tente ajustar o seu próprio código antes... mas caso deseje, dê uma analisada no código e vá comparando abaixo. Tente entender cada mudança. Caso tenhas dúvidas, é só perguntar.

 

Ai, a depender vai implementando uma coisa ou outra no seu.

Algoritmo "Atividade 3"
Var
   cabecalho   :caractere
   numero      :inteiro //numero sendo verificado (de 1 a 20)
   quadrado    :inteiro //quandro do número
   cubo        :inteiro //cubo do número
   qtdDivisores:inteiro //quantidade de divisores do número
   divisor     :inteiro //auxiliar para verificar a quantidade de divisores
   
Inicio
cabecalho <- "Numero Quadrado Cubo Divisores Primos"
escreval(cabecalho)
para numero de 1 ate 20 faca
   //o número em si
   escreva(numero:4)
   //quadrado do número
   quadrado <- numero * numero
   escreva (quadrado:8)
   //cubo do número
   cubo <- quadrado * numero
   escreva (cubo:8)
   //quantidade de restos
   qtdDivisores <- 0
   para divisor de 1 ate numero faca
      se (numero mod divisor = 0) ENTÃO
         {escreva(divisor:8)} //não é para escrever
         qtdDivisores <- qtdDivisores + 1
      fimse
   fimpara
   escreva (qtdDivisores:6)
   //primo
   se qtdDivisores = 2 ENTÃO
      escreva ("":7,"Sim")
   senao
      escreva ("":7,"Nao")
   fimse
   escreval("")
fimpara
fimalgoritmo

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×