Ir ao conteúdo
  • Cadastre-se
carlosd17

Como resolver exercício de classificação de dados?

Recommended Posts

1. Um estudo estatístico sobre acidentes de trânsito foi realizado em 3.500 cidades brasileiras. Os dados coletados foram: • código de identifica¸c˜ao da cidade (valor inteiro, único para cada cidade) • nome da cidade • quantidade de veículos de passeio • quantidade de acidentes de trânsito com vítimas Escreva um algoritmo que realize a leitura dos dados desse estudo estatístico e apresente, como saída em tela: 1. o código e o nome da cidade que possuem o maior número de veículos 2. o código e o nome da cidade que possuem o menor número de veículos 3. o valor do maior índice de acidentes de trânsito, assim como o código e o nome da cidade `a qual pertence esse índice 4. o valor do menor índice de acidentes de trânsito, assim como o código e o nome da cidade `a qual pertence esse índice 5. o valor da média de acidentes de trânsito nas cidades que possuem menos de 2.000 veículos de passeio 6. o valor da média geral de acidentes de trânsito desse estudo

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro usuário,

 

Seja bem-vindo ao Fórum do Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a resposta está correta ou não, ou para que possa ser auxiliado com a dúvida no desenvolvimento do exercício.

 

Infelizmente, não há como resolver os trabalhos pelos usuários. O objetivo do Fórum do Clube do Hardware é auxiliar seus usuários a encontrar soluções para que possam sanar suas dúvidas, e não de trazer soluções prontas para seus usuários.. Além disso, copiar e colar respostas que não são de autoria própria do qualquer usuário é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
algoritmo "" 
var 
cidade, veiculos, acidentes: vetor[1..5] de inteiro 
maior_indice, cidade_maior, menor_indice, cidade_menor, soma_veic, media, soma_2000, cont_2000, i: inteiro 
inicio 
soma_veic <- 0 
soma_acidentes <- 0 
soma_2000 <- 0 
cont_2000 <- 0 
para i de 1 ate 5 faca 
escreva ("Informe o código da cidade ", i) 
leia (cidade) 
escreva ("Informe o número de automóveis: ") 
leia (veiculos) 
escreva ("Informe o número de acidentes: ") 
leia (acidentes) 
soma_veic <- soma_veic + veiculos 
se (i = 1) então 
menor_indice <- acidentes[1] / veiculos[1] 
cidade_menor <- cidade[1] 
maior_indice <- acidentes[1] / veiculos[1] 
cidade_maior <- cidade[1] 
senao 
se (menor_indice > acidentes/veiculos) então 
menor_indice <- acidentes / veiculos 
cidade_menor <- cidade 
fimse 
se (maior_indice < acidentes/veiculos) então 
maior_indice <- acidentes / veiculos 
cidade_maior <- cidade 
fimse 
fimse 
se (veiculos < 2000) então 
soma_2000 <- soma_2000 + acidentes 
cont_2000 <- cont_2000 + 1 
fimse 
fimpara 
escreval ("Maior índice de acidentes de transito: ", maior_indice, " na cidade: ", cidade_maior) 
escreval ("Menor índice de acidentes de transito: ", menor_indice, " na cidade: ", cidade_menor) 
escreval ("Média de veículos nas cinco cidades juntas: ", soma_veic / 5) 
escreval ("Média de acidentes de trânsito nas cidades com menos de 2.000 veículos de passeio: ", soma_2000 / cont_2000) 
fimalgoritmo 

 

pode olha e ver o que estou fazendo de errado

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

3 horas atrás, carlosd17 disse:

pode olha e ver o que estou fazendo de errado

 

O quê que está dando errado?


Precisamos saber antes o que está dando errado, para depois analisar onde está.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×