Ir ao conteúdo
  • Cadastre-se
david.palazzo

Excel média em mais de um intervalo

Recommended Posts

Boa tarde!

Preciso calcular a média mensal anual. Explico:

São três intervalos, no caso, um para cada quadrimestre. Entre cada intervalo tem a média do quadrimestre. Mas preciso também calcular a média mensal do ano, desconsiderando as células com zero. O problema ao aplicar as funções MEDIA ou MEDIASE ou MEDIASES, não consigo partilhar em três intervalos. Só funciona se considerar o intervalo todo, incluindo os resultados das médias quadrimestrais, e nesse caso, a média mensal retorna errado. Uma das tentativa, foi essa: =MÉDIASE(C3:C6;”>=0″)+MÉDIASE(C8:C11;”>=0″)+MÉDIASE(C13:C16;”>=0″) – não deu certo!
Outra:
=MÉDIASES(C3:C16;C3:C6;”>=1″;C8:C11;”>=1″;C13:C16;”>=1″) – não deu certo!
Será que tem uma saída?

ControleCompras.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite @david.palazzo

 

Normalmente o pessoal digita o resultado para permitir conferências, o que você não fez.

 

Experimente copiar e colar a formula abaixo na célula B19 e arrastar pela linha até a célula F19

 

=SOMARPRODUTO((DIREITA($A$3:$A$16;12)<>"quadrimestre")*($B3:$B16>0)*($B3:$B16))/SOMARPRODUTO((DIREITA($A$3:$A$16;12)<>"quadrimestre")*($B3:$B16>0))

Se foi útil, clique em curtir.

 

Dê retorno.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×