Ir ao conteúdo
  • Cadastre-se

Recommended Posts

Ola boa tarde #amigos.

Então sou iniciante no visualg, nisso estou perdido em 1 projeto que não sei como começa se não for pedi muito teria como vocês me ajuda é claro.

Esse é o projeto só não sei como vou consegui teria como vocês me ajuda.

"O sistema deverá ta funcionando que gerenciam o cliente, produto e fluxo de caixa"

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro usuário,

 

Seja bem-vindo ao Fórum do Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a resposta está correta ou não, ou para que possa ser auxiliado com a dúvida no desenvolvimento do exercício.

 

Infelizmente, não há como resolver os trabalhos pelos usuários. O objetivo do Fórum do Clube do Hardware é auxiliar seus usuários a encontrar soluções para que possam sanar suas dúvidas, e não de trazer soluções prontas para seus usuários.. Além disso, copiar e colar respostas que não são de autoria própria do qualquer usuário é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Luciano Florindo Breguêz Moreira        você quer cadastrar o cliente e os produto que ele comprou e o valor das compras ?
    para isso você precisa usar vetores para guardar os dados, e no final você pode imprimir cada cliente e os produtos e os valores de cada um , sendo assim você precisa criar um vetor do tipo caracter para o nome dos clientes, e outro vetor também do tipo caracter para o produto e outro do tipo inteiro para o valor, depois você usa um laço de repetição para pegar esses dados do usuário,  então em qual linguagem você pretende fazer esse código ?  

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Luciano Florindo Breguêz Moreira     faça aos poucos , se você já tiver estudado sobre vetores , então primeiro crie os vetores  para os nomes  e os produtos e os valor ,  depois coloque um laço de repetição que pode ser o repita / ate  e dentro desse laço pegue os nomes dos clientes e os nomes dos produtos e o valor de cada produto usando o comando leia  ,  colocando esses dados nos vetores .     faça  essa parte e poste aqui para podermos ver como está e em que podemos ajudar  .

Compartilhar este post


Link para o post
Compartilhar em outros sites
Var
n1,n2,n3,opcao: caracter
p1,p2,p3, v1,v2,v3,result: real

Inicio

escreval("Digite o nome do primeiro cliente")
leia(n1)
escreval("---------------------------------------------")
escreval("Digite o nome do segundo cliente")
leia(n2)
escreval("---------------------------------------------")
escreval("Digite o nome do terceiro cliente")
leia(n3)
escreval("---------------------------------------------")
escreval("Digite o valor do primeiro produto")
leia(v1)
escreval("---------------------------------------------")
escreval("Digite o valor do primeiro produto")
leia(v2)
escreval("---------------------------------------------")
escreval("Digite o valor do primeiro produto")
leia(v3)
escreval("---------------------------------------------")
escreval("| Escolha a opção desejada")
escreval("| 1- Somar valores dos produtos")
escreval("| 2- Mostrar valores dos produtos")
escreval("| 3- Mostrar produtos e valores")
leia(opcao)
---------------------------------------------

 result <- v1+v2+v3
escolha opcao
caso "1"
escreval("O valor dos produtos somados é: ",result)

caso "2"
escreval("O valor dos produtos é")
escreval("Maça: R$",v1)
escreval("Banana: R$",v2)
escreval("Pera: R$",v3)

caso "3"
escreval("Os produtos e os valores são:")
escreval("Maça: R$",v1)
escreval("Banan: R$",v2)
escreval("Pera: R$",v3)
escreval("O valor total é: ", result)

fimescolha


Fimalgoritmo

 

 

( Tipo eu fiz assim e se eu for fazer pelo "SE então" será que da certo ou nada tambem ?

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Luciano Florindo Breguêz Moreira     pelo jeito você está bem no início dos estudos de programação ,   pois você está repetindo códigos que o próprio programa deveria fazer ,   então eu nem poderia mas vou postar o seu código mais bem organizado para que você possa ter uma melhor visualização de como fazer ,  então seu código com algumas  modificações ficaria assim  :

Algoritmo "cadastrar clientes e produtos"
Var
n1,n2,n3,opcao,opcao2: caracter
p1,p2,p3, v1,v2,v3,result: real
cliente : vetor[1..100] de caracter
produto : vetor[1..100] de caracter
valor   : vetor[1..100] de inteiro
cont,j  : inteiro
Inicio
  cont:=1
  repita
    limpatela
    escreval("====  Escolha a opção desejada  ====")
    escreval("| 1- Somar valores dos produtos")
    escreval("| 2- Mostrar valores dos produtos")
    escreval("| 3- Mostrar produtos e valores")
    escreval("| 4- Cadastrar Clientes e Produtos")
    escreval("| 5- sair do programa")
    leia(opcao)
    result:=0
    escolha opcao
    caso "1"
      para j de 1 ate cont-1 faca
        result:=result+valor[j]
      fimpara
      escreval("O valor dos produtos somados é: ",result)
      escreval("    Tecle Enter")
      leia(opcao)
    caso "2"
      escreval("O Valor De Todos Os Produtos é")
      para j de 1 ate cont-1 faca
        escreval("Valor ",valor[j])
      fimpara
      escreval("    Tecle Enter")
      leia(opcao)
    caso "3"
      escreval("Mostrando Os Produtos E Valores")
      para j de 1 ate cont-1 faca
        result:=result+valor[j]
        escreval("Produto ",produto[j],"  --  Valor",valor[j])
      fimpara
      escreval("    Tecle Enter")
      leia(opcao)
    caso "4"
      repita
        escreval("Digite o Nome do Cliente")
        leia(cliente[cont])
        escreval("---------------------------------------------")
        escreval("Digite o nome do Produto")
        leia(produto[cont])
        escreval("---------------------------------------------")
        escreval("Digite o valor do produto")
        leia(valor[cont])
        escreval("---------------------------------------------")
        cont:=cont+1
        escreva("Quer Cadastrar Outro Cliente  S/N")
        leia(opcao2)
      ate opcao2="n"
    fimescolha
  ate opcao="5"
Fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×