Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
allanalencar

Portugol resolução de algoritmo portugol

Recommended Posts

23 minutos atrás, Simon Viegas disse:

1#
Os cálculos das médias só precisam ser calculados uma vez, ou seja, devem ficar fora do for.

Não entendi essa parte, tem algum cálculo que está "inútil" no código? @Simon Viegas

adicionado 39 minutos depois

Rodando 100%, testado e aprovado, dados testados na mão batendo 100% com os dados fornecidos pelo programa!

Obrigado a todos envolvidos, agora vou partir para o projeto em linguagem C e irei criar um post e espero a ajuda de vocês, que além de esclarecedora e limpa, é muito útil, a paciência e disposição de vocês para ensinar e o método que utilizam, é incrível, estimulando o iniciante a entender.
Mais uma vez obrigado!!!

WhatsApp Image 2018-05-24 at 13.46.11.jpeg

Editado por Erick Corrêa
  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
39 minutos atrás, Erick Corrêa disse:

Não entendi essa parte, tem algum cálculo que está "inútil" no código? @Simon Viegas


Sim.. está está calculando a média a cada loop... como não está sendo utilizado, está sendo inútil.
 

Veja:

1 hora atrás, Erick Corrêa disse:

      pfilho:=100*contadorf/contador
      ph:=100*homem/contador
      pm:=100*mulher/contador
   fimpara

 


Você deixou os cálculos dentro para. A média só precisa ser calculada uma vez. Logo, depois do para.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

 

44 minutos atrás, Erick Corrêa disse:

Rodando 100%, testado e aprovado, dados testados na mão batendo 100% com os dados fornecidos pelo programa!

Obrigado a todos envolvidos, agora vou partir para o projeto em linguagem C e irei criar um post e espero a ajuda de vocês, que além de esclarecedora e limpa, é muito útil, a paciência e disposição de vocês para ensinar e o método que utilizam, é incrível, estimulando o iniciante a entender.
Mais uma vez obrigado!!!

 

Por favor, poste o código aqui para revisarmos.

adicionado 1 minuto depois
agora, Erick Corrêa disse:

No caso serve pra otimizar o programa, é menos processamento, correto?


Também... mas a questão em si não é a quantidade, mas a "lógica envolvida", ou seja, seria "errado" ficar calculando. A média deveria ser calculada de uma vez só.

  • Curtir 3

Compartilhar este post


Link para o post
Compartilhar em outros sites

Segue, já ajustado:

Algoritmo "Entrevista"
//Aluno: Erick Corrêa da silva
//R.A.: 175.864-45
Var
   nome  : caractere
   idade : inteiro
   sexo  : caractere
   filhos,j, homem, mulher, rena_acime_500: inteiro
   nasc_2000           : inteiro
   rendaf: real
   contador, contadorf:real
   ph,pm,pfilho:real



Inicio
   Para j de 1 ate 2 faca
      escreval ("DIGITE OS DADOS DO ENTREVISTADO")
      escreval ("Tecle ENTER para sair!")
      escreva ("Nome          :")
      leia(nome)
      se compr(nome)=0 então
         interrompa
      fimse
      escreva ("Idade         :")
      leia(idade)
      se idade < 19 então
         nasc_2000:=nasc_2000+1
      fimse
      escreva ("Sexo [M ou F] :")
      leia(sexo)
      se sexo="M" então
         homem:=homem+1
      senao
         se sexo="F" então
            mulher:=mulher+1
         fimse
      fimse
      escreva ("Filhos        :")
      leia(filhos)
      se filhos > 0 então
         contadorf:=contadorf+1
      fimse
      escreva ("Renda Familiar:R$")
      leia(rendaf)
      se rendaf >= 500.00 então
         rena_acime_500:=rena_acime_500+1
      fimse
      limpatela
      contador:=contador+1

   fimpara

   pfilho:=100*contadorf/contador
   ph:=100*homem/contador
   pm:=100*mulher/contador

   escreval("A porcentagem de homens e mulheres é respectivamente:",ph,"% e",pm,"%.")
   escreval("Pessoas com renda familiar acima de R$500,00:",rena_acime_500," pessoas.")
   escreval("Porcentagem de pessoas que tenham ao menos um filho:",pfilho,"%.")
   escreval("Pessoas que nasceram a partir do ano 2000:",nasc_2000,".")




Fimalgoritmo

 

  • Curtir 1
  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

1#
Lembrar de mudar para 20. Está com 2.

 

 

 

2#
Tome cuidado com as divisões por 0. Poderia fazer por exemplo:

se contador <> 0 ENTÃO
   pfilho:=100*contadorf/contador
   ph:=100*homem/contador
   pm:=100*mulher/contador
fimse


***

 

No geral. O código está bom. Parabéns!

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
4 minutos atrás, Simon Viegas disse:

1#
Lembrar de mudar para 20. Está com 2.

 

 

 

2#
Tome cuidado com as divisões por 0. Poderia fazer por exemplo:


se contador <> 0 ENTÃO
   pfilho:=100*contadorf/contador
   ph:=100*homem/contador
   pm:=100*mulher/contador
fimse


***

 

No geral. O código está bom. Parabéns!

 

Ajustei de acordo com o indicado, realmente deixa tudo bem explícito ao que deve ser feito, o que o programa realmente deve seguir, sem falhas ou brechas para as mesmas!!

 

Obrigado galera!!

Até o próximo código!!

Abraço!

  • Amei 3

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×