Ir ao conteúdo
  • Cadastre-se
Luiz Antônio de Almeida

Excel Controle diario de alunos(as) faltantes

Recommended Posts

Boa tarde, pessoal!

 

Numa planilha Excel, preciso listar os nomes de alunos(as) que faltaram numa determinada data, baseando-se numa lista de chamada onde a cada PRESENÇA digito "C" e a cada FALTA digito "F".

 

Recorrendo a alguns auxílios, fui orientado a utilizar a seguinte fórmula matricial:

 

=SEERRO(INDICE($B$4:$B$30;MENOR(IF($B$4:$B$30<>"";SE(DESLOC($B$4;0;CORRESP($Q$3;$C$3:$Microsoft3;0);27;1)="F";LIN($B$4:$B$30)-3));LIN(A1)));"")

 

Anexo o arquivo para que possam comprovar, que realmente funcionou.

 

Porém este arquivo que anexei é apenas um exemplo.

 

O arquivo original que utilizo possui mais de 1000 nomes e percebi que, mesmo quando inadvertidamente não digito "C" (PRESENÇA)  ou "F" (FALTA), ou seja, a célula do dia referente a um(a) determinado(a) aluno fica vazia, mesmo assim o nome aparece como faltante. Estranho, pois, no arquivo anexo - que é exemplo -não aparece.

 

Gostaria de saber se tem como nesta fórmula acima introduzir um critério que, quando a célula estiver em branco, não conte como falta e não apareça o nome do(a) aluno(a).

 

Desde já, agradeço quem puder ajudar-me,

 

Luiz A Almeida

 

Controlando Frequencia diaria.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Porque funcionaria em uma planilha e na outra não? :confused:

É possível anexar uma cópia da sua planilha original?!

Notei que a fórmula do post tem escrita em inglês e na da planilha anexada, não:

=SEERRO(INDICE($B$4:$B$30;MENOR(IF($B$4:$B$30<>"";SE(DESLOC($B$4;0;CORRESP($Q$3;$C$3:$Microsoft3;0);27;1)="F";LIN($B$4:$B$30)-3));LIN(A1)));"") -> Fórmula do post

=SEERRO(ÍNDICE($B$4:$B$30;MENOR(SE($B$4:$B$30<>"";SE(DESLOC($B$4;0;CORRESP($Q$3;$C$3:$M$3;0);27;1)="F";LIN($B$4:$B$30)-3));LIN(A1)));"") -> Planilha anexada

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×