Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Luiz Antônio de Almeida

Excel Controle diario de alunos(as) faltantes

Recommended Posts

Boa tarde, pessoal!

 

Numa planilha Excel, preciso listar os nomes de alunos(as) que faltaram numa determinada data, baseando-se numa lista de chamada onde a cada PRESENÇA digito "C" e a cada FALTA digito "F".

 

Recorrendo a alguns auxílios, fui orientado a utilizar a seguinte fórmula matricial:

 

=SEERRO(INDICE($B$4:$B$30;MENOR(IF($B$4:$B$30<>"";SE(DESLOC($B$4;0;CORRESP($Q$3;$C$3:$Microsoft3;0);27;1)="F";LIN($B$4:$B$30)-3));LIN(A1)));"")

 

Anexo o arquivo para que possam comprovar, que realmente funcionou.

 

Porém este arquivo que anexei é apenas um exemplo.

 

O arquivo original que utilizo possui mais de 1000 nomes e percebi que, mesmo quando inadvertidamente não digito "C" (PRESENÇA)  ou "F" (FALTA), ou seja, a célula do dia referente a um(a) determinado(a) aluno fica vazia, mesmo assim o nome aparece como faltante. Estranho, pois, no arquivo anexo - que é exemplo -não aparece.

 

Gostaria de saber se tem como nesta fórmula acima introduzir um critério que, quando a célula estiver em branco, não conte como falta e não apareça o nome do(a) aluno(a).

 

Desde já, agradeço quem puder ajudar-me,

 

Luiz A Almeida

 

Controlando Frequencia diaria.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Porque funcionaria em uma planilha e na outra não? :confused:

É possível anexar uma cópia da sua planilha original?!

Notei que a fórmula do post tem escrita em inglês e na da planilha anexada, não:

=SEERRO(INDICE($B$4:$B$30;MENOR(IF($B$4:$B$30<>"";SE(DESLOC($B$4;0;CORRESP($Q$3;$C$3:$Microsoft3;0);27;1)="F";LIN($B$4:$B$30)-3));LIN(A1)));"") -> Fórmula do post

=SEERRO(ÍNDICE($B$4:$B$30;MENOR(SE($B$4:$B$30<>"";SE(DESLOC($B$4;0;CORRESP($Q$3;$C$3:$M$3;0);27;1)="F";LIN($B$4:$B$30)-3));LIN(A1)));"") -> Planilha anexada

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×