Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
cafcatos

VisualG algoritmo feroz para quem não sabe o que está acontecendo

Recommended Posts

Postado (editado)

Tem esse problema que já fiz de tudo mas não consigo nem entender o que estou fazendo. Começo e no meio fico toda atrapalhada. Sou mega iniciante e super frustrada. o tal problema é o seguinte:

Foi realizada uma pesquisa entre os habitantes de uma cidade. Através dessa pesquisa foram coletados os dados de salário, idade, sexo, e número de filhos de cada habitante. Faça um algoritmo que calcule e mostre:

a) A média de salário das mulheres. 
b) A maior e a menor idade da população.
c) A média do número de filhos de cada habitante.
d) O maior salário da população.
e) O percentual de pessoas com salário maior que R$ 954,00.

Obs.: O programa encerra quando o salário digitado for igual a zero.

 

meu algoritmo todo errado é o seguinte:

Var
idade,sexo,mulheres,somaFilho,quantFilho,habitante,menoridade,maioridade:inteiro
TotalSalario,percentualSalario,totalFilho,maiorSalario,salario,salarioMulher,mediaSalMulher:real
inicio

salario:= 1
    enquanto (salario <> 0) faca

        escreval("Digite o seu salario")
        leia (salario)

            se(salario <> 0) então

                escreval("Digite seu sexo:")
                escreval("1 - Masculino")
                escreval("2 - Feminino")
                leia(sexo)

                escreval("Digite a sua idade")
                leia(idade)

                escreval("qual o numero de filhos:")
                leia(quantFilho)

            se(salario > maiorSalario) então
            maiorSalario <- salario
            
            fimse
            
            se(salario > 954) então
             salarioMaior 954<= salarioMaior 954 + 1
            
                
            enquanto(salario > 0) faca
                totalSalario<-totalSalario + salario
                totalFilho<- quantFilho + quantFilho
                habitante <- habitante + 1
                
    fimenquanto
           repita
             escreval("Sua idade")
             leia(idade)
             se(idade>= 18) então
               escreval("maioridade")
             senao("menoridade")
             fimse
             escreval("Sua idade")
             leia(idade)
             se(idade>= 18) então
               escreval("maioridade")
             senao("menoridade")
           ate(idade=0)
         fimse

       fimse

ate(sexo = 1) ou (sexo = 2)
mediaSalMulher := totalSalMulher/habitante
escreval("Digite Nº Filhos")
leia(filhos)
totalFilhos := totalFilhos + filhos
mediaFilhos := totalFilhos/habitante

      fimse
   fimse
   escreval("____________________________________________________")
fimenquanto

mediaSalMulher := salarioMulher / mulheres
mediaFilho := somaFilho / habitante
percentualSalMaior954 := (salarioMaior954 * 100) / habitante


escreval("RELATORIO")
escreval("a) Media Salario das mulheres: ", meidaSalMulher)
escreval("b) Maior idade da poulcao:", maioridade)
escreval("Menor idade da populacao:", menoridade)
escreval("c) A média do numero de filhos de cada habitante:", mediaFilho)
escreval("d) O maior salario da população:", maiorSalario)
escreval("e) O percentual de pessoas com salario maior que R$ 954,00:", percentualSalario)


fimalgoritmo


 

Editado por DiF
Botão CODE <>
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Seria bom se fosse na linguagem. Pois estou aprendendo agora e é por isso que não consigo entender o que e como fazer.

adicionado 2 minutos depois

@Matheus Ribeiro_765701 seria bom se fosse nessa linguagem pois, estou aprendendo agora e é por isso que não consigo entender o quê e como fazer. Porém, se tem como explicar em outra linguagem também é bem vindo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu ia fazer em C, porém o código ia ficar muito "complicado" para entender para o portugol (Linguagenzinha inútil por sinal), então se possivel, me diga que erro está você está tendo? Se o programa roda, o programa da crash quando alguma informação é colocada? Para que eu possa lhe auxiliar

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@cafcatos    seu código está bom ,  só precisa organiza-lo melhor ,   então modifiquei algumas linhas  e ele ficou assim  :

Algoritmo "pesquisa"
Var
  sexo : caracter
  mulheres,somaFilho,contador:inteiro
  quantFilho,idade,habitante,menoridade,maioridade:inteiro
  salario,TotalSalario,percentualSalario,totalFilho,mediaFilhos:real
  maiorSalario,porcSalMaior_954,salarioMulher,mediaSalMulher,salAcima_954:real
inicio
  salario := 1
  escreval("====== Coletando Dados Da Pesquisa ======")
  enquanto salario <> 0 faca
    contador := contador + 1
    escreval("Digite seu sexo   M  /  F ")
    leia(sexo)
    escreval("Digite a sua idade ")
    leia(idade)
    se contador = 0 ENTÃO
      menoridade := idade
    fimse
    escreval("qual o numero de filhos ")
    leia(quantFilho)
    totalFilho := totalFilho + quantFilho
    escreval("Digite o seu salario")
    leia(salario)
    TotalSalario := TotalSalario + salario
    se salario > 954 ENTÃO
      salAcima_954 := salAcima_954 + 1
    fimse
    se sexo = "f" ENTÃO
      salarioMulher := salarioMulher + salario
    fimse
    se maioridade < idade ENTÃO
      maioridade := idade
    fimse
    se menoridade > idade ENTÃO
      menoridade := idade
    fimse
    se maiorSalario > salario ENTÃO
      maiorSalario := salario
    fimse
  fimenquanto
  mediaSalMulher := salarioMulher div contador
  mediaFilhos := totalFilho div contador
  porcSalMaior_954 := salAcima_954 * 100 div contador
  escreval("============ RELATORIO ==============")
  escreval("a) Media Salario das mulheres ------------------------------: ", mediaSalMulher)
  escreval("b) Maior idade da populcao ---------------------------------: ", maioridade)
  escreval("   Menor idade da populacao --------------------------------: ", menoridade)
  escreval("c) A média do numero de filhos de cada habitante -----------: ", mediaFilhos)
  escreval("d) O maior salario da população ----------------------------: ", maiorSalario)
  escreval("e) O percentual de pessoas com salario maior que R$ 954,00 -: ",porcSalMaior_954)
fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Muito obrigada. Agora vou quebrar a cabeça mais um pouco para entender. Meu problema é saber o quê tenho de colocar e quais a ordem. valeu!

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×