Ir ao conteúdo
  • Cadastre-se
Kakahh

VisualG Algoritmo com algum erro

Recommended Posts

O menor valor sempre apresenta 0 independente do numero que eu informe, preciso de ajuda pra descobrir o que tem errado

var
   valor_venda, maior_venda ,menor_venda:real
   x:inteiro
inicio
      escreval("Veja qual a maior venda e a menor venda do dia")
      para x de 1 ate 5  faca
           escreva("Informe o valor da venda:")
           leia(valor_venda)
           escreval("---------------")
            se (valor_venda > maior_venda )então
            maior_venda <- valor_venda
            fimse
            se (valor_venda < menor_venda) então
            menor_venda<- valor_venda
            fimse
      fimpara
             escreval("O valor da maior venda é:",maior_venda)
             escreva("O valor da menor venda é:",menor_venda)
fimalgoritmo

 

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Kakahh      para que funcione certo você precisa inicializar a variável menor_venda  com o primeiro valor_venda que entrar e depois fazer a comparação do jeito que você colocou mesmo , então coloque essas linhas logo abaixo do leia(valor_venda) assim : 

leia(valor_venda)
se x = 1 ENTÃO
  menor_venda := valor_venda
fimse

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Por conta da sintaxe do Visualg com o " = " não funcionou, mas coloquei da seguinte forme

menor_venda<-valor_venda  e funcionou perfeitamente, muito obrigada !!!!!

  • Curtir 3

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

Sobre:

21 horas atrás, Kakahh disse:

Por conta da sintaxe do Visualg com o " = " não funcionou, mas coloquei...


Então, no código do @devair1010 tem ":=", e não apenas "=". No caso, tanto faz usar "<-" ou ":=".

 

Att

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×