Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Kakahh

VisualG Algoritmo com algum erro

Recommended Posts

Postado (editado)

O menor valor sempre apresenta 0 independente do numero que eu informe, preciso de ajuda pra descobrir o que tem errado

var
   valor_venda, maior_venda ,menor_venda:real
   x:inteiro
inicio
      escreval("Veja qual a maior venda e a menor venda do dia")
      para x de 1 ate 5  faca
           escreva("Informe o valor da venda:")
           leia(valor_venda)
           escreval("---------------")
            se (valor_venda > maior_venda )então
            maior_venda <- valor_venda
            fimse
            se (valor_venda < menor_venda) então
            menor_venda<- valor_venda
            fimse
      fimpara
             escreval("O valor da maior venda é:",maior_venda)
             escreva("O valor da menor venda é:",menor_venda)
fimalgoritmo

 

Editado por Simon Viegas
  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
Postado (editado)

@Kakahh      para que funcione certo você precisa inicializar a variável menor_venda  com o primeiro valor_venda que entrar e depois fazer a comparação do jeito que você colocou mesmo , então coloque essas linhas logo abaixo do leia(valor_venda) assim : 

leia(valor_venda)
se x = 1 ENTÃO
  menor_venda := valor_venda
fimse

 

Editado por devair1010
  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Por conta da sintaxe do Visualg com o " = " não funcionou, mas coloquei da seguinte forme

menor_venda<-valor_venda  e funcionou perfeitamente, muito obrigada !!!!!

  • Curtir 3

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

Sobre:

21 horas atrás, Kakahh disse:

Por conta da sintaxe do Visualg com o " = " não funcionou, mas coloquei...


Então, no código do @devair1010 tem ":=", e não apenas "=". No caso, tanto faz usar "<-" ou ":=".

 

Att

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×