Ir ao conteúdo
  • Cadastre-se
Kakahh

VisualG RESOLVIDO Exercício de repetição determinada

Recommended Posts

Uma loja de Calçados deseja fazer uma estimativa para saber quais calçados vendem mais entre femininos e masculinos. Considerando 50 vendas, leia o valor do calçado vendido e se é feminino (F) ou masculino (M). Após as vendas mostre qual o gênero de calçado mais vendido e o valor total de vendas dos calçados masculinos e femininos.

 

  1. var
       f,m,genero,mais_vend:caracter
        total_fem,total_masc, x,valor:inteiro
    inicio
          escreval("Veja qual o gênero do calçado mais vendido e o valor total das vendas de ambos")
          acm<-0
          para x de 1 ate 5 passo 1 faca
               escreva("Informe o valor do calçado:")
               leia(valor)
               escreval("Informe o gênero do calçado:")
               escreval("Digite F para feminino")
               escreval("Digite M para masculino")
               escreva("->")
               leia(genero)
               se (f > m) então
                mais_vend<- f
               fimse
               se(m > f ) então
               mais_vend<- m
               fimse
          fimpara
          escreva("O genero mais vendido é:" ,mais_vend)
          
    fimalgoritmo

    Estou tendo dificuldade em conseguir mostrar qual o gênero mais vendido, fiz dessa forma mas não funcionou. O valor total das vendas de cada gênero também não sei como colocar, se alguém pode me mostrar o caminho, o que estou errado eu agradeço.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Kakahh    o erro é por que você está comparando variáveis do tipo caractere se uma é maior que a outra , e assim só funciona com inteiro ,  e também nem precisa ver se é m é maior que f , pois só precisa saber a quantidade de cada hum ,  então seu código com algumas modificações ficaria assim  :

Algoritmo "calçados"
var
  genero,mais_vend                  : caracter
  f,m,total_fem,total_masc,valor,x  : inteiro
  v_c_masc,v_c_fem                  : inteiro
inicio
  escreval("Veja qual o gênero do calçado mais vendido e o valor total das vendas de ambos")
  para x de 1 ate 5 passo 1 faca
    escreva("Informe o valor do calçado:")
    escreva("-> ")
    leia(valor)
    escreval("Informe o gênero do calçado:   F / M ")
    escreva("-> ")
    leia(genero)
    se (genero = "m") ENTÃO
      m := m + 1
      v_c_masc := v_c_masc + valor
    senao
      se genero = "f" ENTÃO
        f := f + 1
        v_c_fem := v_c_fem + valor
      fimse
    fimse
  fimpara
  se m > f ENTÃO
    mais_vend := "Masculino"
  senao
    mais_vend := "Feminino"
  fimse
  escreval("O genero mais vendido é:" ,mais_vend)
  escreval("O Total Das Vendas De Calçados Masculinos é ",v_c_masc)
  escreval("O Total Das Vendas De Calçados Femininos é " ,v_c_fem )
fimalgoritmo

 

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Só um adendo:

 

As variáveis total_fem e total_masc não estão sendo utilizadas. Precisa remover da declaração.

 

  • Curtir 1
  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×