Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
jehssyk

VisualG Criar um algoritmo decrescente

Recommended Posts

Postado (editado)

OBS. no visualG (portugol)

 

Crie um algoritmo que leia os limites inferior e superior de um intervalo e imprimir todos os números pares no intervalo aberto e seu somatório (UTILIZE O PARA). Suponha que os dados digitados são para um intervalo DECRECENTE

exemplo

Limite inferior: 5 Saída: 12 10 8 6

Limite superior: 14 Soma: 36

 

O QUE FIZ ATE AGORA.

var

su, in, i, soma: inteiro


inicio

// Seção de Comandos


escreval("Digite o valor inferior ")

leia(in)


escreval("Digite o valor superior ")

leia(su)


soma <- 0


se (i mod 2 = 0) então

in <- in + 1

senao

in <- in + 2


fimse


para i de in ate su passo 2 faca

soma <- soma + 1

escreva ("", i)

fimpara


fimalgoritmo

 

Não sei o que está errado, porq não soma, e como coloco na ordem decrescente!

 

Editado por Simon Viegas
Inserir tag CODE
  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@jehssyk    seu código está bom só precisa uma melhor organização , e para ser na ordem decrescente você coloca o maior número primeiro no para e para ir ate o menor número e o passo é de dois em dois pois são pares e menos dois para ir de cima para baixo , então seu código com algumas modificações ficaria assim :

Algoritmo "ordem decrescente"
var
  su,in,i,soma,aux : inteiro
inicio
  escreva("Digite o valor inferior ")
  leia(in)
  escreva("Digite o valor superior ")
  leia(su)
  soma <- 0
  se in > su ENTÃO // se inferior maior que superior
    aux:=in        // organiza os números na ordem certa
    in:=su
    su:=aux
  fimse
  se (su mod 2 <> 0) ENTÃO  // posiciona no último par do intervalo
    su := su - 1
  fimse
  para i de su ate in passo -2 faca
    soma <- soma + i  // i é o número par então soma + i
    escreval(i)       // imprime o número
  fimpara
  escreval("a soma é ",soma)
fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

Só um adendo

 

Foquemos no enunciado

17 horas atrás, jehssyk disse:

Crie um algoritmo que leia os limites inferior e superior de um intervalo e imprimir todos os números pares no intervalo aberto e seu somatório (UTILIZE O PARA). Suponha que os dados digitados são para um intervalo

 

O que significa intervalo aberto?

 

Então, o resultado não está batendo com o enunciado.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
Postado (editado)

estava rodando so que não consegui colocar do maior para o menor, e a soma estar errado, esta dando 50, o meu estar dando certo, só que ao invés de imprimir de forma decrescente, estar crescente. 

adicionado 30 minutos depois

Porque o meu não imprimir em ordem decrescente ?? 

Editado por jehssyk
  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, jehssyk disse:

Porque o meu não imprimir em ordem decrescente ?? 

Não imprime por que você implementou para imprimir em ordem crescente. Tem que configurar para imprimir da forma que deseja..

 

 

O @devair1010 já explicou... seria algo como:


Em vez de:

21 horas atrás, jehssyk disse:

para i de in ate su passo 2 faca


Use:

para i de su ate in passo -2 faca


Ou seja, indo do maior para o menor, diminuindo de 2 em 2... faça os ajustes e posta o código completo.

 

 

Obs.: para postar o código, favor pressionar o botão <> e colar o código dentro.

 

No aguardo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×