Ir ao conteúdo
  • Cadastre-se
jehssyk

VisualG Função que receba dois números inteiros x e y

Recommended Posts

Escreva uma função que receba dois números inteiros x e y. Essa função deve verificar se x é divisível por y. No caso positivo, a função deve retornar 1, caso contrário zero. Escreva também um algoritmo para testar tal função exibindo uma mensagem de acordo com o resultado. 

NÃO SEI NEM COMO COMEÇAR, DE 20 SÓ NÃO CONSEGUI 3, ESSE QUE NÃO SEI COMO, E MAIS DOIS MAIS OU MENOS, SE ALGUÉM PODER ME AJUDAREM E EXPLICAR! AGRADEÇO.


OBS. no visualG (portugol)

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@jehssyk       você precisa criar essa função que verifica , colocando ela lá no inicio logo depois das variáveis, e dentro dela você faz a verificação usando o comando mod  , então se x mod y for igual a zero é por que é divisível e não sobra nada , e nesse caso retorne 1 , senão retorne 0 , e no loop principal coloque as variáveis x e y com o valor que você quiser e usando outra variável para pegar o resultado de retorno chame essa função que faz a verificação , e em seguida veja se a variável de retorno é 1 então imprime que é divisível senão imprima que não é divisível  .

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
var
   x,y:INTEIRO

Procedimento Soma(A, B:Inteiro)
   Escreva("Soma de dois numeros", A+B)
FimProcedimento

inicio
   Escreval("Digite um valor para x:")
   leia(x)
   Escreval("Digite um valor para y:")
   leia(y)
   Se (x %y =0) então
      escreval("Divisao sem resto")
      escreval("Soma",x+y)
      escreva(retorne 1)
   Senao
      escreval("Divisao com resto")
      escreval("Soma:",x+y)
      escreva(retorne 0)
   fimse
fimalgoritmo

 

Eu tentei, mais fica dando [division by zero], o que eu fiz de errado ?

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

Está usando qual versão do Visualg?

adicionado 22 minutos depois

 

@jehssyk, seu código (apenas subi o então, que estava na linha de baixo) aqui no Visualg está rodando normalmente... e está no caminho certo...

 

Mas está com erro de sintaxe (regras do Visualg) e erros de lógica (não está de acordo com o enunciado).

 

Em 28/05/2018 às 15:12, jehssyk disse:

escreva(retorne 1)

 

Essa estrutura está errada...  Nem muito menos está sendo pedido a "soma dos números"... não tem nada a ver. Pode tirar também... ;)

 

 

Em fim... minha sugestão é a seguinte: primeiro faça esse algoritmo sem uso de função ou procedimentos... apenas "receba x e y e informe se tem resto ou não". Faça um código novo!!!

 

Ai depois te explicamos como fazer com função, assim como está sendo pedido.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×