Ir ao conteúdo
  • Cadastre-se
SAMUELLOPES

Excel problema com função se(procv

Recommended Posts

Boa noite.
Estou inserindo uma fórmula SE(PROCV para pesquisar um valor numérico em outra aba, a fim de retornar um status “P” ou “A” em formanto formato de texto. ex:
SE(PROCV(B4;ENTRADA;2;FALSO);“P”;“A”), porém a formula não está funcionando. Quando preencho a coluna 1 da planilha ENTRADA com o valor procurado, me retorna a condição “se falso = A” e quando preencho as coluna 1 e 2 da planilha ENTRADA com o valor procurado, me retorna a condição “se verdadeiro=P”. Se apago o valor da coluna 1, não me retorna nenhum valor (#N/D). A ideia é perquisar o valor numérico listado na célula B4 da planilha que está na primeira aba, na coluna 2 da 2ª aba, e me retornar texto “P”, se presente nessa coluna, ou retornar o texto “A”, se não presente nessa coluna.
Alguém pode me ajudar? Já se foram horas tentando resolver esse problema.

Além do anexo, segue também link do 4Shared com a planilha.

https://www.4shared.com/account/home.jsp#jsVerification
Obrigado desde já.

ERRO FORMULA PROCV.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

@SAMUELLOPES , Bom Dia.

 

Para que possamos ajudar preenche alguns dados pois sabemos montar formula, mas não sabemos de se projeto

 

Poste o modelo com dados e resultado esperado

 

Decio

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia,

 

Considerando apenas o trecho:

12 horas atrás, SAMUELLOPES disse:

retornar texto “P”, se presente nessa coluna, ou retornar o texto “A”, se não presente nessa coluna.

 

Sugiro você testar a seguinte fórmula:

=SE(SEERRO(PROCV(E4;ENTRADA;2;FALSO);"A")="A";"A";"P")

 

Caso não funcione, por favor, informe mais detalhes para lhe ajudarmos.

 

[]'s

Compartilhar este post


Link para o post
Compartilhar em outros sites

@SAMUELLOPES , bom dia e vem vindo ao Clube do Hardware

 

As funções ÍNDICE/CORRESP seriam mais apropriadas nessa situação. Mas vejamos o porquê do erro:

A função PROCV só procura na primeira coluna do intervalo passado como argumento "matriz_tabela". Note no entanto que seu intervalo nomeado "ENTRADA" não começa na coluna que contém ID DO CONTENTOR (C) mas sim uma coluna antes (B). Então, pra usar PROCV você teria que ou redefinir ENTRADA para começar na coluna C ou, melhor, deslocar o intervalo com a função DESLOC uma coluna à direita:

=SE(PROCV(B4;DESLOC(ENTRADA;0;1);1;FALSO);"P";"A")

Incrementando para não aparecer erro #N/D quando não houver célula preenchida:

=SEERRO(SE(PROCV(B4;DESLOC(ENTRADA;0;1);1;FALSO);"P";"A");"")

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×