Ir ao conteúdo
  • Cadastre-se
Visitante

VisualG VisualG - Campo em branco

Recommended Posts

Visitante

Saudações terráqueos!

Preciso fazer com que esse laço de repetição seja interrompido caso o usuário deixe o campo "nome" em branco. Mas quero que o programa continue a execução dos comandos que vem depois do laço (Não postei os comandos para não alongar demais o post).

Desse jeito que fiz, sempre dá erro.

Quando coloco um comando para encerrar a execução do programa (fimalgoritmo) dentro do "Se" no lugar do "fimpara', funciona normalmente.

inicio
repet <- 0
Para repet de 0 ate 12 passo 1 faca
           Escreva ("Nome: ")
           Leia (nome)
           se nome = "" então
           fimpara

           fimse
fimpara 
fimalgoritmo

Alguém pode me ajudar?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×