Ir ao conteúdo
  • Cadastre-se
Daniel Nascimento Araújo

Excel Atualizando Códigos da Tabela de Preço

Recommended Posts

Bom dia amigos, tenho um problema e espero que vocês tenham a solução, eu possuo uma planilha de nome "Tabela de Preço", onde eu preciso fazer uma busca usando como parâmetro a coluna "Nome Produto" em outra planilha de nome "Planilha de Produtos" usando como parâmetro a coluna "Nome" desta planilha. O que eu preciso, ambas as planilhas possuem os nomes dos produtos, porém apenas uma possui os códigos, então eu preciso de alguma fórmula que compare essas duas colunas que citei, e obtendo resultados iguais, eu precisava obter as informações da coluna "CodigoNFe" da planilha "Planilha de Produtos". Basicamente preciso preencher todos os códigos na "Tabela de Preço" utilizando as informações da "Planilha de Produtos". Espero que possam me ajudar, e desde já, um muito obrigado.

Planilha de Produtos.xlsx

Tabela de Preço.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde, @Daniel Nascimento Araújo

 

Copie e cole a formula abaixo na célula F2 da planilha Tabela de Preços e arraste até a última linha que tenha dados na coluna anterior.

=SEERRO(ÍNDICE('[Planilha de Produtos.xlsx]Plan1'!$D$2:$D$4221;CORRESP(A2;'[Planilha de Produtos.xlsx]Plan1'!$F$2:$F$4221;0));"NÃO EMCPNTRADO")

Não se esqueça de clicar em curtir.

 

Dê retorno.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×