Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Noob3304

VisualG Intervalo para uma variavel

Recommended Posts

Postado (editado)

Estou fazendo um pseudocódigo no Visualg e queria saber como eu peço para ele aceitar somente valores para variavel entre 0 e 10, podendo ser valores com vírgula também, e se o usuário digitar fora deste intervalo, escrever um aviso pedindo numeros dentro do intervalo.

Editado por Simon Viegas
Restaurar postagem original

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro usuário,

 

Seja bem-vindo ao Fórum do Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a resposta está correta ou não, ou para que possa ser auxiliado com a dúvida no desenvolvimento do exercício.

 

Infelizmente, não há como resolver os trabalhos pelos usuários. O objetivo do Fórum do Clube do Hardware é auxiliar seus usuários a encontrar soluções para que possam sanar suas dúvidas, e não de trazer soluções prontas para seus usuários.. Além disso, copiar e colar respostas que não são de autoria própria do qualquer usuário é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

Compartilhar este post


Link para o post
Compartilhar em outros sites
Postado (editado)
INICIO
   //MATEMATICA: variaveis dos bimestes de matematica
   escreval ("Digite sua nota do primeiro bimeste em matematica:")
   leia (matematica[0,0])
   escreval ("Digite sua nota do segundo bimeste em matematica:")
   leia (matematica[0,1])
   escreval ("Digite sua nota do terceiro bimeste em matematica:")
   leia (matematica[0,2])
   escreval ("Digite sua nota do quarto bimeste em matematica:")
   leia (matematica[0,3])

     

Gostaria que estas notas somente aceitassem entre 0 e 10 caso contrario pedir notas de novo ao usuário notificando-o.

 

update

Consegui resolver parcialmente, coloquei vários "se", deu um trabalho enorme , se alguem souber fazer de um modo diferente poste aqui por gentiliza.

 

Editado por Simon Viegas

Compartilhar este post


Link para o post
Compartilhar em outros sites

Está anexado o código, como ele ficou muito grande e se colocasse normal na pagina ia ficar incompreensível , coloquei no formato txt. 

Código:

Spoiler

//Algoritmo feito para ver se a pessoa passou ou nao de ano
algoritmo "materias que tenho que me dedicar"
//definição das variáveis
   var
      Matematica : vetor [0..0,0..3] de real
      Portugues : vetor [1..1,0..3] de real
      Filosofia : vetor [2..2,0..3] de real
      Geografia : vetor [3..3,0..3] de real
      Sociologia : vetor [4..4,0..3] de real
      Educacao_Fisica : vetor [5..5,0..3] de real
      Fisica : vetor [6..6,0..3] de real
      Biologia : vetor [7..7,0..3] de real
      Religiao : vetor [8..8,0..3] de real
      Quimica : vetor [9..9,0..3] de real
      inglês: vetor [10..10,0..3] de real
      Literatura : vetor [11..11,0..3] de real
      Matematica_soma: real
      Portugues_soma: real
      Filosofia_soma: real
      Geografia_soma: real
      Sociologia_soma: real
      Educacao_fisica_soma: real
      Fisica_soma: real
      Biologia_soma: real
      Religiao_soma: real
      Quimica_soma: real
      Ingles_soma: real
      Literatura_soma: real
      
//pedindo valor dado pelo usuario para as variaveis e armazenando elas
INICIO
   //MATEMATICA: variaveis dos bimestes de matematica
   repita
   escreval ("Digite sua nota do primeiro bimeste em matematica:")
   leia (matematica[0,0])
   se (matematica[0,0] >=0) e (matematica[0,0]<= 10) então
      repita
         escreval ("Digite sua nota do segundo bimeste em matematica:")
         leia (matematica[0,1])
         se (matematica[0,1] >=0) e (matematica[0,1]<= 10) então
            repita
               escreval ("Digite sua nota do terceiro bimeste em matematica:")
               leia (matematica[0,2])
               se (matematica[0,2] >=0) e (matematica[0,2]<= 10) então
               repita
                     escreval ("Digite sua nota do quarto bimeste em matematica:")
                     leia (matematica[0,3])
                        se (matematica[0,3] >=0) e (matematica[0,3]<= 10) então
                           repita
                           escreval ("Digite sua nota do primeiro bimeste em portugues:")
                           leia (portugues[1,0])
                           se (portugues[1,0] >=0) e (portugues[1,0]<= 10) então
                              repita
                              escreval("Digite sua nota do segundo bimestre em portugues:")
                              leia (portugues[1,1])
                                 se (portugues[1,1] >=0) e (portugues[1,1]<= 10) então
                                    repita
                                    escreval ("Digite sua nota do terceiro bimestre em portugues:")
                                    leia (portugues [1,2])
                                       se (portugues[1,2] >=0) e (portugues[1,2]<= 10) então
                                          repita
                                          escreval ("Digite sua nota do quarto bimestre em portugues:")
                                          leia (portugues[1,3])
                                             se (portugues[1,3] >=0) e (portugues[1,3]<= 10) então
                                                repita
                                                escreval ("Digite sua nota do primeiro bimestre em filosofia:")
                                                leia (filosofia [2,0])
                                                se (filosofia[2,0] >=0) e (filosofia[2,0]<= 10) então
                                                repita
                                                   escreval ("Digite a nota do segundo bimestre em filosofia:")
                                                   leia (filosofia[2,1])
                                                   se (filosofia[2,1] >=0) e (filosofia[2,1]<= 10) então
                                                   repita
                                                      escreval ("Digite a nota do terceiro bimestre em filosofia:")
                                                      leia (filosofia[2,2])
                                                      se (filosofia[2,2] >=0) e (filosofia[2,2]<= 10) então
                                                      repita
                                                         escreval ("Digite a nota do quarto bimestre em filosofia:")
                                                         leia (filosofia[2,3])
                                                         se (filosofia[2,3] >=0) e (filosofia[2,3]<= 10) então
                                                         repita
                                                            escreval ("Digite sua nota do primeiro bimestre em geografia:")
                                                            leia (geografia[3,0])
                                                            se (geografia[3,0] >=0) e (geografia[3,0]<= 10) então
                                                            repita
                                                               escreval ("Digite sua nota do segundo bimestre em geografia:")
                                                               leia (geografia[3,1])
                                                               se (geografia[3,1] >=0) e (geografia[3,1]<= 10) então
                                                               repita
                                                                  escreval ("Digite sua nota do terceiro bimestre em geografia:")
                                                                  leia (geografia[3,2])
                                                                  se (geografia[3,2] >=0) e (geografia[3,2]<= 10) então
                                                                  repita
                                                                     escreval ("Digite sua nota do quarto bimestre em geografia:")
                                                                     leia (geografia[3,3])
                                                                     se (geografia[3,3] >=0) e (geografia[3,3]<= 10) então
                                                                     repita
                                                                        escreval ("Digite sua nota do primeiro bimestre em sociologia:")
                                                                        leia (sociologia[4,0])
                                                                        se  (sociologia[4,0] >=0) e (sociologia[4,0]<= 10) então
                                                                        repita
                                                                           escreval ("Digite sua nota do segundo bimestre em sociologia:")
                                                                           leia (sociologia[4,1])
                                                                           se (sociologia[4,1] >=0) e (sociologia[4,1]<= 10) então
                                                                           repita
                                                                              escreval ("Digite sua nota do terceiro bimestre em sociologia:")
                                                                              leia (sociologia[4,2])
                                                                              se (sociologia[4,2] >=0) e (sociologia[4,2]<= 10) então
                                                                              repita
                                                                                 escreval ("Digite sua nota do quarto bimestre em sociologia:")
                                                                                 leia (sociologia[4,3])
                                                                                 se (sociologia[4,3] >=0) e (sociologia[4,3]<= 10) então
                                                                                 repita
                                                                                    escreval ("Digite sua nota do primeiro bimestre em educacao fisica:")
                                                                                    leia (educacao_fisica[5,0])
                                                                                    se (educacao_fisica[5,0] >=0) e (educacao_fisica[5,0]<= 10) então
                                                                                    repita
                                                                                       escreval ("Digite sua nota do segundo bimestre em educacao fisica:")
                                                                                       leia (educacao_fisica[5,1])
                                                                                       se  (educacao_fisica[5,1] >=0) e (educacao_fisica[5,1]<= 10) então
                                                                                       repita
                                                                                          escreval ("Digite sua nota do terceiro bimestre em educacao fisica:")
                                                                                          leia (educacao_fisica[5,2])
                                                                                          se (educacao_fisica[5,2] >=0) e (educacao_fisica[5,2]<= 10) então
                                                                                          repita
                                                                                             escreval ("Digite sua nota do quarto bimestre em educacao fisica:")
                                                                                             leia (educacao_fisica[5,3])
                                                                                             se (educacao_fisica[5,3] >=0) e (educacao_fisica[5,3]<= 10) então
                                                                                             repita
                                                                                                escreval ("Digite sua nota do primeiro bimestre em fisica:")
                                                                                                leia (fisica[6,0])
                                                                                                se (fisica[6,0] >=0) e (fisica[6,0]<= 10) então
                                                                                                repita
                                                                                                   escreval ("Digite sua nota do segundo bimestre em fisica:")
                                                                                                   leia (fisica[6,1])
                                                                                                   se (fisica[6,1] >=0) e (fisica[6,1]<= 10) então
                                                                                                   repita
                                                                                                      escreval ("Digite sua nota do terceiro bimestre em fisica:")
                                                                                                      leia (fisica[6,2])
                                                                                                      se (fisica[6,2] >=0) e (fisica[6,2]<= 10) então
                                                                                                      repita
                                                                                                         escreval ("Digite sua nota do quarto bimestre em fisica:")
                                                                                                         leia (fisica[6,3])
                                                                                                         se (fisica[6,3] >=0) e (fisica[6,3]<= 10) então
                                                                                                         repita
                                                                                                            escreval ("Digite sua nota do primeiro bimestre em biologia:")
                                                                                                            leia (biologia[7,0])
                                                                                                            se (biologia[7,0] >=0) e (biologia[7,0]<= 10) então
                                                                                                            repita
                                                                                                               escreval ("Digite sua nota do segundo bimestre em biologia:")
                                                                                                               leia (biologia[7,1])
                                                                                                               se (biologia[7,1] >=0) e (biologia[7,1]<= 10) então
                                                                                                               repita
                                                                                                                  escreval ("Digite sua nota do terceiro bimestre em biologia:")
                                                                                                                  leia (biologia[7,2])
                                                                                                                  se (biologia[7,2] >=0) e (biologia[7,2]<= 10) então
                                                                                                                  repita
                                                                                                                     escreval ("Digite sua nota do quarto bimestre em biologia:")
                                                                                                                     leia(biologia[7,3])
                                                                                                                     se (biologia[7,3] >=0) e (biologia[7,3]<= 10) então
                                                                                                                     repita
                                                                                                                        escreval ("Digite sua nota do primeiro bimestre em religiao:")
                                                                                                                        leia (religiao[8,0])
                                                                                                                        se (religiao[8,0] >=0) e (religiao[8,0]<= 10) então
                                                                                                                        repita
                                                                                                                           escreval ("Digite sua nota do segundo bimestre em religiao:")
                                                                                                                           leia(religiao[8,1])
                                                                                                                           se (religiao[8,1] >=0) e (religiao[8,1]<= 10) então
                                                                                                                           repita
                                                                                                                              escreval ("Digite sua nota do terceiro bimestre em religiao:")
                                                                                                                              leia(religiao[8,2])
                                                                                                                              se (religiao[8,2] >=0) e (religiao[8,2]<= 10) então
                                                                                                                              repita
                                                                                                                                 escreval ("Digite sua nota do quarto bimestre em religiao:")
                                                                                                                                 leia (religiao[8,3])
                                                                                                                                 se  (religiao[8,3] >=0) e (religiao[8,3]<= 10) então
                                                                                                                                 repita
                                                                                                                                    escreval ("Digite sua nota do primeiro bimestre em quimica:")
                                                                                                                                    leia(quimica[9,0])
                                                                                                                                    se (quimica[9,0] >=0) e (quimica[9,0]<= 10) então
                                                                                                                                    repita
                                                                                                                                       escreval ("Digite sua nota do segundo bimestre em quimica:")
                                                                                                                                       leia (quimica[9,1])
                                                                                                                                       se (quimica[9,1] >=0) e (quimica[9,1]<= 10) então
                                                                                                                                       repita
                                                                                                                                          escreval  ("Digite sua nota do terceiro bimestre em quimica:")
                                                                                                                                          leia(quimica[9,2])
                                                                                                                                          se (quimica[9,2] >=0) e (quimica[9,2]<= 10) então
                                                                                                                                          repita
                                                                                                                                             escreval ("Digite sua nota do quarto bimestre em quimica:")
                                                                                                                                             leia (quimica[9,3])
                                                                                                                                             se (quimica[9,3] >=0) e (quimica[9,3]<= 10) então
                                                                                                                                             repita
                                                                                                                                                escreval  ("Digite sua nota do primeiro bimestre em inglês:")
                                                                                                                                                leia(inglês[10,0])
                                                                                                                                                se (inglês[10,0] >=0) e (inglês[10,0]<= 10) então
                                                                                                                                                repita
                                                                                                                                                   escreval ("Digite sua nota do segundo bimestre em inglês:")
                                                                                                                                                   leia(inglês[10,1])
                                                                                                                                                   se (inglês[10,1] >=0) e (inglês[10,1]<= 10) então
                                                                                                                                                   repita
                                                                                                                                                      escreval ("Digite sua nota do terceiro bimestre em inglês:")
                                                                                                                                                      leia(inglês[10,2])
                                                                                                                                                      se (inglês[10,2] >=0) e (inglês[10,2]<= 10) então
                                                                                                                                                      repita
                                                                                                                                                         escreval ("Digite sua nota do quarto bimestre em inglês:")
                                                                                                                                                         leia(inglês[10,3])
                                                                                                                                                         se (inglês[10,3] >=0) e (inglês[10,3]<= 10) então
                                                                                                                                                         repita
                                                                                                                                                            escreval ("Digite sua nota do primeiro bimestre em literatura:")
                                                                                                                                                            leia(literatura[11,0])
                                                                                                                                                            se (literatura[11,0] >=0) e (literatura[11,0]<= 10) então
                                                                                                                                                            repita
                                                                                                                                                               escreval ("Digite sua nota do segundo bimestre em literatura:")
                                                                                                                                                               leia(literatura[11,1])
                                                                                                                                                               se  (literatura[11,1] >=0) e (literatura[11,1]<= 10) então
                                                                                                                                                               repita
                                                                                                                                                                  escreval ("Digite sua nota do terceiro bimestre em literatura:")
                                                                                                                                                                  leia(literatura[11,2])
                                                                                                                                                                  se  (literatura[11,2] >=0) e (literatura[11,2]<= 10) então
                                                                                                                                                                  repita
                                                                                                                                                                     escreval ("Digite sua nota do quarto bimestre em literatura:")
                                                                                                                                                                     leia (literatura[11,3])
                                                                                                                                                                     se  (literatura[11,3] >=0) e (literatura[11,3]<= 10) então
                                                                                                                                                                        se  (Matematica_soma e Portugues_soma e Filosofia_soma e Geografia_soma e Sociologia_soma e Educacao_fisica_soma e Fisica_soma e Biologia_soma e Religiao_soma e Quimica_soma e Ingles_soma e Literatura_soma >= 24) então
                                                                                                                                                                           escreva ("Você foi aprovado!!!")
                                                                                                                                                                        senao
                                                                                                                                                                           escreva ("Você foi reprovado!!!")
                                                                                                                                                                        fimse
                                                                                                                                                                     senao
                                                                                                                                                                        escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                                                                     fimse
                                                                                                                                                                     ate  (literatura[11,3] >=0) e (literatura[11,3])<= 10)
                                                                                                                                                                  senao
                                                                                                                                                                     escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                                                                  fimse
                                                                                                                                                                  ate  (literatura[11,2] >=0) e (literatura[11,2])<= 10)
                                                                                                                                                               senao
                                                                                                                                                                  escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                                                               fimse
                                                                                                                                                               ate (literatura[11,1] >=0) e (literatura[11,1])<= 10)
                                                                                                                                                            senao
                                                                                                                                                               escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                                                            fimse
                                                                                                                                                            ate (literatura[11,0] >=0) e (literatura[11,0])<= 10)
                                                                                                                                                         senao
                                                                                                                                                            escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                                                         fimse
                                                                                                                                                         ate (inglês[10,3] >=0) e (inglês[10,3])<= 10)
                                                                                                                                                         
                                                                                                                                                      senao
                                                                                                                                                         escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                                                      fimse
                                                                                                                                                      ate (inglês[10,2] >=0) e (inglês[10,2])<= 10)
                                                                                                                                                   senao
                                                                                                                                                      escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                                                   fimse
                                                                                                                                                   ate (inglês[10,1] >=0) e (inglês[10,1])<= 10)
                                                                                                                                                senao
                                                                                                                                                   escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                                                fimse
                                                                                                                                                ate  (inglês[10,0] >=0) e (inglês[10,0])<= 10)
                                                                                                                                             senao
                                                                                                                                                escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                                             fimse
                                                                                                                                             ate (quimica[9,3] >=0) e (quimica[9,3])<= 10)
                                                                                                                                          senao
                                                                                                                                             escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                                          fimse
                                                                                                                                          ate  (quimica[9,2] >=0) e (quimica[9,2])<= 10)
                                                                                                                                       senao
                                                                                                                                          escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                                       fimse
                                                                                                                                       ate (quimica[9,1] >=0) e (quimica[9,1])<= 10)
                                                                                                                                    senao
                                                                                                                                       escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                                    fimse
                                                                                                                                    ate (quimica[9,0] >=0) e (quimica[9,0])<= 10)
                                                                                                                                 senao
                                                                                                                                    escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                                 fimse
                                                                                                                                 ate (religiao[8,3] >=0) e (religiao[8,3])<= 10)
                                                                                                                              senao
                                                                                                                                 escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                              fimse
                                                                                                                              ate (religiao[8,2] >=0) e (religiao[8,2])<= 10)
                                                                                                                           senao
                                                                                                                              escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                           fimse
                                                                                                                           ate (religiao[8,1] >=0) e (religiao[8,1])<= 10)
                                                                                                                        senao
                                                                                                                           escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                        fimse
                                                                                                                        ate (religiao[8,0] >=0) e (religiao[8,0])<= 10)
                                                                                                                     senao
                                                                                                                        escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                     fimse
                                                                                                                     ate (biologia[7,3] >=0) e (biologia[7,3]<= 10)
                                                                                                                  senao
                                                                                                                     escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                                  fimse
                                                                                                                  ate (biologia[7,2] >=0) e (biologia[7,2]<= 10)
                                                                                                               senao
                                                                                                                  escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                               fimse
                                                                                                               ate (biologia[7,1] >=0) e (biologia[7,1]<= 10)
                                                                                                            senao
                                                                                                               escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                            fimse
                                                                                                            ate (biologia[7,0] >=0) e (biologia[7,0]<= 10)
                                                                                                         senao
                                                                                                            escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                         fimse
                                                                                                         ate (fisica[6,3] >=0) e (fisica[6,3]<= 10)
                                                                                                      senao
                                                                                                         escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                      fimse
                                                                                                      ate (fisica[6,2] >=0) e (fisica[6,2]<= 10)
                                                                                                   senao
                                                                                                      escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                   fimse
                                                                                                   ate (fisica[6,1] >=0) e (fisica[6,1]<= 10)
                                                                                                senao
                                                                                                   escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                                fimse
                                                                                                ate (fisica[6,0] >=0) e (fisica[6,0]<= 10)
                                                                                             senao
                                                                                                escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                             fimse
                                                                                             ate (educacao_fisica[5,3] >=0) e (educacao_fisica[5,3]<= 10)
                                                                                             
                                                                                          senao
                                                                                             escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                          fimse
                                                                                          ate (educacao_fisica[5,2] >=0) e (educacao_fisica[5,2]<= 10)
                                                                                          
                                                                                       senao
                                                                                          escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                       fimse
                                                                                       ate (educacao_fisica[5,1] >=0) e (educacao_fisica[5,1]<= 10)
                                                                                    senao
                                                                                       escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                    fimse
                                                                                 ate (educacao_fisica[5,0] >=0) e (educacao_fisica[5,0]<= 10)
                                                                                 senao
                                                                                    escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                                 fimse
                                                                              ate (sociologia[4,3] >=0) e (sociologia[4,3]<= 10)
                                                                              senao
                                                                                 escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                              fimse
                                                                              ate (sociologia[4,2] >=0) e (sociologia[4,2]<= 10)
                                                                           senao
                                                                              escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                           fimse
                                                                           ate (sociologia[4,1] >=0) e (sociologia[4,1]<= 10)
                                                                           
                                                                        senao
                                                                           escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                        fimse
                                                                        ate (sociologia[4,0] >=0) e (sociologia[4,0]<= 10)
                                                                     senao
                                                                        escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                     fimse
                                                                     ate (geografia[3,3] >=0) e (geografia[3,3]<= 10)
                                                                  senao
                                                                     escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                                  fimse
                                                                  ate (geografia[3,2] >=0) e (geografia[3,2]<= 10)
                                                               senao
                                                                  escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                               fimse
                                                               ate (geografia[3,1] >=0) e (geografia[3,1]<= 10)
                                                            senao
                                                               escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                            fimse
                                                            ate (geografia[3,0] >=0) e (geografia[3,0]<= 10)
                                                         senao
                                                            escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                         fimse
                                                         ate (filosofia[2,3] >=0) e (filosofia[2,3]<= 10)
                                                      senao
                                                         escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                      fimse
                                                      ate (filosofia[2,2] >=0) e (filosofia[2,2]<= 10)
                                                   senao
                                                      escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                   fimse
                                                   ate (filosofia[2,1] >=0) e (filosofia[2,1]<= 10)
                                                senao
                                                   escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                                fimse
                                                ate (filosofia[2,0] >=0) e (filosofia[2,0]<= 10)
                                             senao
                                                escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                             fimse
                                             ate (portugues[1,3] >=0) e (portugues[1,3]<= 10)
                                       senao
                                          escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                       fimse
                                       ate (portugues[1,2] >=0) e (portugues[1,2]<= 10)
                                 senao
                                    escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                                 fimse
                                 ate (portugues[1,1] >=0) e (portugues[1,1]<= 10)
                           senao
                              escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                           fimse
                           ate (portugues[1,0] >=0) e (portugues[1,0]<= 10)
                        senao
                           escreval ("Digite uma nota entre 0 e 10 e tente novamente")
                        fimse
                        ate (matematica[0,3] >=0) e (matematica[0,3]<= 10)
               senao
                  escreval ("Digite uma nota entre 0 e 10 e tente novamente")
               fimse
               ate (matematica[0,2] >=0) e (matematica[0,2]<= 10)
         senao
            escreval ("Digite uma nota entre 0 e 10 e tente novamente")
         fimse
         ate (matematica[0,1] >=0) e (matematica[0,1]<= 10)
   senao
      escreval ("Digite uma nota entre 0 e 10 e tente novamente")
   fimse
   ate (matematica[0,0] >=0) e (matematica[0,0]<= 10)

//Soma todas as notas dos bimestres de matematica
   Matematica_soma <- (matematica[0,0] + matematica[0,1] + matematica[0,2] + matematica[0,3])

//Soma todas as notas dos bimestres de portugues
   Portugues_soma <- (portugues[1,0] + portugues[1,1] + portugues[1,2] + portugues[1,3])

//Soma todas as notas dos bimestres de filosofia
   Filosofia_soma <- (filosofia[2,0] + filosofia[2,1] + filosofia[2,2] + filosofia[2,3])
   
//Soma todas as notas dos bimestres de geografia
   Geografia_soma <- (geografia[3,0] + geografia[3,1] + geografia[3,2] + geografia[3,3])

//Soma todas as notas dos bimestres de sociologia
   sociologia_soma <- (sociologia[4,0] + sociologia[4,1] + sociologia[4,2] + sociologia[4,3])
         
//Soma todas as notas dos bimestres de educacao fisica
   educacao_fisica_soma <- (educacao_fisica[5,0] + educacao_fisica[5,1] + educacao_fisica[5,2] + educacao_fisica[5,3])

//Soma todas as notas dos bimestres de fisica
   fisica_soma <- (fisica[6,0] + fisica[6,1] + fisica[6,2] + fisica[6,3])
   
//Soma todas as notas dos bimestres de biologia
   biologia_soma <- (biologia[7,0] + biologia[7,1] + biologia[7,2] + biologia[7,3])

//Soma todas as notas dos bimestres de religiao
   religiao_soma <- (religiao[8,0] + religiao[8,1] + religiao[8,2] + religiao[8,3])
   
//Soma todas as notas dos bimestres de quimica
   quimica_soma <- (quimica[9,0] + quimica[9,1] + quimica[9,2] + quimica[9,3])
   
//Soma todas as notas dos bimestres de inglês
   ingles_soma <- (inglês[10,0] + inglês[10,1] + inglês[10,2] + inglês[10,3])

//Soma todas as notas dos bimestres de literatura
    literatura_soma <- (literatura[11,0] + literatura[11,1] + literatura[11,2] + literatura[11,3])
fimalgoritmo

 

Editado por Simon Viegas
Inserir código no corpo; Inserir tag SPOILER (botão "olho") devido ao tamanho

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

Sobre:

Em 09/06/2018 às 12:58, Noob3304 disse:

Estou fazendo um pseudocódigo no Visualg e queria saber como eu peço para ele aceitar somente valores para variavel entre 0 e 10, podendo ser valores com vírgula também, e se o usuário digitar fora deste intervalo, escrever um aviso pedindo numeros dentro do intervalo.

 

Poderia usar um laço de repetição, que vai repetir até que o número seja maior igual a 0 e o número seja menor igual a 10. Dentro, coloca um se que também verifica a nota, ai, se nota não estiver nesse critério, exibe a mensagem.

 

 

 

adicionado 21 minutos depois

@Noob3304, antes de verificar essa questão de só aceitar entre 0 e 10, sugiro revisar a estrutura da base em si.

 

Por exemplo, no seu código tem essas variáveis:

1 hora atrás, Noob3304 disse:

   var
      Matematica : vetor [0..0,0..3] de real
      Portugues : vetor [1..1,0..3] de real
      Filosofia : vetor [2..2,0..3] de real
      Geografia : vetor [3..3,0..3] de real
      Sociologia : vetor [4..4,0..3] de real
      Educacao_Fisica : vetor [5..5,0..3] de real
      Fisica : vetor [6..6,0..3] de real
      Biologia : vetor [7..7,0..3] de real
      Religiao : vetor [8..8,0..3] de real
      Quimica : vetor [9..9,0..3] de real
      inglês: vetor [10..10,0..3] de real
      Literatura : vetor [11..11,0..3] de real
      Matematica_soma: real
      Portugues_soma: real
      Filosofia_soma: real
      Geografia_soma: real
      Sociologia_soma: real
      Educacao_fisica_soma: real
      Fisica_soma: real
      Biologia_soma: real
      Religiao_soma: real
      Quimica_soma: real
      Ingles_soma: real
      Literatura_soma: real

 

Por que as coordenadas estão 0..0, 1..1, 2..2 etc?

 

 

 

Sugiro o seguinte: poste o enunciado completo e o código sem a tentativa de implementar a verificação se está entre 0 e 10. Aí damos uma revisada.

 

No aguardo.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Realmente não precisava estar com variáveis bidimensionais, como estou aprendendo, queria utilizar, mais não foi uma boa escolha, pois só deu mais trabalho, agora arrumei.

Já falando de laço de repetição, eu fiz o código utilizando o ,repita,ate,se, como abaixo:

Algoritmo "parte do codigo"

Var
Matematica : vetor [0..3] de real

Inicio
repita
escreval ("Digite sua nota do primeiro bimeste em matematica:")
   leia (matematica[0])
   se (matematica[0] >=0) e (matematica[0]<= 10) então
      repita
         escreval ("Digite sua nota do segundo bimeste em matematica:")
         leia (matematica[1])
         se (matematica[1] >=0) e (matematica[1]<= 10) então
            repita
               escreval ("Digite sua nota do terceiro bimeste em matematica:")
               leia (matematica[2])
               se (matematica[2] >=0) e (matematica[2]<= 10) então
               repita
                     escreval ("Digite sua nota do quarto bimeste em matematica:")
                     leia (matematica[3])
                        se (matematica[3] >=0) e (matematica[3]<= 10) então

  	senao
    	escreval ("Digite uma nota entre 0 e 10 e tente novamente")
    fimse
    ate (matematica[3] >=0) e (matematica[3]<= 10)
         senao
         	escreval ("Digite uma nota entre 0 e 10 e tente novamente")
         fimse
         ate (matematica[2] >=0) e (matematica[2]<= 10)
         	senao
          		escreval ("Digite uma nota entre 0 e 10 e tente novamente")
            fimse
            ate (matematica[1] >=0) e (matematica[1]<= 10)
              senao
              	escreval ("Digite uma nota entre 0 e 10 e tente novamente")
              fimse
              ate (matematica[0] >=0) e (matematica[0]<= 10)


Fimalgoritmo

Tipo, você falou para usar laços de repetição, eu usei eles, teria uma forma mais fácil usando os mesmos?

 

Editado por Simon Viegas
Remover linhas em branco

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

 

1 hora atrás, Noob3304 disse:

Tipo, você falou para usar laços de repetição, eu usei eles, teria uma forma mais fácil usando os mesmos?

 

De um modo geral, teria que ser com laço de repetição mesmo...

 

 

Agora, para ler as notas da disciplina, poderia usar um laço de repetição também, ou seja, usar uma variável para controlar as posições do vetor, em vez de usar números diretamente.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 10/06/2018 às 17:50, Simon Viegas disse:

 

 

 

De um modo geral, teria que ser com laço de repetição mesmo...

 

 

Agora, para ler as notas da disciplina, poderia usar um laço de repetição também, ou seja, usar uma variável para controlar as posições do vetor, em vez de usar números diretamente.

Ótima ideia , tu poderias dar um exemplo de variável que controla as posições, que não tenho nem ideia como usar um laço de repetição nisso

Compartilhar este post


Link para o post
Compartilhar em outros sites
8 minutos atrás, Noob3304 disse:

Ótima ideia , tu poderias dar um exemplo de variável que controla as posições, que não tenho nem ideia como usar um laço de repetição nisso

 

Antes, faça o seguinte:

Em 10/06/2018 às 15:30, Simon Viegas disse:

[...] poste o enunciado completo e o código sem a tentativa de implementar a verificação se está entre 0 e 10. Aí damos uma revisada.

Editado por Simon Viegas

Compartilhar este post


Link para o post
Compartilhar em outros sites
10 minutos atrás, Simon Viegas disse:

 

Antes, faça o seguinte:

Lembro que tu tinhas falado isso, só que tipo, o código eu mandei já no txt e esse enunciado que não entendi...

Compartilhar este post


Link para o post
Compartilhar em outros sites
17 minutos atrás, Noob3304 disse:

Lembro que tu tinhas falado isso, só que tipo, o código eu mandei já no txt e esse enunciado que não entendi...

 

Pressuponha que todas as notas inseridas serão entre 0 e 10, ou seja, não sendo necessário verificar se a nota é válida.

 

A partir daí ajustar as variáveis que serão usadas para armazenar... Essa parte da verificação pode ficar para depois. (ela está atrapalhando)

Editado por Simon Viegas

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pera aí , acabei de ver que me equivoquei, já mando outra mensagem.

Editado por Noob3304

Compartilhar este post


Link para o post
Compartilhar em outros sites
10 minutos atrás, Noob3304 disse:

Ah entendi, por exemplo, sempre quando digitar algum número, ela armazena no primeiro "leia" que encontrar, então se entendi bem, em vez de colocar leia sempre após escreval , eu poderia coloca-lo numa parte só para estas vareáveis numa sequencia  logica, e outra parte para os "se" para não ter que colocar vários comandos um dentro do outro, acertei?

 

É por ai.

 

Mas basicamente o que estou propondo é "reorganizar as variáveis" antes de tudo. Para isso, ficará mais fácil reanalizando um código sem essa verificação de notas... estes deixaram o código muito poluído.

 

Então:

- poste o código sem a verificação de notas;

- tento reanalizar as estruturas para te passar algumas sugestões;

- após, só após, insere a parte de verificar se uma nota é válida na nova estrutura.

 

Ou seja, tentar fazer as duas coisas ao mesmo tempo não seria interessante...

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 minuto atrás, Simon Viegas disse:

 

É por ai.

 

Mas basicamente o que estou propondo é "reorganizar as variáveis" antes de tudo. Para isso, ficará mais fácil reanalizando um código sem essa verificação de notas... estes deixaram o código muito poluído.

 

Então:

- poste o código sem a verificação de notas;

- tento reanalizar as estruturas para te passar algumas sugestões;

- após, só após, insere a parte de verificar se uma nota é válida na nova estrutura.

 

Ou seja, tentar fazer as duas coisas ao mesmo tempo não seria interessante...

Ok , irei modifica-lo.

adicionado 26 minutos depois
Algoritmo "Codigo de notas sem verificação de intervalo"

Var
      Matematica : vetor [0..3] de real
      Portugues : vetor [0..3] de real
      Filosofia : vetor [0..3] de real
      Geografia : vetor [0..3] de real
      Sociologia : vetor [0..3] de real
      Educacao_Fisica : vetor [0..3] de real
      Fisica : vetor [0..3] de real
      Biologia : vetor [0..3] de real
      Religiao : vetor [0..3] de real
      Quimica : vetor [0..3] de real
      inglês: vetor [0..3] de real
      Literatura : vetor [0..3] de real
      Matematica_soma: real
      Portugues_soma: real
      Filosofia_soma: real
      Geografia_soma: real
      Sociologia_soma: real
      Educacao_fisica_soma: real
      Fisica_soma: real
      Biologia_soma: real
      Religiao_soma: real
      Quimica_soma: real
      Ingles_soma: real
      Literatura_soma: real
Inicio
// Matematica: Pede a nota em todos os 4 bimestre e armazena
   escreval ("Digite sua nota do 1 bimestre em matematica:")
   leia (matematica[0])
   escreval ("Digite sua nota do 2 bimestre em matematica:")
   leia (matematica[1])
   escreval ("Digite sua nota do 3 bimestre em matematica:")
   leia (matematica[2])
   escreval ("Digite sua nota do 4 bimestre em matematica:")
   leia (matematica[3])
   
//Portugues: Pede a nota em todos os 4 bimestre e armazena
   escreval ("Digite sua nota do 1 bimestre em portugues:")
   leia (portugues[0])
   escreval ("Digite sua nota do 2 bimestre em portugues:")
   leia (portugues[1])
   escreval ("Digite sua nota do 3 bimestre em portugues:")
   leia (portugues[2])
   escreval ("Digite sua nota do 4 bimestre em portugues:")
   leia (portugues[3])
   
//Filosofia: Pede a nota em todos os 4 bimestre e armazena
   escreval ("Digite sua nota do 1 bimestre em Filosofia:")
   leia (Filosofia[0])
   escreval ("Digite sua nota do 2 bimestre em Filosofia:")
   leia (Filosofia[1])
   escreval ("Digite sua nota do 3 bimestre em Filosofia:")
   leia (Filosofia[2])
   escreval ("Digite sua nota do 4 bimestre em Filosofia:")
   leia (Filosofia[3])
//Geografia: Pede a nota em todos os 4 bimestre e armazena
   escreval ("Digite sua nota do 1 bimestre em Geografia:")
   leia (Geografia[0])
   escreval ("Digite sua nota do 2 bimestre em Geografia:")
   leia (Geografia[1])
   escreval ("Digite sua nota do 3 bimestre em Geografia:")
   leia (Geografia[2])
   escreval ("Digite sua nota do 4 bimestre em Geografia:")
   leia (Geografia[3])
   
//Sociologia: Pede a nota em todos os 4 bimestre e armazena
   escreval ("Digite sua nota do 1 bimestre em Sociologia:")
   leia (Sociologia[0])
   escreval ("Digite sua nota do 2 bimestre em Sociologia:")
   leia (Sociologia[1])
   escreval ("Digite sua nota do 3 bimestre em Sociologia:")
   leia (Sociologia[2])
   escreval ("Digite sua nota do 4 bimestre em Sociologia:")
   leia (Sociologia[3])
   
   //Educacao_Fisica: Pede a nota em todos os 4 bimestre e armazena
   escreval ("Digite sua nota do 1 bimestre em Educacao_Fisica:")
   leia (Educacao_Fisica[0])
   escreval ("Digite sua nota do 2 bimestre em Educacao_Fisica:")
   leia (Educacao_Fisica[1])
   escreval ("Digite sua nota do 3 bimestre em Educacao_Fisica:")
   leia (Educacao_Fisica[2])
   escreval ("Digite sua nota do 4 bimestre em Educacao_Fisica:")
   leia (Educacao_Fisica[3])
   
   //Fisica: Pede a nota em todos os 4 bimestre e armazena
   escreval ("Digite sua nota do 1 bimestre em Fisica:")
   leia (Fisica[0])
   escreval ("Digite sua nota do 2 bimestre em Fisica:")
   leia (Fisica[1])
   escreval ("Digite sua nota do 3 bimestre em Fisica:")
   leia (Fisica[2])
   escreval ("Digite sua nota do 4 bimestre em Fisica:")
   leia (Fisica[3])
   
   //Religiao: Pede a nota em todos os 4 bimestre e armazena
   escreval ("Digite sua nota do 1 bimestre em Biologia:")
   leia (Biologia[0])
   escreval ("Digite sua nota do 2 bimestre em Biologia:")
   leia (Biologia[1])
   escreval ("Digite sua nota do 3 bimestre em Biologia:")
   leia (Biologia[2])
   escreval ("Digite sua nota do 4 bimestre em Biologia:")
   leia (Biologia[3])
   
   //Religiao: Pede a nota em todos os 4 bimestre e armazena
   escreval ("Digite sua nota do 1 bimestre em Religiao:")
   leia (Religiao[0])
   escreval ("Digite sua nota do 2 bimestre em Religiao:")
   leia (Religiao[1])
   escreval ("Digite sua nota do 3 bimestre em Religiao:")
   leia (Religiao[2])
   escreval ("Digite sua nota do 4 bimestre em Religiao:")
   leia (Religiao[3])
   
   //Quimica: Pede a nota em todos os 4 bimestre e armazena
   escreval ("Digite sua nota do 1 bimestre em Quimica:")
   leia (Quimica[0])
   escreval ("Digite sua nota do 2 bimestre em Quimica:")
   leia (Quimica[1])
   escreval ("Digite sua nota do 3 bimestre em Quimica:")
   leia (Quimica[2])
   escreval ("Digite sua nota do 4 bimestre em Quimica:")
   leia (Quimica[3])
   
   //inglês: Pede a nota em todos os 4 bimestre e armazena
   escreval ("Digite sua nota do 1 bimestre em inglês:")
   leia (inglês[0])
   escreval ("Digite sua nota do 2 bimestre em inglês:")
   leia (inglês[1])
   escreval ("Digite sua nota do 3 bimestre em inglês:")
   leia (inglês[2])
   escreval ("Digite sua nota do 4 bimestre em inglês:")
   leia (inglês[3])
   
   //Literatura: Pede a nota em todos os 4 bimestre e armazena
   escreval ("Digite sua nota do 1 bimestre em Literatura:")
   leia (Literatura[0])
   escreval ("Digite sua nota do 2 bimestre em Literatura:")
   leia (Literatura[1])
   escreval ("Digite sua nota do 3 bimestre em Literatura:")
   leia (Literatura[2])
   escreval ("Digite sua nota do 4 bimestre em Literatura:")
   leia (Literatura[3])
   
   //Soma todas as notas dos bimestres de matematica
   Matematica_soma <- (matematica[0] + matematica[1] + matematica[2] + matematica[3])

   //Soma todas as notas dos bimestres de portugues
   Portugues_soma <- (portugues[0] + portugues[1] + portugues[2] + portugues[3])

   //Soma todas as notas dos bimestres de filosofia
   Filosofia_soma <- (filosofia[0] + filosofia[1] + filosofia[2] + filosofia[3])

   //Soma todas as notas dos bimestres de geografia
   Geografia_soma <- (geografia[0] + geografia[1] + geografia[2] + geografia[3])

   //Soma todas as notas dos bimestres de sociologia
   sociologia_soma <- (sociologia[0] + sociologia[1] + sociologia[2] + sociologia[3])

   //Soma todas as notas dos bimestres de educacao fisica
   educacao_fisica_soma <- (educacao_fisica[0] + educacao_fisica[1] + educacao_fisica[2] + educacao_fisica[3])

   //Soma todas as notas dos bimestres de fisica
   fisica_soma <- (fisica[0] + fisica[1] + fisica[2] + fisica[3])

   //Soma todas as notas dos bimestres de biologia
   biologia_soma <- (biologia[0] + biologia[1] + biologia[2] + biologia[3])

   //Soma todas as notas dos bimestres de religiao
   religiao_soma <- (religiao[0] + religiao[1] + religiao[2] + religiao[3])

   //Soma todas as notas dos bimestres de quimica
   quimica_soma <- (quimica[0] + quimica[1] + quimica[2] + quimica[3])

   //Soma todas as notas dos bimestres de inglês
   ingles_soma <- (inglês[0] + inglês[1] + inglês[2] + inglês[3])

   //Soma todas as notas dos bimestres de literatura
    literatura_soma <- (literatura[0] + literatura[1] + literatura[2] + literatura[3])
   
   se  (Matematica_soma e Portugues_soma e Filosofia_soma e Geografia_soma e Sociologia_soma e Educacao_fisica_soma e Fisica_soma e Biologia_soma e Religiao_soma e Quimica_soma e Ingles_soma e Literatura_soma >= 24) então
      escreval ("Você foi aprovado")
   senao
      escreval ("Você foi reprovado")
   fimse
   

   

      


Fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

1#

Para ler as notas de uma mesma disciplina, pode fazer assim:

para i de 0 ate 3 faca
   // Matematica: Pede a nota em todos os 4 bimestre e armazena
   escreval ("Digite sua nota do 1 bimestre em matematica:")
   leia (matematica[i])
   escreval ("Digite sua nota do 2 bimestre em matematica:")
   leia (matematica[i])
   escreval ("Digite sua nota do 3 bimestre em matematica:")
   leia (matematica[i])
   escreval ("Digite sua nota do 4 bimestre em matematica:")
   leia (matematica[i])
   fimPara

 

 

 

2#

Em vez de usar vários vetores:

1 hora atrás, Noob3304 disse:

Var
   Matematica      :vetor [0..3] de real
   Portugues       :vetor [0..3] de real
   Filosofia       :vetor [0..3] de real
   Geografia       :vetor [0..3] de real
   Sociologia      :vetor [0..3] de real
   Educacao_Fisica :vetor [0..3] de real
   Fisica          :vetor [0..3] de real
   Biologia        :vetor [0..3] de real
   Religiao        :vetor [0..3] de real
   Quimica         :vetor [0..3] de real
   inglês          :vetor [0..3] de real
   Literatura      :vetor [0..3] de real

 

Poderia agrupá-los em uma matriz, ex.:

   Notas :vetor [0..11,0..3] de real //[Disciplica,Bimestre]

 

Para ler usaria algo como:

para numBimestre de 0 ate 3 faca
   // Matematica: Pede a nota em todos os 4 bimestre e armazena
   escreval("Digite sua nota do",numBimestre,"bimestre em matematica:")
   leia(Notas[0,numBimestre])
fimPara

 

 

 

***

 

 

Ai ajusta o restando do código para essas estruturas..

 

No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 11/06/2018 às 20:54, Simon Viegas disse:

1#

Para ler as notas de uma mesma disciplina, pode fazer assim:


para i de 0 ate 3 faca
   // Matematica: Pede a nota em todos os 4 bimestre e armazena
   escreval ("Digite sua nota do 1 bimestre em matematica:")
   leia (matematica[i])
   escreval ("Digite sua nota do 2 bimestre em matematica:")
   leia (matematica[i])
   escreval ("Digite sua nota do 3 bimestre em matematica:")
   leia (matematica[i])
   escreval ("Digite sua nota do 4 bimestre em matematica:")
   leia (matematica[i])
   fimPara

 

 

 

2#

Em vez de usar vários vetores:

 

Poderia agrupá-los em uma matriz, ex.:


   Notas :vetor [0..11,0..3] de real //[Disciplica,Bimestre]

 

Para ler usaria algo como:


para numBimestre de 0 ate 3 faca
   // Matematica: Pede a nota em todos os 4 bimestre e armazena
   escreval("Digite sua nota do",numBimestre,"bimestre em matematica:")
   leia(Notas[0,numBimestre])
fimPara

 

 

 

***

 

 

Ai ajusta o restando do código para essas estruturas..

 

No aguardo.

Tentei fazer isso de 2 formas diferentes e está dando erro nos 2, segue os 2 modos que estou colocando:

Algoritmo "Refazendo codigo com matriz"

Var
matriz: vetor [0..11,0..3] de real


inicio
para 0 de 0 ate 3 faca
   // Matematica: Pede a nota em todos os 4 bimestre e armazena
   escreval("Digite sua nota do",numBimestre,"bimestre em matematica:")
   leia(Notas[0,0])
fimPara
fimalgoritmo

 

Algoritmo "Refazendo codigo com matriz"

Var
matriz: vetor [0..11,0..3] de real


inicio
para matriz de 0 ate 3 faca
   // Matematica: Pede a nota em todos os 4 bimestre e armazena
   escreval("Digite sua nota do",numBimestre,"bimestre em matematica:")
   leia(Notas[0,0])
fimPara
fimalgoritmo

 

Editado por Simon Viegas
Separar os códigos
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

1#

Sobre:

28 minutos atrás, Noob3304 disse:

Tentei fazer isso de 2 formas diferentes e está dando erro nos 2, segue os 2 modos que estou colocando:

 

Ok. Para melhor exemplificação, segue código:

algoritmo "Refazendo codigo com matriz"
var
   notas             :vetor [0..11,0..3] de real //[Disciplica,Bimestre]
   nomesDisciplinas  :vetor [0..11] de caractere
   numBimestre   :inteiro
   codDisciplina :inteiro
   
inicio
nomesDisciplinas[ 0] <- "Matemática"
nomesDisciplinas[ 1] <- "Português"
nomesDisciplinas[ 2] <- "Filosofia"
nomesDisciplinas[ 3] <- "Geografia"
nomesDisciplinas[ 4] <- "Sociologia"
nomesDisciplinas[ 5] <- "Educacão Física"
nomesDisciplinas[ 6] <- "Física"
nomesDisciplinas[ 7] <- "Biologia"
nomesDisciplinas[ 8] <- "Religião"
nomesDisciplinas[ 9] <- "Química"
nomesDisciplinas[10] <- "inglês"
nomesDisciplinas[11] <- "Literatura"
para codDisciplina de 0 ate 11 faca //para cada um das disciplinas
   para numBimestre de 0 ate 3 faca //para cada um dos bimestres
      escreval("Digite sua nota do",numBimestre+1,"º bimestre em ",nomesDisciplinas[codDisciplina])
      leia(Notas[codDisciplina,numBimestre])
   fimPara
fimPara
fimAlgoritmo

 

 

Editado por Simon Viegas

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×