Ir ao conteúdo
  • Cadastre-se

Recommended Posts

Boa tarde, estou a umas 2 horas tentando identificar qual o erro desse código. Alguém pode me ajudar? ele tem como finalidade, comparar as questões dos alunos, contar a quantidade de acertos e dar as notas.

Algoritmo "Gabarito"
Var
   Gab : Vetor[1..5] de Caractere
   Nome: Vetor[1..3] de Caractere
   GabA: Vetor[1..5] de Caractere
   Nota: Vetor[1..3] de Real
   C : Inteiro
Inicio
      Escreval("-----------------------------")
      Escreval("Passo 1- Cadastro de gabarito")
      Escreval("-----------------------------")
      Para C <- 1 ate 5 Faca
           Escreva("Questão ",C,": ")
           Leia(Gab[C])
      Fimpara
      Limpatela
      Para C <- 1 ate 3 faca
           Escreval("-----------------------------")
           Escreval("            Aluno C          ")
           Escreval("-----------------------------")
           Escreva("Nome: ")
           Leia(Nome[C])
           Para C <- 1 ate 5 faca
                Escreva("Questao ",C,":")
                Leia(GabA[C])
                Se (GabA[C]= Gab[C]) então
                    Nota[c] <- Nota[c] + 2
                Fimse
           Fimpara
      Limpatela
      Fimpara
      Escreval("============")
      Escreval("Notas Finais")
      Escreval("============")
      Para C <- 1 Ate 3 faca
           Escreval(Nome[C],Nota[C])

      Fimpara
Fimalgoritmo

 

Editado por Simon Viegas
Inserir tag CODE

Compartilhar este post


Link para o post
Compartilhar em outros sites
10 minutos atrás, Luide Vqs disse:

Boa tarde, estou a umas 2 horas tentando identificar qual o erro desse código.

 

Se não sabe qual o erro, como sabe que está errado?

 

Tente explicar o que não está se comportando corretamente...

 

 

 

No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Simon Viegas bom, a itenção é que ele funcione assim: (min 37)

 

mas, ele simplesmente não funciona, ao colocar no visualg ele fecha por erro 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Por óbvio que não vamos assistir o vídeo todo para depois comparar com o seu código :)

 

6 minutos atrás, Luide Vqs disse:

mas, ele simplesmente não funciona, ao colocar no visualg ele fecha por erro 

Brincadeiras a parte: "que erro"?

 

 

 

 

 

 

adicionado 1 minuto depois

ADENDO: a ideia é que VOCÊ pare para entender o que ocorre, a partir daí analisar e tentar corrigir. Como não está conseguindo "corrigir", pelo menos tem que indicar o que está errado.

 

No aguardo.

Editado por Simon Viegas

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ele da um erro na linha 27 "Nota[c] <- Nota[c] + 2"  Nota[4] não encontrada, mas o que não faz nenhum sentido sendo estou desenvolvendo co base em 3 alunos e o vetor que coloquei tem 3 espaços porque é exatamente a nota de cada um.

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 minutos atrás, Luide Vqs disse:

Ele da um erro na linha 27 "Nota[c] <- Nota[c] + 2"  Nota[4] não encontrada, mas o que não faz nenhum sentido sendo estou desenvolvendo co base em 3 alunos e o vetor que coloquei tem 3 espaços porque é exatamente a nota de cada um.

 

Pronto! Então já sambemos que é algo no "posicionamento desse vetor". Ao analisar, verás que dentro do para do Aluno, tem outro para para as questões, certo? acontece que você usou a mesma variáveis nos 2. No pode! Use outra variável no para interno.

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×