Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  

Recommended Posts

Boa tarde, estou a umas 2 horas tentando identificar qual o erro desse código. Alguém pode me ajudar? ele tem como finalidade, comparar as questões dos alunos, contar a quantidade de acertos e dar as notas.

Algoritmo "Gabarito"
Var
   Gab : Vetor[1..5] de Caractere
   Nome: Vetor[1..3] de Caractere
   GabA: Vetor[1..5] de Caractere
   Nota: Vetor[1..3] de Real
   C : Inteiro
Inicio
      Escreval("-----------------------------")
      Escreval("Passo 1- Cadastro de gabarito")
      Escreval("-----------------------------")
      Para C <- 1 ate 5 Faca
           Escreva("Questão ",C,": ")
           Leia(Gab[C])
      Fimpara
      Limpatela
      Para C <- 1 ate 3 faca
           Escreval("-----------------------------")
           Escreval("            Aluno C          ")
           Escreval("-----------------------------")
           Escreva("Nome: ")
           Leia(Nome[C])
           Para C <- 1 ate 5 faca
                Escreva("Questao ",C,":")
                Leia(GabA[C])
                Se (GabA[C]= Gab[C]) então
                    Nota[c] <- Nota[c] + 2
                Fimse
           Fimpara
      Limpatela
      Fimpara
      Escreval("============")
      Escreval("Notas Finais")
      Escreval("============")
      Para C <- 1 Ate 3 faca
           Escreval(Nome[C],Nota[C])

      Fimpara
Fimalgoritmo

 

Editado por Simon Viegas
Inserir tag CODE

Compartilhar este post


Link para o post
Compartilhar em outros sites
10 minutos atrás, Luide Vqs disse:

Boa tarde, estou a umas 2 horas tentando identificar qual o erro desse código.

 

Se não sabe qual o erro, como sabe que está errado?

 

Tente explicar o que não está se comportando corretamente...

 

 

 

No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Simon Viegas bom, a itenção é que ele funcione assim: (min 37)

 

mas, ele simplesmente não funciona, ao colocar no visualg ele fecha por erro 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Por óbvio que não vamos assistir o vídeo todo para depois comparar com o seu código :)

 

6 minutos atrás, Luide Vqs disse:

mas, ele simplesmente não funciona, ao colocar no visualg ele fecha por erro 

Brincadeiras a parte: "que erro"?

 

 

 

 

 

 

adicionado 1 minuto depois

ADENDO: a ideia é que VOCÊ pare para entender o que ocorre, a partir daí analisar e tentar corrigir. Como não está conseguindo "corrigir", pelo menos tem que indicar o que está errado.

 

No aguardo.

Editado por Simon Viegas

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ele da um erro na linha 27 "Nota[c] <- Nota[c] + 2"  Nota[4] não encontrada, mas o que não faz nenhum sentido sendo estou desenvolvendo co base em 3 alunos e o vetor que coloquei tem 3 espaços porque é exatamente a nota de cada um.

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 minutos atrás, Luide Vqs disse:

Ele da um erro na linha 27 "Nota[c] <- Nota[c] + 2"  Nota[4] não encontrada, mas o que não faz nenhum sentido sendo estou desenvolvendo co base em 3 alunos e o vetor que coloquei tem 3 espaços porque é exatamente a nota de cada um.

 

Pronto! Então já sambemos que é algo no "posicionamento desse vetor". Ao analisar, verás que dentro do para do Aluno, tem outro para para as questões, certo? acontece que você usou a mesma variáveis nos 2. No pode! Use outra variável no para interno.

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Esse era realmente o problema, muito obrigado. Não sabia mais o que fazer sz

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×