Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Luide Vqs

Portugol Apagando rápido de mais

Recommended Posts

Olha eu de novo novamente, boa noite, juro q tentei resolver o problema mas não consegui, quando eu escolho os casos de 1 a 4, o "Desenho" aparece e apaga mt rápido, como posso resolver isso?

algoritmo "semnome"
var
   M:Vetor[1..4, 1..4] de inteiro
   R,L,C:Inteiro
Procedimento Matriz()
inicio
      Para L <- 1 ate 4 faca
           Para C <- 1 ate 4 faca
                Escreva(M[L,C]:4)
           Fimpara
         Escreval()
      Fimpara
Fimprocedimento
Procedimento Diagonal()
Inicio
      Para L <- 1 ate 4 faca
          Para C <- 1 ate 4 faca
              Se (L=C) então
                Escreva(M[L,C]:4)
              Senao
                Escreva("":4)
              Fimse
          Fimpara
       Escreval()
      Fimpara
Fimprocedimento
Procedimento Superior()
Inicio
      Para L <- 1 ate 4 faca
           Para C <- 1 ate 4 faca
                Se (L<C) então
                   Escreva(M[L,C]:4)
                Senao
                   Escreva("":4)
                Fimse
           Fimpara
        Escreval()
      Fimpara
Fimprocedimento
Procedimento Inferior()
Inicio
      Para L <- 1 ate 4 faca
           Para C <- 1 ate 4 faca
                Se (L>C) então
                    Escreva(M[L,C]:4)
                Senao
                    Escreva("":4)
                Fimse
           Fimpara
           Escreval()
      Fimpara
Fimprocedimento
inicio
      Para L <- 1 ate 4 faca
           Para C <- 1 ate 4 faca
                Escreva("Digite o valor da posição [",L,",",C,"]")
                Leia(M[L,C])
           Fimpara
      Fimpara
      Limpatela
      Repita
            Limpatela
            Escreval("=====================")
            Escreval("    Menu De Opções   ")
            Escreval("=====================")
            Escreval("[1]Mostrar a Matriz  ")
            Escreval("[2]Diagonal Principal")
            Escreval("[3]Triangulo Superior")
            Escreval("[4]Triangulo Inferior")
            Escreval("[5]Sair")
            Escreva("Escolha: ")
            Leia(R)
            Escolha R
            Caso 1
                 Matriz()
            Caso 2
                 Diagonal()
            Caso 3
                 Superior()
            Caso 4
                 Inferior()
      Limpatela
      FimEscolha
      Ate (R = 5)
fimalgoritmo

 

Editado por Simon Viegas
Ao postar um código utilize a tag CODE (botao <>)
  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
9 minutos atrás, Luide Vqs disse:

o "Desenho" aparece e apaga mt rápido

Coloque para ler alguma variável ali depois fimEscolha.

 

Obs.: esse limpaTela em cima do fimEscolha está dentro do Caso 4... da forma que indentou, parece que fora, mas não tá.

 

Qualquer coisa pressione CTRL+G para reindentar.

adicionado 2 minutos depois

... o ao tentar ler, vai travar o programa até que seja pressionado ENTER. É apenas para aproveitar essa característica

... apenas apague esse limpaTela. Não é necessário.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

ja apaguei ele, o problema continuou, fiz uma gambiarra aqui e parece que deu certo

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
agora, Luide Vqs disse:

ja apaguei ele, o problema continuou, fiz uma gambiarra aqui e parece que deu certo

 

São 3 fatos distintos!

 

1-

6 minutos atrás, Simon Viegas disse:

Coloque para ler alguma variável ali depois fimEscolha.

Isso vai resolver o problema de sumir;

 

2-

Independente da questão acima, o limparTela está fora do lugar... ele está dentro do Caso 4, se sua intenção era limpar a tela após cada impressão, teria que fica após o fimEscolha. Como dito, pressione CTRL+G no código original e verás onde deveria ficar...

 

3-

Independente de tá no lugar errado, ele não é necessário, pois já tem um lá em cima... apenas apague essa linha.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia amigos, sou iniciante em Visualg (Algoritmo) pelo que verifiquei o LIMPATELA que esta dentro do laço abaixo do comando repita é o causador de mostrar rápido e acaba apagando, coloca um // no inicio ou pode apagar direto.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×