Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
bruningomes17

Visual Basic Visualg - estudando logística de programação

Recommended Posts

Bom dia!

 

Estou começando a estudar logica de programação, e quando tento escrever um algorítimo usando as funções "se" e "caso", estou encontrando algumas dificuldades, no exercício em questlao seria um calculo de média de KILL de um jogo, o calculo funciona normalmente, mas por algum motivo eu não consigo fazer o algorítimo realizar uma "escolha caso" o valor de negativo, segue abaixo o código, espero que alguém possa me ajudar a identificar o erro. 

 

var
   MT, MO, M: Real
inicio
      Escreval ("==================")
      Escreval ("       KILL       ")
      Escreval ("==================")
      Escreva ("Quantos personagens você matol? ")
      Leia (MT)
      Escreva ("Quantas vezes te mataram? ")
      Leia (MO)
      M <- MT-MO
      Escreval (" sua media de KILL é ", M)
      Escreval ("==================")
      Se (M>=1) e (M<=10) então
      Escolha (M)
              Caso 1, 2, 3, 4, 5
              Escreval ("Você esta indo bem!")
              Caso 6, 7, 8, 9, 10
              Escreval ("Você esta otimo!")
      Senao
           Se (M>10) então
           Escreval ("Você esta joganndo muito bem")
           Senao
                Se (M<=0) e (M<=-10) então
                Escolha (M)
                        Caso -1, -2, -3, -4, -5
                        Escreval ("Sua média esta negativa, isso não e bom.")
                        Caso -6, -7, -8, -9, -10
                        Escreval ("voce esta indo muito mau")
                Senao
                     Se (M<=-10) então
                     Escreval ("Você devia tentar jogar outro jogo.")
                     Fimse
                        Fimescolha
                Fimse
           Fimse
              Fimescolha
      Fimse
      Escreval ("==================")
fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×