Ir ao conteúdo
  • Cadastre-se
DwSExcalibur

Outro Alguem poderia me ajudar com esse programa (Em portugol)

Recommended Posts


Para esta atividade queremos que você exercite o conteúdo que está sendo apresentado na disciplina. Sendo assim: Escreva um algoritmo que faça a entrevista de 20 pessoas.


Seu algoritmo em Portugol deve conter os seguintes requisitos: 
I. Realizar a leitura dos seguintes dados, para cada uma das 20 pessoas:
   - Nome.
   - Idade.
   - Sexo.
   - Quantidade de filhos.
   - Renda mensal familiar.

Obs.: Sair do laço de repetição se um nome não for preenchido, mesmo se não atingir 20 pessoas.

II. Com base nos dados coletados, apresente na tela as seguintes informações:
     - Percentual de mulheres e homens.
     - Número de pessoas com renda familiar de 500.00 (quinhentos reais) ou acima.
     - Percentual de pessoas que tem ao menos 1 filho.
     - Número de pessoas que nasceram a partir do ano 2000.

 

 - Utilize o programa VisulG 
- A atividade deve ser realizada utilizando o pseudocódigo Portugol (português estruturado).

 

Segue o pragrama que eu fiz  porém estou com uma duvida na linha  ,enquanto (cont < 2) ou (nome <>   "  ") faca,  acontece um erro minha duvida e como fazer uma variável caracter receber nada (vazio) quando o usuário não digitar

Algoritmo "mapa"

Var
  nome: caracter
  idade: inteiro
  nasc: inteiro
  sexo: inteiro
  h:real
  m:real
  percenth: real
  percentm: real
  percentf: real
  filhos: inteiro
  f:inteiro
  renda: real
  r:inteiro
  cont : inteiro
  vazio : caracter

Inicio
    cont <- 0
    h<-0
    m<-0
    f<-0
    r<-0

 enquanto (cont < 2) ou (nome <>   "  ") faca

 escreva ("Escreva seu nome: ")
 leia(nome)
 se (nome = " " ) então
 interrompa
 fimse
 escreva ("Escreva sua idade: ")
 leia (idade)
  se (idade <= 18) então
   nasc <- (nasc + 1)
 fimse
 escreva ("Qual e o seu sexo? homem digite(1) mulher digite(2): ")
 leia (sexo)
  se (sexo = 2) então
   m <- (m + 1)
   senao
    m <- (m+0)
  fimse
   se (sexo = 1) então
    h <- (h+1)
     senao
     h <- (h+0)
 fimse
 escreva ("Escreva quantos filhos tem: ")
 leia (filhos)
  se (filhos >= 1) então
   f <- (f + 1)
 fimse
 escreva ("Qual e sua renda:")
 leia (renda)
  se (renda >= 500) então
   r <- (r + 1)
 fimse

 cont <- (cont+1)

 fimenquanto
 
 percenth <- ((h / 2)*100)
 percentm <- ((m / 2)*100)
 percentf <- ((f/2) * 100)
 escreval(" O numero de pessoas nascidas a partir de 2000 e: " , nasc)
 escreval(" O percentural de homens e: ", percenth , "%")
 escreval(" O percentual de mulheres e:" , percentm , "%")
 escreval(" O numero de pessoas com renda maior que 500 e: ", r)
 escreval(" O percentural de filhos e: ", percentf, "%" )


Fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro usuário,

 

Seja bem-vindo ao Fórum do Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a resposta está correta ou não, ou para que possa ser auxiliado com a dúvida no desenvolvimento do exercício.

 

Infelizmente, não há como resolver os trabalhos pelos usuários. O objetivo do Fórum do Clube do Hardware é auxiliar seus usuários a encontrar soluções para que possam sanar suas dúvidas, e não de trazer soluções prontas para seus usuários.. Além disso, copiar e colar respostas que não são de autoria própria do qualquer usuário é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×