Ir ao conteúdo
  • Cadastre-se
Rosaly de Rezende

Excel formula para trazer a data mais antiga

Recommended Posts

Bom dia, @Rosaly de Rezende

 

Para fazer o que você deseja com formulas, a planilha irá ficar pesada e os cálculos demorados para serem processados.

 

Na célula F2 --> copie e cole a formula abaixo e depois arraste até a última linha com dados,

(Ela vai retornar a data como data, pois na coluna C ela consta como texto e o Excel não consegue utilizar nas formulas)

=DATA.VALOR(C2)

Na célula G2 copie a cole a formula abaixo, que irá retornar os códigos de produtos sem repetidos

=SEERRO(ÍNDICE($A$2:$A$33334;CORRESP(0;ÍNDICE(CONT.SE($G$1:G1;$A$2:$A$33334););));"")

Na célula H2 --> copie e cole a formula abaixo que irá retornar a maior data para o código da coluna F:

=MÁXIMO(SE($A$2:$A$33334=G2;$F$2:$F$33334))

A formula da coluna H é matricial, portanto, após colar a formula na célula, clique em F2 depois em CTRL+SHIFT+ENTER, que serão automaticamente, inseridas chaves no inicio e no final da fórmula.

A fórmula da coluna G só deverá ser arrastada até quando houver códigos, pois como não tem repetidos, o número de linhas é bem inferior.

Formate como com formato datas as colunas F2 e H2

 

Não se esqueça de clicar em Curtir.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×